FOG client under Ubuntu 18.04. Authentication ERROR: Could not authenticate


  • Developer

    Hi,
    I am updating my Ubuntu 18.04 image and I see that the FOG client is not working fine.

    OS: Ubuntu 18.04
    FOG Client: 0.11.16

    13/06/2019 17:50 Middleware::Communication URL: http://xxxx.eus/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     13/06/2019 17:50 Middleware::Response Success
     13/06/2019 17:50 Middleware::Communication URL: http://xxxx.eus/fog/management/index.php?sub=requestClientInfo&mac=94:57:A5:ED:DE:E1&newService&json
     13/06/2019 17:50 Middleware::Authentication Waiting for authentication timeout to pass
     13/06/2019 17:50 Middleware::Communication Download: http://xxxx.eus/fog/management/other/ssl/srvpublic.crt
     13/06/2019 17:50 Middleware::Authentication ERROR: Could not authenticate
     13/06/2019 17:50 Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority
     13/06/2019 17:50 Middleware::Response Success
     13/06/2019 17:50 Middleware::Communication URL: http://xxxx.eus/fog/service/getversion.php?clientver&newService&json
     13/06/2019 17:50 Middleware::Communication URL: http://xxxx.eus/fog/service/getversion.php?newService&json
    
     13/06/2019 17:50 Service Creating user agent cache
     13/06/2019 17:50 Middleware::Response ERROR: Unable to get subsection
     13/06/2019 17:50 Middleware::Response ERROR: Object reference not set to an instance of an object
     13/06/2019 17:50 Middleware::Response ERROR: Unable to get subsection
     13/06/2019 17:50 Middleware::Response ERROR: Object reference not set to an instance of an object
     13/06/2019 17:50 Middleware::Response ERROR: Unable to get subsection
     13/06/2019 17:50 Middleware::Response ERROR: Object reference not set to an instance of an object
    

    The mono version in the client is the 4.

    # dpkg -l | grep "ii  mono"
    ii  mono-4.0-gac                                                     4.6.2.7+dfsg-1ubuntu1                       all          Mono GAC tool (for CLI 4.0)
    ii  mono-4.0-service                                                 4.6.2.7+dfsg-1ubuntu1                       all          Mono service manager for CLI 4.0
    ii  mono-complete                                                    4.6.2.7+dfsg-1ubuntu1                       amd64        complete Mono runtime, development tools and all libraries
    ii  mono-csharp-shell                                                4.6.2.7+dfsg-1ubuntu1                       all          interactive C# shell
    ii  mono-devel                                                       4.6.2.7+dfsg-1ubuntu1                       all          Mono development tools
    ii  mono-gac                                                         4.6.2.7+dfsg-1ubuntu1                       all          Mono GAC tool
    ii  mono-jay                                                         4.6.2.7+dfsg-1ubuntu1                       amd64        LALR(1) parser generator oriented to Java/CLI
    ii  mono-mcs                                                         4.6.2.7+dfsg-1ubuntu1                       all          Mono C# 2.0 / 3.0 / 4.0 / 5.0  compiler for CLI 2.0 / 4.0 / 4.5
    ii  mono-runtime                                                     4.6.2.7+dfsg-1ubuntu1                       amd64        Mono runtime - default version
    ii  mono-runtime-common                                              4.6.2.7+dfsg-1ubuntu1                       amd64        Mono runtime - common files
    ii  mono-runtime-sgen                                                4.6.2.7+dfsg-1ubuntu1                       amd64        Mono runtime - SGen
    ii  mono-utils                                                       4.6.2.7+dfsg-1ubuntu1                       amd64        Mono utilities
    ii  mono-xbuild                                                      4.6.2.7+dfsg-1ubuntu1                       all          MSBuild-compatible build system for Mono
    ii  mono-xsp4                                                        4.2-2.1                                     all          simple web server to run ASP.NET 4.0 applications
    ii  mono-xsp4-base                                                   4.2-2.1                                     all          base libraries for XSP 4.0
    ii  monodoc-base                                                     4.6.2.7+dfsg-1ubuntu1                       all          shared MonoDoc binaries
    ii  monodoc-http                                                     4.2-2.2                                     all          MonoDoc http based viewer
    ii  monodoc-manual                                                   4.6.2.7+dfsg-1ubuntu1                       all          compiled XML documentation from the Mono project
    
    

    Any ideas?


  • Developer

    @Fernando-Gietz Just found this. Hope you got to test this at all. I am going to mark this fixed now.


  • Developer


  • Developer

    @Fernando-Gietz Back to work now but will try to grab a copy of the Zazzles.dll for you some time today or in the evening.


  • Developer

    @Sebastian-Roth Can you send me the zazzles files? the link of the previous post is obsolete


  • Developer


Log in to reply
 

516
Online

6.2k
Users

13.6k
Topics

128.2k
Posts