Multi-Task Problem


  • Developer

    The problem is that the multicastSession is not created ( I am very clever boy XD) but we dont know the reason of this behaviour.

    Any errors in the php log?



  • @Sebastian-Roth

    MariaDB [fog]> SELECT * FROM multicastSessionsAssoc;
    +-------+------+-----+
    | msaID | msID | tID |
    +-------+------+-----+
    |    57 |    0 |  87 |
    |    56 |    0 |  86 |
    |    55 |    0 |  85 |
    |    54 |    0 |  84 |
    |    53 |    0 |  83 |
    |    52 |    0 |  82 |
    |    51 |    0 |  81 |
    |    50 |    0 |  80 |
    |    49 |    0 |  79 |
    |    48 |    0 |  78 |
    |    47 |    0 |  77 |
    |    46 |    0 |  76 |
    |    45 |    0 |  75 |
    |    44 |    0 |  74 |
    |    43 |    0 |  73 |
    |    42 |    0 |  72 |
    |    41 |    0 |  71 |
    |    40 |    0 |  70 |
    |    39 |    0 |  69 |
    |    38 |    0 |  68 |
    |    37 |    0 |  67 |
    |    36 |    0 |  66 |
    |    35 |    0 |  65 |
    |    34 |    0 |  64 |
    |    33 |    0 |  63 |
    |    32 |    0 |  62 |
    |    31 |    0 |  61 |
    |    30 |    0 |  60 |
    +-------+------+-----+
    28 rows in set (0.00 sec)
    
    MariaDB [fog]> 
    


  • @Sebastian-Roth

    [jgill@fogserver log]$ systemctl status FOGMulticastManager
    ● FOGMulticastManager.service - FOGMulticastManager
       Loaded: loaded (/usr/lib/systemd/system/FOGMulticastManager.service; enabled; vendor preset: disabled)
       Active: active (running) since Wed 2019-06-12 09:22:41 MDT; 1h 31min ago
     Main PID: 5610 (FOGMulticastMan)
       CGroup: /system.slice/FOGMulticastManager.service
               ├─5610 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager &
               └─5613 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager &
    
    Jun 12 09:22:41 fogserver.bhs.tn systemd[1]: Started FOGMulticastManager.
    [jgill@fogserver log]$ 
    

  • Developer

    @Joe-Gill First make sure the multicast service is actually running: systemctl status FOGMulticastManager

    You are on the right track here. Try this: SELECT * FROM multicastSessionsAssoc;





  • @Fernando-Gietz

    MariaDB [fog]> SELECT * FROM multicastSessions;
    Empty set (0.00 sec)
    
    MariaDB [fog]> SELECT * FROM multicastAssoc;
    ERROR 1146 (42S02): Table 'fog.multicastAssoc' doesn't exist
    MariaDB [fog]> 
    
    

  • Developer

    And in the database appears?
    See the multicastSessions and MulticastSessionAssoc

    If you go to the Active Tasks page, the multicast tasks appears?



  • @Sebastian-Roth
    @Fernando-Gietz

    Here is the latest…

    [jgill@fogserver log]$ ls -lar
    total 80
    -rw-r--r--. 1 root root  4056 Jun 12 09:22 servicemaster.log
    -rw-r--r--. 1 root root  1433 Jun 12 09:31 pinghost.log
    -rw-r--r--. 1 root root  3471 Jun 12 09:31 multicast.log
    -rw-r--r--. 1 root root 28408 Jun 12 09:22 groupmanager.log
    -rw-r--r--. 1 root root  7770 Jun 12 09:22 fogsnapinrep.log
    -rw-r--r--. 1 root root  4559 Jun 12 09:22 fogsnapinhash.log
    -rw-r--r--. 1 root root  1812 Jun 12 09:30 fogscheduler.log
    -rw-r--r--. 1 root root  8714 Jun 12 09:22 fogreplicator.log
    -rw-r--r--. 1 root root  4462 Jun 12 09:22 fogimagesize.log
    drwxr-xr-x. 5 root root    67 Jun 12 09:23 ..
    drwxr-xr-x. 2 root root   218 Jun 12 09:22 .
    [jgill@fogserver log]$ 
    
    06-12-19 9:22:41 am]
    ==================================
    ===        ====    =====      ====
    ===  =========  ==  ===   ==   ===
    ===  ========  ====  ==  ====  ===
    ===  ========  ====  ==  =========
    ===	 ====  ====  ==  =========
    ===  ========  ====  ==  ===   ===
    ===  ========  ====  ==  ====  ===
    ===  =========  ==  ===   ==   ===
    ===  ==========    =====      ====
    ==================================
    ===== Free Opensource Ghost ======
    ==================================
    ============ Credits =============
    = https://fogproject.org/Credits =
    ==================================
    == Released under GPL Version 3 ==
    ==================================
    
    
    [06-12-19 9:22:41 am] Interface Ready with IP Address: 127.0.0.1
    [06-12-19 9:22:41 am] Interface Ready with IP Address: 127.0.1.1
    [06-12-19 9:22:41 am] Interface Ready with IP Address: 172.16.1.19
    [06-12-19 9:22:41 am] Interface Ready with IP Address: fogserver.bhs.tn
    [06-12-19 9:22:41 am]  * Starting MulticastManager Service
    [06-12-19 9:22:41 am]  * Checking for new items every 10 seconds
    [06-12-19 9:22:41 am]  * Starting service loop
    [06-12-19 9:22:41 am]  * No new tasks found
    [06-12-19 9:22:51 am]  * No new tasks found
    [06-12-19 9:23:01 am]  * No new tasks found
    [06-12-19 9:23:11 am]  * No new tasks found
    [06-12-19 9:23:21 am]  * No new tasks found
    [06-12-19 9:23:31 am]  * No new tasks found
    [06-12-19 9:23:41 am]  * No new tasks found
    [06-12-19 9:23:51 am]  * No new tasks found
    [06-12-19 9:24:01 am]  * No new tasks found
    [06-12-19 9:24:11 am]  * No new tasks found
    [06-12-19 9:24:21 am]  * No new tasks found
    [06-12-19 9:24:31 am]  * No new tasks found
    [06-12-19 9:24:42 am]  * No new tasks found
    [06-12-19 9:24:52 am]  * No new tasks found
    [06-12-19 9:25:02 am]  * No new tasks found
    [06-12-19 9:25:12 am]  * No new tasks found
    [06-12-19 9:25:22 am]  * No new tasks found
    
    

    Nothing is showing up in the logs at all.

    And from the web interface…

    Screenshot from 2019-06-12 09-34-06.png



  • @Fernando-Gietz
    @Sebastian-Roth

    Well the problem persists on the new server… Multicast.log shows no new tasks and zero multicast.log.udpcstxxxx files in the /opt/fog/log directory. I’m betting the database issues persist on. I’ll be in first thing tomorrow morning. (7AM MST)

    Cheers!



  • @Fernando-Gietz

    What shows up in the UDP log is from over a year ago when I messed with multi-cast last. I am working on building a new server.

    Thanks!


  • Developer

    And the log of the multicast tasks?
    /opt/fog/log/multicast.log.udpcastxxxx
    Where xxxx is the ID of the multicast tasks.



  • @Sebastian-Roth

    Yes. It shows up there like normal. Just nothing in the log.


  • Developer

    @Joe-Gill Do you actually see the multicast task in the web UI? How do you schedule the multicast task? Please tell us the exact steps you do scheduling the task so we might be able to understand and reproduce your issue.



  • @Sebastian-Roth Any ideas here?


Log in to reply
 

337
Online

6.4k
Users

13.8k
Topics

130.3k
Posts