Failed to download kernel, init and fog-client binaries...



  • Hey guys,

    i´ve tried to set up a FOG Server on Debian 9 today which didn´t quite work out well. The Server has two NICs which are used for (1) Imaging Network and (2) Connection to the Internet. (We have a proxy server btw. and i already tried all the solutions posted on here)

    As for the installation of FOG:
    1st I used GIT pull to get it onto my server
    2nd Ran the installation process with “sudo ./installfog.sh”, but it´s stuck right there
    3rd I went to the forum and checked out the possible issues with the proxy server
    -> changes to the /etc/bashrc file.
    -> run the install.sh with “no_proxy=“localhost”” etc…

    So i´d really appreciate your help!

    305b663b-a62e-4019-8628-eb4a143198d5-image.png


  • Senior Developer

    @MFuchs135 Please run the following commands and post a picture of that here:

    sudo -i
    cd /home/user/FOG-Imaging-Server/tmp
    ls -al
    cat binaries1.5.6.zip.sha256
    


  • @Sebastian-Roth I tried a few times before and i thought it worked, but now i get this message, besides curl showing the download finished successfully.! c005a24f-d333-4b7c-b225-f4f605662323-image.png
    (if you don´t speak german it shows “no correctly formatted sha256-checksumline was found”)


  • Senior Developer

    @MFuchs135 Please try running this command to see if it properly returns on success: sha256sum --check binaries1.5.6.zip.sha256 ; echo $?

    Take a picture of the output and post here.



  • @Sebastian-Roth i already mentioned in my EDIT, that i manually verified the checksum, which worked flawlessly. I am so confused right now…


  • Senior Developer

    @MFuchs135 said in Failed to download kernel, init and fog-client binaries...:

    could not download binaries1.5.6.zip properly

    This message means that the installer was not able to verify the checksum. Plesae run the following and post output here:

    cd fogproject/tmp
    sha256sum --check binaries1.5.6.zip.sha256
    

    PS: Sorry for the misspelled curl commands. I just fixed that so other people won’t run into it as well.



  • @Sebastian-Roth Dear Sebastian,

    i managed to get my curl working with the proxy flawlessly and if i execute the commands above with a space between the -kOL switch and the URL i can download them manually with no problem, but i can´t verify the SHA256 checksum and following error occurs: “no correct formatted SHA256Checksum was found”

    Did you copy the commands from the installer itself or did you just write it down? Because if i try them without the spaces it redirects me to the curl help-page.

    EDIT: after i deleted the old files in the tmp folder and tried the download with the installer again it downloaded the two files without a problem and the manual verification with the sha256 checksum also did not show any errors, but the installer still stops and shows the error : "could not download binaries1.5.6.zip properly…

    Thanks in advance


  • Senior Developer

    @Wayne-Workman Sure, good point!

    @MFuchs135 This is what the installer does at this point (I guess you are using the latest release version 15…6 with git and not the development branch dev-branch😞

    cd fogproject/tmp
    curl -kOL https://fogproject.org/binaries1.5.6.zip
    curl -kOL https://fogproject.org/binaries1.5.6.zip.sha256
    sha256sum --check binaries1.5.6.zip.sha256
    


  • @moderators @developers is there a curl or wget command he could run to attempt to manually download the latest init? Doing this manually may more directly reveal any potential problems.


  • Senior Developer

    @MFuchs135 said in Failed to download kernel, init and fog-client binaries...:

    We have a proxy server btw. and i already tried all the solutions posted on here

    What do you mean by “tried all the solutions posted here”?? Please be more specific. Post the exact URLs of forum posts you read and tried things from. If we don’t know what exactly you tried we can’t help you.


Log in to reply
 

405
Online

7.4k
Users

14.5k
Topics

136.8k
Posts