Fog 1.5.5 - Snapin replication loop


  • Testers

    I am having issues with the snapins replicating over and over, here is a snippet of the logs.

    03-05-19 3:55:58 pm]  | Started sync for Snapin 01a - BAY-Teamviewer - Resource id #375436
    [03-05-19 3:55:58 pm]   # 01a - BAY-Teamviewer: File does not exist optfogsnapinsTeamViewer-Bay.sfx.exe (13Storage)
    [03-05-19 3:55:58 pm]   # 01a - BAY-Teamviewer: File does not exist on master node, deleting TeamViewer-Bay.sfx.exe on 13Storage
    [03-05-19 3:55:59 pm]  | CMD: lftp -e 'set xfer:log 1; set xfer:log-file /opt/fog/log/fogsnapinrep.01a - BAY-Teamviewer.transfer.13Storage.log;set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; set net:limit-rate 0:384000; mirror -c --parallel=20 -R -i "TeamViewer-Bay.sfx.exe" --ignore-time -vvv --exclude ".srvprivate" "/opt/fog/snapins" "/opt/fog/snapins"; exit' -u fog,[Protected] 10.13.40.39
    

    [03-05-19 3:55:58 pm] # 01a - BAY-Teamviewer: File does not exist optfogsnapinsTeamViewer-Bay.sfx.exe (13Storage)
    it doesnt exist because the path is being included in the name.

    Sorry if this has been addressed already but I couldn’t find a solution.


  • Testers


  • Developer

    @Greg-Plamondon This issue was found and fixed not long after FOG 1.5.5 came out. Find the fixes here: https://github.com/FOGProject/fogproject/commit/9089f34879ba0fa6ebd0bfb1c872bfcc97a6bf17

    You can either switch to the dev-branch or manually add the fixes. I’d suggest using dev-branch as it includes a couple of improvements and you might find the UI to be way more responsive when you have storage nodes in your setup.


Log in to reply
 

329
Online

6.1k
Users

13.4k
Topics

126.4k
Posts