USB nic general problems



  • Hello,

    There are more new laptops without network interface like DELL XPS models. To get them booted into fog I use a USB nic. Some of them couse problems (like legacy and uefi secure ) to start with a network boot so you need some testing to find a good one. The docking stations from DELL are not working. The usb-c network nic works.
    However I have to use this nic for every model I install without a network card so now I have problems with the security token and repeated mac address. Because I can’t reset the security token of the client, the option just isn’t available for this client, I deleted the client and added the mac address of the usb-nic to: FOG_QUICKREG_PENDING_MAC_FILTER hoping this would resolve my problems.
    However, this made it impossible to add the client to the server as it does not accept the mac address and without a mac you can’t add a client.
    So I tried to shorten the mac in FOG_QUICKREG_PENDING_MAC_FILTER and only use the first 6 characters. Now I can add the client to the server but the fog service on the client is again not working. I get the token error again: Could not get security token. And because of this the client is not added to AD
    I’m in a bit of a loop here. So for the moment I add these clients manually to AD but it would be nice if one of you clever guys could help me out as I’m sure many more problems like this will come.
    I’m currently using version: 1.5.2. So if this is already tackled in a newer version I would be so happy… :-)

    Already a big thank you!


  • Developer

    @martial The fog-client mostly fails with Middleware::Response Invalid security token. From that I see in our code this can only happen if there is a security token set in the DB for this host (identified via MAC address but it’s always the same as you re-use the same adapter over and over).

    Well let’s see if we can figure this out in the DB:

    shell> mysql -u root -p
    Password:
    ...
    mysql> use fog;
    ...
    mysql> SELECT h.hostID,h.hostName,h.hostSecToken,m.hmMAC,m.hmPrimary,m.hmPending FROM hosts h JOIN hostMAC m ON h.hostID=m.hmHostID AND m.hmMAC LIKE '%aa:bb:cc:dd:ee:ff%';
    ...
    

    Use the USB nic adapter MAC address instead of aa:bb:cc:dd:ee:ff. See if you get any results.



  • We have so much automated with Fog because we have so many installations. Image, software, drivers, AD. Other stuff via AD. It is running smoothly but yes, being able to change the mac address would already be very helpful!



  • @Sebastian-Roth Thank you for your answer and I completely understand!
    The log is uploaded.fog.log


  • Developer

    @martial First let me give you a more general answer to your request. FOG came to life when every machine still had an internal ethernet adapter - I know this sounds a bit like dinosaurs roaring but hey - so the MAC address was used as unique identifier of machines.Over the years more and more devices without ethernet came out and we had a first go at switching to a different unique identifier that would be machine specific but not (only) using its MAC address. You can find discussions on this topic in the forums. The end of the story as of now is that we were running into major issues with the other unique identifier and decided to stay with the MAC address for now. It’s a huge change within FOG and we don’t seem to have enough time to go ahead with this change - development, testing, user support… It’s all a big story.

    Ok, enough of that, back to the point. Re-using the same ethernet adapter (MAC address) is essentially breaking FOGs logic of identifying machines. I am not sure but I think most people using FOG this way don’t use the fog-client and therefore don’t run into the same issue as you are. Imaging usually works just fine.

    I am not saying that AD join is impossible but I have not looked into it myself to have a solution for you at hand. There might be other tools around that can be used to make Windows join a Domain on first boot or something like that.

    now I have problems with the security token and repeated mac address

    You might also want to take a look at the database entries to see why you seem to have duplicate MAC entries in there. As well please share the full client log so we can have a look. Possibly it’s something else causing the problem.



  • I am completely new to FOG and I am just throwing ideas out there, but your problem made me realize that I am going to have the same problem in a few months. Our district is starting to purchase laptops and they also do not have NIC ports and we will have to use USB NICs.

    In fog 1.5.5, it seems like you can go to the host machine listed in the web ui and change the primary mac address along with the options Ignore Mac on Client and Ignore Mac on Image. Again, just an idea, but try changing the mac to the wireless mac on the laptop and then reinstall the client on the machines. It is extra work, but this may solve your problem.

    Your problem also reminds why I do certain things separately. It sounds like you are trying to image and then add the machine to AD all in one session. I know it is extra work, but I always image and then add the machines to AD manually after. It is a pain for me to do, but in the end, I know everything is working.


Log in to reply
 

350
Online

5.6k
Users

12.9k
Topics

121.2k
Posts