Unable to register/capture/deploy "Failed to get an IP via DHCP! Tried on Interfaces:"

  • Good morning!

    Hopefully this is the right category but I’m a little stuck and was hoping someone more knowledgeable than I could help with this issue:

    I have a new type of machine I’m trying to take an image of: HP Elitedesk 800 G4 35W, per documentation NIC is a LANIntegrated Intel® I219LM GbE LOM(OUI E4:E7:49). I’m able to get into the PXE menu and select register/quick register but after that keep getting an error:
    “Failed to get an IP via DHCP! Tried on Interfaces:
    Please check your network settings and try again”

    In troubleshooting I’ve tried:
    -Updated to most recent Kernel (4.19.6 64 bit, also tried 32 bit), DHCP error
    -Another model machine (HP 650G1 laptop I had nearby), works fine
    -Manually registering and attempting to capture/deploy, DHCP error
    -Manual register and Debug, DHCP error
    -Connected switch directly to the firewall/DHCP server(usually routes through another switch first), DHCP error
    -Checked and ensured RSTP is set correctly(suggested in another thread), DHCP error
    -Disabled RSTP (mostly from curiosity), DHCP error

    Some things to note but I don’t think are relevant as imaging works with other machines:
    -previously FoG server was doing DHCP(on its own network) but has recently been moved to its own VLAN(along with the machine that is being imaged of course) on the main network and DHCP has been configured with opt 66,67
    -Switch is a UniFi Switch 24 connected to a Meraki MX100 which is handling DHCP.

    I’ve kinda hit a wall so I would greatly appreciate any help that could be given!

  • @george1421, @Sebastian-Roth

    Thank you both VERY much! I just went and updated to 1.55 instead of doing the kernel update manually, figured it would probably be better in the long run. Now it appears to be working normally. Sorry I didn’t notice earlier the kernel wasn’t what I thought it was!

  • Developer

    @Jpolk91 said in Unable to register/capture/deploy "Failed to get an IP via DHCP! Tried on Interfaces:":

    kernel version showing in the version info is showing 4.11 for some reason

    Yes that is definitely the reason. See if you can use the 4.12.3 kernels as suggested. If you run into a kernel error then you might need to use the compat inits as well (32 bit and 64 bit).

    Just for the record, the command used to get the network card information only shows the wireless adapter. Use lspci -nn | grep -i net to get both.

  • Moderator

    @Jpolk91 There has been some issues with the 1.5.x line but most have been ironed out with 1.5.5 (1.5.6 is not to far off either). The 1.5.x has a new web gui with a bit heaver load on the FOG server CPU, its not quite a snappy as 1.4.x versions, but its not bad with quite a few improvements in other areas making it a wash performance wise.

  • @george1421 Should I expect any problems just moving up to FOG 1.5.5 from 1.4? I don’t have any particular reason for staying on the old version other than “If it ain’t broke don’t fix it”

  • Moderator

    @Jpolk91 Ah, that’s the problem. That should have been the first question I asked, what version of FOG are you using??? 1.4.2 is pretty old.

    You will need to manually update to 4.12.3 from here: https://fogproject.org/kernels/ Don’t get greedy, move up to a kernel that supports that network adapter but don’t move the latest because they won’t work with FOG 1.4.2 very well.

    You will need to download those files to /var/www/html/fog/service/ipxe. Rename the existing bzImage and bzImage32 to bzImage411 and bzImage32411. And finally rename the downloaded files to match bzImage (for the 64 bit) and bzImage32 for the 32 bit.

  • Hey! @Sebastian-Roth I was thinking and was going to go back to the 4.12.x kernel you mentioned just to check so I went to the page and it caught my eye that the kernel version showing in the version info is showing 4.11 for some reason… I tried going to a few different kernels and it never changed. Does my version of FOG not support kernels over 4.11 for some reason?


  • Sorry for the delay! I had a lot to do after work yesterday and had to bail pretty fast.

    @george1421 your command is the very first two lines in the picture.

    @Sebastian-Roth here ya go.


  • Developer

    @Jpolk91 said in Unable to register/capture/deploy "Failed to get an IP via DHCP! Tried on Interfaces:":


    Well that’s interesting. This NIC is supported in the default Intel driver e1000e since kernel version 4.12.x - long time.

    @Jpolk91 When you boot into a debug task again, please run the following command, take a picture and post here: dmesg | grep -i -e eth -e e1000e

  • Moderator

    @Jpolk91 excellent results. I did make a mistake and should have had you enter a command line switch on the lspci command. lspce -nn|grep etwor That command will give us the vend and device ID that should match what windows sees.

  • @george1421 Thank you for the swift reply!

    I jumped into windows and the hardware ID had several lines for the Ethernet adapter so here is the entire thing:

    and here is the picture showing the output of those commands:

  • Moderator

    So after reading your post I’m questioning which is not getting an IP address. — well after rereading it a third time, I see its FOS not able to get an IP address. You are able to get into the FOG iPXE menu so the computer is pxe booting capable (which requires dhcp to be working). You are also able to get FOS onto the target computer, it appears just FOS is having an issue with the network adapter.

    There is a couple of things I need you to do.

    1. From a computer of the same model that has windows loaded on it. Please go into the device manager and get the hardware ID of this network adapter. What I’m looking for is the hardware ID that would look like thisVEN_8086&DEV_1502 (I made that number up).
    2. Manually register this HP Elitedesk 800 G4 using the mac address of the ethernet adapter. Then in FOG schedule a deployment but before you hit the schedule button, tick the debug checkbox. Then pxe boot the target computer. After a few enter key presses you will be dropped to a linux command prompt, this is the FOS (Fog Operating System). key in 'ip addr showtake a clear picture with a mobile phone of the outputlspci |grep etwor` again take a clear picture and post both here.

Log in to reply