UNSOLVED Dell Precision 5530 PXE Boot problem (Maybe the USB cable is bad)

  • Hello,

    I’m trying to install my image on a new Precision 5530. My USB dongles worked fine on previous models like (Latitude 7390, Precision 5520) but now I’m getting the error “Maybe the USB cable is bad”.

    I tried with the latest 64 bit kernel image
    and with the usbcore.old_scheme_first=1 attribute.

    How can I fix this?
    I’m using fog 1.5.2 and Kernel 4.19.1 (32 and 64 bit).

    Kind regards!
    Johan Jacobs

  • Moderator

    @martial said:


    Ok, we definitely have that driver included in our kernel config (since a long time). So I was wondering if other people had issues with Linux on this device. But seems like people are happily installing Linux on it despite some video card issues - see here. But no one complaining about network issues.

    So I went hunting for those USB messages and read about USB hubs or other faulty USB hardware here and there, e.g.:

    It seems the hub in the monitor went bad and was screwing with all other USB ports on the system

    Maybe just some faulty hardware? Have you tried different ones. Always getting the exact same error on every try?

    Then again I ask you for the third time (and last!), have you tried adding the Kernel Parameter has_usb_nic=1 to the host settings?? If this device is still unregistered and the error happens on registration you might just add the host manually via the web UI, add the parameter and try a capture task to see if that helps.

  • @george1421 Thank you for your support. It is for the usb-c dongle
    It is indeed a realtek USB GbE Family Controller #2
    But it does not matter what usb network dongle or docking we use, the error keeps popping up.

  • Moderator

    @martial Thank you for your response. Can you tell me what that for the USB-A or USB-C dongle?

    The device VID_0BDA PID_8153 [linux 0bda:8153] is a Realtek RTL8153 USB 3.0 GbE adapter.

    Just collecting data here:
    ref: https://www.pcsuggest.com/install-rtl8153-driver-linux/

  • Hello there, I’m answering on behalve of @jjacobs

    @george1421 These are the hardware id’s from the dongle displayed by the prec 5530:


  • Moderator

    @jjacobs Definitely see if you can get the hardware IDs for us. Possibly there is some driver issue that we can figure out and fix. But as well I am asking you again to give the kernel parameter has_usb_nic=1 a try. We have seen USB ethernet adapters that need a reconnect.

  • Moderator

    @jjacobs When you plug those dongles into a windows computer and then go into the device manager. What hardware IDs are represented by each of those dongles. I’m looking for the hardware ID that look similar to this VEN_11C1&DEV_5811&CC_0C0010 for each model.

  • @george1421 Hi,
    I have 2 Dell PXE dongles:

    • 470-ABND USB-C
    • 492-11726 USB-A
      So no convertor is between the dongles, both gave the same error.
  • Moderator

    @jjacobs said in Dell Precision 5530 PXE Boot problem (Maybe the USB cable is bad):

    Precision 5530

    OK I misread your OP and took the 5530 as an older Latitude e5530. The Precision 5530s are really new (I don’t have one yet). Tell me, are these 5530s only USB-C? If so is your usb dongle usb-c or usb-a? Or is the usb-a dongle connected via a usb-c dock?
    The error message kind of indicates its inline with a usb-c to usb-a converter. I might suspect that the FOS kernel is missing some usb-c stuff, but that is only a guess.

  • Moderator

    @jjacobs Please set has_usb_nic=1 as Kernel Parameter for this particular host in the FOG web UI and see if that helps.

  • 0_1543997227981_5530.jpg

  • Moderator

    @jjacobs said in Dell Precision 5530 PXE Boot problem (Maybe the USB cable is bad):

    but now I’m getting the error “Maybe the USB cable is bad”.

    Where exactly are you seeing this error message? A clear screen shot of the error taken with a mobile phone will give us the context of that error message.

    If this happens before the iPXE menu is displayed, then the FOS kernel has no impact here.

    Is this computer in uefi mode or bios (legacy)?

    BTW: shouldn’t a 5530 have a built in ethernet adapter?

  • Moderator

    @jjacobs There most probably is no simple “do this and that and it will work” I am afraid. Every machine is kind of different as it might come with different firmware (version). Maybe start by posting a picture of the error here.