fogserver changed ip, now cant login



  • so i changed the ip from 10.10.11.151 (dhcp) to 10.10.8.80 (static). rebooted. changed ip in .fogsettings. to new ip, ran installer. went to fogserver/fog - page loads. logged in…and nothing. just times out after a while. management page and everything beyond it all acts the same, loading…

    i’ve moved them before but not these ones - these were fresh installs, the server master had 5 storage nodes below it. the one storage node i reinstalled pulls up white screen to ‘database connection unavailable’
    what log/where can i find whats happening?

    edit:: while i wrote this, the page pulled up to dashboard. however it still takes forever to load it, i hit refresh and its still going (3 minutes and counting)



  • @p4cm4n In the case of storage nodes, the fog server that hosts the database has to be updated with the remote node’s new IP address. So to answer your question, No. Though since the database credentials are present on the storage node, some alterations to the scripts could make this possible.



  • @Wayne-Workman perfect chance to ask - will updateip tool, or makefogmobile both work on storage nodes as well?



  • For future readers, the updateIP tool also covers updating the config.class.php file.



  • @p4cm4n the reason ended up being that in config.class.php the page still had database_host as the old IP address
    my thanks go out to sebastian who helped me out with this



  • @Sebastian-Roth only reason i did that was because i wasn’t on site.
    sorry though, wasn’t available because someone in my company decided to do some vlan changing without letting anyone know/testing.
    i’ll be available whenever probably, i’ll check in.


  • Developer

    @p4cm4n said in fogserver changed ip, now cant login:

    i have opened up both SSH and web gui to the outside

    Wouldn’t do that. We can join you in a Teamviewer session on notice. Will you be around in the next hours? I can try to squeeze in a short session. Contact me on chat here in the forums.



  • @Sebastian-Roth i’m more than willing to troubleshoot - didn’t want to waste your guy’s time.
    considering I will be going through this exact process (maybe with less than 5 storage nodes per site however) about 12 times at the different schools i will be maintaining, i’m all for fixing.
    i have opened up both SSH and web gui to the outside, and am available to be pointed in whichever direction.
    further troubleshooting from me, i pulled up chrome inspector on the site locally and saw that scripts were taking a long time, along with something else which i forget at the moment.


  • Developer

    @p4cm4n said:

    i’ll see if it helps my current issue. if not i’ll just reinstall them all.

    Feel free to do a reinstall but from my humble opinion we’d all learn more from trying to find out what’s causing the slow web UI response and fix it.



  • @Wayne-Workman never before. i’ll check it out - thanks.

    the makefogmobile project would help me out probably too (for little one and done labs here and there)
    Thanks for that!

    i’ll see if it helps my current issue. if not i’ll just reinstall them all.




  • Developer

    @p4cm4n Don’t have much of an idea yet. Can you try accessIng the web UI using different browsers and doing so from different machines. Makes a difference?

    Do you know how to use browser developer tools to look at the traffic? In Firefox hit F12 to open the Tools and switch to the network tab. Now reload the page and see where exactly it hangs. Take a screenshot and post here.



  • @Sebastian-Roth it seems very similar to this
    https://forums.fogproject.org/topic/11581/slow-webinterface-after-update-to-1-5-0

    all are 1.5.4 though, only installed 5 days ago, registered 3 clients and captured 3 images.



  • the errors i did see seem to be with children processes. i’m not sure what it was set to before the install, but its now 5. i bumped it to 35 per george’s comments in another thread about the issue i was getting (fastcgi header)
    what made it jump so low? its running on an older machine, but not that bad (core2 t8300, 2GB on debian w/xfce)

    altogether though, it didnt resolve anything. i changed that, checked again and about 120 seconds or so the page pulled up. ive been continually checking both error logs and the access logs but nothing is showing in either errors now since i fixed that, put my original .fogsettings back (i tried passwords and things last night) and reran installer, and just to be sure rechecked the children processes again.

    also i noticed if i just go to the apache pages, they’re instantaneous. don’t know if that helps…as soon as i clock the folder fog, is when it slows down.

    edit: okay, so now i’ve noticed that if i go to a page, settings for example itll take a while to get there, but if i go to sub pages, they’re normal-ish speed. same with storage - i clicked on it to change IP’s and navigating through those pages, and saving settings were fine also.


  • Developer

    @p4cm4n Anything in the apache and php-fpm logs? See my signature…


Log in to reply
 

373
Online

6.0k
Users

13.3k
Topics

125.1k
Posts