Slow webinterface after update to 1.5.0



  • We have one master server, with two storage nodes.
    Master: 1.5.0
    Stoarge01: 1.4.4
    Stoarge02: 1.4.4

    After the update to 1.5.0, the web interface seems to run really slow in certain menus.
    When clicking on the “Storage” icon at the top, it will hang there for more than 5 minutes before entering the menu and the same thing seems to happen with the “Fog Configuration” menu.

    We thought it might have something to do with the two storage nodes, so we decided to turn off the replication to them/even tried shutting them down, but that didn’t help at all.

    I have posted a picture of the top command on our master server below:
    0_1520494382988_FOG.png


  • Testers

    I am having this issue with 1.5.2


  • Moderator

    @moses 1.5.1 stable was released last night, please update your install to 1.5.1 and ensure that the issue has been resolved.


  • Senior Developer

    Please try installing using the working-1.5.1 branch. I hope to push it as release soon just need same little more feedback.



  • @tom-elliott I’m having this issue as well. Login screen appears pretty quickly, but logging in takes at least 3-5 minutes and all UI navigation takes several seconds to up to a minute to load.



  • @Tom-Elliott
    The slowdown is constant. After I sign in and click on storage it just hang there for a couple of minutes before opening. After it opens, I can go to the dashboard fx and when I go back to storage it happens again.
    Tried signing out / in and did a reboot of the server, but the issue is constant.

    If you’d like, I can record a screen capture of it?


  • Senior Developer

    @andershoeg is the slowdown just after you login? I’m trying to narrow down where the problem is and I believe I might have a solution already, but knowing when the slowdown is happening will make this much simpler.



  • @sebastian-roth
    I’ve been looking into the database to find the duplicates but there are none. Sorted after MAC addresses and they all showed up, but none of them are showing more than once.
    I also tried exporting the host list to .csv and take a look if I could find any duplicates there :/
    At the moment, we got 53 hosts registered.

    @Tom-Elliott
    The hosts are installed by using the SmartInstaller, is that the legacy client?


  • Senior Developer

    Do you have a lot of hosts using the legacy client?


  • Developer

    @AndersHoeg You seem to have duplicate MAC addresses in your database?! How many hosts are registered? Have you had a look at the tables yet?



  • @tom-elliott
    I have tried disabling the storage nodes, that doesn’t change anything.
    All three servers are running Ubuntu Server 16.04.4 LTS and are fully updated.

    @Sebastian-Roth
    I have now upgraded the storage nodes to 1.5.0 and I do still have the same issue.

    UPDATE:
    I have been looking at the apache error log(var/log/apache2/error.log) while I press the storage button on the web interface and while waiting I do get an error after waiting for about a minute or two:
    Not sure if it has something to do with the interface acting slow, just wanted to include it:
    0_1520510456647_E96A40D2.PNG


  • Developer

    @AndersHoeg said:

    Master: 1.5.0
    Stoarge01: 1.4.4
    Stoarge02: 1.4.4

    Please make sure to upgrade your storage nodes as well.


  • Senior Developer

    If you need the node then reenable it of course. How many nodes do you have? I find it unlikely that replication was what was causing your slowdown as you state it doesn’t seem to have gotten any better.

    Are all nodes on the same version of fog?

    What os are they running?


  • Senior Developer

    Try disabling the nodes from the storage nodes themselves. It sounds like they cannot talk to one another. I know this is counterintuitive but I’m aware of issues with it I just don’t have a good path forward to fix them currently.


 

449
Online

41.6k
Users

12.1k
Topics

114.4k
Posts