Printers Management : Win10x64 NOK, Win7x64 OK



  • Hi !
    I’m trying to use the printer management service with FOG.

    On a Win7x64 with an HP LaserJet PRO M402, it’s work.
    The same printer with Win10x64 is not showing in the Windows printer management.

    The printer section on FOG :

    • Name : XXXX
    • Printer Port : IP_1xx.xxx.xxx.xxx
    • Printer INF file : \NAS…\HP_M402_DNE\hpdo602a_x64.inf
    • Printer IP : 1xx.xxx.xxx.xxx
    • Printer Model : HP LaserJet Pro M402-M403 n-dne PCL 6 (found into the inf file)

    On the Win7x64 client : after the FOG service execution (drivers on NAS) :

    • in the Windows printer management : i can see the printer
    • with printmanagement.msc : i can see :
      -> the port
      -> the drivers

    On the Win10x64 client : after the FOG service execution (drivers on NAS) :

    • in the Windows printer management : i can’t see the printer
    • with printmanagement.msc : i can the port BUT i cannot see the drivers …

    If i use the “Fog PrinterManager Helper” on the Win10x64 with the same parameters (drivers on NAS) :

    • in the Windows printer management : i can see the printer
    • with printmanagement.msc : i can :
      -> the port
      -> the drivers

    The share is a public share without any authentification.

    FOG seem not be able to copy the drivers on Win10x64 with the FOG Client … or something like that …

    If i use the FOG Client on the Win10x64 with local drivers (Printer INF File : C:\HP_M402_DNE\hpdo602a_x64.inf) :

    • in the Windows printer management : i can see the printer
    • with printmanagement.msc : i can :
      -> the port
      -> the drivers

    What can i do ?

    Win10x64 version : 1803 (without any antivirus)



  • Hi,
    Today is a good day !
    i tried a new test : i used an other NAS (Seagate) and created a public share.
    With the same windows 10 station, i can xcopy files as SYSTEM and the printer was correctly installed.

    So, now, on the Syno NAS, i will tried to join our domain … i will be back 😉


  • Moderator

    @Jonathan-Cool They may be reserved accounts which is why it trips up, I don’t think there’s much to change in the settings there, going with the Samba credentials route seems the best way.

    If your Samba share is AD enabled then domain connected PCs will likely logon under their actual accounts when they try to connect to the share rather than Windows assuming you want to logon as ‘System’


  • Senior Developer



  • @Quazz Hmmm, you right ! … seem to be possible !
    I so close to resovle this issue … maybe, need to check the NAS configuration ?


  • Moderator

    @Jonathan-Cool Your NAS probably treats unknown users as guest users. I’m guessing it thinks of “system” and “admin” as existing users, thus rejecting them.



  • Some news … weird … : see below … : on the Win10 1803 station :

    C:\>PsExec64.exe -S cmd
    
    C:\WINDOWS\system32>cd ..
    
    C:\Windows>cd ..
    
    C:\>whoami
    autorite nt\système
    
    C:\>net use Z: \\fog-nas\drivers_imp
    L'erreur système 58 s'est produite.
    
    Le serveur spécifié ne peut pas exécuter l'opération demandée.
    
    
    C:\>net use Z: \\fog-nas\drivers_imp /user:admin
    L'erreur système 58 s'est produite.
    
    Le serveur spécifié ne peut pas exécuter l'opération demandée.
    
    
    C:\>net use Z: \\fog-nas\drivers_imp /user:admin password
    L'erreur système 5 s'est produite.
    
    Accès refusé.
    
    
    C:\>net use Z: \\fog-nas\drivers_imp /user:fakeuser fakepassword
    La commande s'est terminée correctement #WTF ?! fakeuser doesn't exist on  the NAS ! What the HELL ?!
    
    
    C:\>net use
    Les nouvelles connexions seront mémorisées.
    
    
    État         Local     Distant                   Réseau
    
    -------------------------------------------------------------------------------
    OK           Z:        \\fog-nas\drivers_imp  Microsoft Windows Network
    La commande s'est terminée correctement.
    
    
    C:\>net use Z: /delete
    Z: a été supprimé.
    
    

  • Moderator

    @Jonathan-Cool Did using samba credentials change anything?



  • @davido38
    Hi,
    I tried with LmCompatibilityLevel = 1 (already set) or LmCompatibilityLevel = 5 (i rebooted after modification) and no more success 😞



  • @Jonathan-Cool
    As-tu essayé de modifier la clef de registre windows 10

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    LmCompatibilityLevel avec une valeur 1 ou 5 ?



  • @davido38 Yes, i enabled this protocol during my tests 😉



  • Hi,

    is the smb1 protocol enabled on windows 10 ?

    by default it is not.



  • Hi,

    fog@fog-nas:/$ samba -V
    Version 4.1.20
    fog@fog-nas-44:/$ 
    
    

    I will try ti logging with samba credentils asap …


  • Moderator

    @Jonathan-Cool Error 58 indicates this has to do with how Samba has changed between Windows 7 and Windows 10, specifically for security.

    What Samba version is the NAS running?

    Try logging in with Samba credentials to the share in the net use command instead of guest logon.



  • Hi !
    I’m back with the answers …

    @Quazz

    C:\>whoami
    PC-test-Win10\administrateur
    
    C:\>net use Z: \\fog-nas\drivers_imp
    La commande s est terminée correctement.
    
    
    C:\>xcopy Z:\test.txt
    Z:\test.txt
    1 fichier(s) copié(s)
    
    C:\>PsExec64.exe -S cmd.exe
    
    PsExec v2.2 - Execute processes remotely
    Copyright (C) 2001-2016 Mark Russinovich
    Sysinternals - www.sysinternals.com
    
    
    Microsoft Windows [version 10.0.17134.523]
    (c) 2018 Microsoft Corporation. Tous droits réservés.
    
    C:\WINDOWS\system32>whoami
    autorite nt\système
    
    C:\WINDOWS\system32>cd C:\
    
    C:\>net use
    Les nouvelles connexions seront mémorisées.
    
    La liste est vide.
    
    
    C:\>net use Z: \\fog-nas\drivers_imp
    L'erreur système 58 s'est produite.
    
    Le serveur spécifié ne peut pas exécuter l'opération demandée.
    

    @quinniedid

    PC-test-Win10\administrateur
    
    C:\>PsExec64.exe -S cmd.exe
    
    PsExec v2.2 - Execute processes remotely
    Copyright (C) 2001-2016 Mark Russinovich
    Sysinternals - www.sysinternals.com
    
    
    Microsoft Windows [version 10.0.17134.523]
    (c) 2018 Microsoft Corporation. Tous droits réservés.
    
    C:\WINDOWS\system32>net use
    Les nouvelles connexions seront mémorisées.
    
    La liste est vide.
    
    
    C:\WINDOWS\system32>net use Z: \\fog-nas\drivers_imp
    L'erreur système 58 s'est produite.
    
    Le serveur spécifié ne peut pas exécuter l'opération demandée.
    
    
    C:\WINDOWS\system32>cd \\fog-nas\drivers_imp\
    '\\fog-nas\drivers_imp\'
    CMD ne prend pas les chemins UNC comme répertoires en cours.
    
    C:\WINDOWS\system32>
    

    and the screensot of permissions displayed by Win10 : https://drive.google.com/open?id=1OEPXC-dYWlqfksnCKwxKFIzjbhj-7VoE

    The win10 station and win7 station aren’t on the domain. Same with the NAS … but works win7 so … i think it’s not a domain issue. Isn’t it ?



  • @Jonathan-Cool I find it very interesting that a SYSTEM account will work on Windows 7 but not Windows 10. One thing I would like to see is doing the same thing with PSExec running as the SYSTEM account and once you have that command window open change the directory to where you usually have the drivers dumped to. Run the xcopy from the NAS. I would be curious to see the behavior difference between Windows 7 and Windows 10.

    Also, can you capture a screenshot of the security permissions of the folder specially on Windows 10 that the drivers are dropped into? Something like this: 9af71ed8-fd11-49f5-89f5-8dec43110fcc-image.png


  • Moderator

    @Jonathan-Cool Still seems to be a permission problem from what I can tell.

    You can try to test by assigning a drive letter as the system user to the samba share and see if you can then access the files using the drive letter assignment.

    Something like:

    1. net use V: \server\share /user:name1 passw2
    2. xcopy V:\drivers C:\drivers
    3. net use V: /delete

    I’m guessing if the W10 joined the domain that could work too.



  • Hi,
    @quinniedid Nope, the NAS is only on the LAN but not configured for the samba domain.

    I tried a new simple test on the Win10 v1803 : if i copy / paste the drivers into C:\ and set the printer (on the FOG printer management), the printer is seen correctly on the win10 … and i can SEE the drivers in the “printmangement.msc” Windows tool … so, the culprit is the share … not the driver, not the ini file … just the share … OR Windows 10 configuration.

    So, the drivers are on a Synology NAS with :

    The printer section on FOG :

    Name : XXXX
    Printer Port : IP_1xx.xxx.xxx.xxx
    Printer INF file : \NAS…\HP_M402_DNE\hpdo602a_x64.inf
    Printer IP : 1xx.xxx.xxx.xxx
    Printer Model : HP LaserJet Pro M402-M403 n-dne PCL 6 (found into the inf file)
    

    What can i try now ?



  • @Jonathan-Cool Is your NAS also connected or configured to your samba domain?


  • Senior Developer

    @Jonathan-Cool To me this seems like a “simple” permission issue. What if you create a public share for this drivers where no authentication is needed? Not sure if I miss the point here.


Log in to reply
 

284
Online

7.4k
Users

14.5k
Topics

136.5k
Posts