Typo in /packages/web/lib/service/fogservice.class.php



  • line number 343 variable itemTyep spelled incorrectly

    stops storage node image Replicator working properly

    It loops.


  • Senior Developer

    @yrubdarb Fixed this issue in working, thanks for reporting.

    If you see any other issues, are you familiar with GIT? Can you put in a Pull Request against the working branch? (If you could look at working-1.6 that would be great too).

    Sorry if I seem a bit distant lately. I had to make a bunch of life decisions very recently and it has greatly impacted my availability for the time being.

    I am still here, I just may not be anywhere near as active as I once was until I am settled a bit more.

    Thank you,


  • Moderator

    @yrubdarb The developers are ALWAYS looking for another set of eyes with coding skills to double check their work. I might suggest spinning up a new FOG server and then using git to switch to the working branch to get the absolute latest beta builds. And then from github create a pull request (hint: I’m not 100% sure of what I’m saying). Once you get the github files you can review them, and adjust if necessary and then push the fixes back to the code base. The developers will review and integrate into the official code base.

    So if you have some time to spend to help FOG get even better, everyone would appreciate it.



  • We are using the 1.5.4 branch and having issue with the replicator. We have found quite a few errors in the code if we are on the correct branch I can post the fixes for them.



  • This post is deleted!


  • @yrubdarb What branch are you on?


 

607
Online

5.4k
Users

12.6k
Topics

118.6k
Posts