Updating Fog from 1.4.4 to 1.5.2 or 1.5.3 = fail on EL 6.9



  • I have been using this amazing projet for a about 2 year now. thank you.
    I have updated a few time from 1.3 to 1.4.4. About an hour ago I am trying to update to fogproject-1.5.2 but it failed and broke my installation.
    I rolledback my install went back to a working 1.4.4 and tried fogproject-1.5.3 (which was release while I was doing this.) but it still fails from 1.4.4.

    running install script goes well until when it ask to :

    • Press [Enter] key when database is updated/installed.

    then my web admin page goes not working and showing garbled info…
    http://fog-server/fog/management/ show this in my browser… (chrome and firefox)
    OS is Scientific Linux 6.9 updated.

    * @license http://opensource.org/licenses/gpl-3.0 GPLv3 * @link https://fogproject.org */ /** * The main index presenter * * @category Index_Page * @package FOGProject * @author Tom Elliott * @license http://opensource.org/licenses/gpl-3.0 GPLv3 * @link https://fogproject.org */ require '../commons/base.inc.php'; $FOGPageManager = FOGCore::getClass('FOGPageManager'); if (session_status() != PHP_SESSION_NONE) { if (isset($_SESSION['delitems']) && !in_array($sub, array('deletemulti', 'deleteconf')) ) { unset($_SESSION['delitems']); } } FOGCore::getClass('ProcessLogin')->processMainLogin(); require '../commons/text.php'; $Page = FOGCore::getClass('Page'); $nodes = array( 'schema', 'client', 'ipxe' ); if (!in_array($node, $nodes) && ($node == 'logout' || !$currentUser->isValid()) ) { $currentUser->logout(); $Page ->setTitle($foglang['Login']) ->setSecTitle($foglang['ManagementLogin']) ->startBody(); FOGCore::getClass('ProcessLogin') ->mainLoginForm(); $Page ->endBody() ->render(); } else { if (FOGCore::$ajax) { $FOGPageManager->render(); exit; } $Page->startBody(); $FOGPageManager->render(); //if ($FOGPageManager->getFOGPageName() !== $FOGPageManager->getFOGPageTitle()) { $Page ->setTitle($FOGPageManager->getFOGPageTitle()); //} $Page->setSecTitle($FOGPageManager->getFOGPageName()); $Page ->endBody() ->render(); }
    


  • @tom-elliott I am willing to try I am already at 1.5.3 on SL69…

    so writing with george1421… I issued those commands.:

    git clone https://github.com/FOGProject/fogproject.git
    cd fogproject
    git checkout working
    cd bin
    [root@fog:/opt/fogproject/bin ]% ./installfog.sh
    installing…

    Yes. it is working !
    file /etc/httpd/conf.d/fog.conf was rewritten correctly.

    then I switched back to the master
    git checkout master
    thank you all.


  • Moderator

    @tom-elliott Thank you for the quick response. It looks like I wiped my centos 6 vm, but I can spin up a new one and confirm its working.

    Also the OP mentioned that the new UI on his mobile running chromium under android gave a strange web page. I need to find my android tablet to see what’s up with that.


  • Senior Developer

    @george1421 I’ve added a check to the working branch that will check if Redhat and if OS Version is < 7. If so, it will set the handler to the application/x-httpd-php, otherwise set as FPM. Mind testing it for me at all? (Anybody can do it, I don’t have a CentOS 6 or earlier to test with myself right now.)


  • Moderator

    @Developers we may need to have the FOG installer bypass setting up php-fpm on RHEL 6 derivative operating systems. I was able to help the OP get his install up and running using the reversing steps below.


  • Moderator

    You will need to do this by hand,

    1. cd /etc/httpd
    2. We are looking for a file that contains this text
      grep -R -e "127.0.0.1:9000" *
    3. Once you locate that file open it with your editor.
    4. Search for these lines
    #SetHandler application/x-httpd-php
    SetHandler "proxy:fcgi://127.0.0.1:9000"
    
    1. Uncomment the first line and then place the comment (hash tag) in front of the other line to make them look like this:
    SetHandler application/x-httpd-php
    #SetHandler "proxy:fcgi://127.0.0.1:9000"
    
    1. Save and exit your editor.
    2. Restart apache
      service httpd restart
    3. Now try to go to the management page.

  • Senior Developer

    @lepage I’ve never tested on SL though it should work. Can you please ensure remi repository is installed and verify your php version?


  • Moderator

    @lepage Centos 6.x has an issue with the newer php-fpm engine. You will need to switch back to the apache-php engine to install fog 1.5.2 or later on centos 6.9



  • Scientific Linux is the exact same as CentOS 6.9. Binary, source& config compatible… it’s the source from Red Hat EL6.9… there is also the fact that is was working for years.

    @wayne-workman unless you mean that CentOS 6x and EL 6x altogether is also not supported by fog 1.5.x and from your link this is what I understand.

    in that case FOG should not offer that update or the readme should, maybe mention it.



  • @lepage said in Updating Fog from 1.4.4 to 1.5.2 or 1.5.3 = fail:

    OS is Scientific Linux 6.9 updated.

    Scientific Linux is not officially supported. See the link in my signature for what the installer currently works for.



  • If I fail to find a solution today I will revert to 1.4.4 for now.


Log in to reply
 

447
Online

6.2k
Users

13.6k
Topics

128.0k
Posts