Multicasting Issue



  • Hi All,
    Bit of a weird one here, Fog Multicast sessions start fine and image up to around 39% then stall, the network traffic tails off and dies.

    we have been successful multi-casting in this lab before so I’m not sure what to check (Bit of a fog novice) any advice is welcome.

    We have checked the switches and they all seem to be configured right



  • @sebastian-roth

    Update:
    The switches were waiting for 260sec (4min 20sec) for the clients to send out a “I still want to receive this multicast stream” but the clients didn’t so the switches stopped sending the multicasts. I’ve changed that so the switches will now wait for 1260sec (21min) before stopping the multicast.

    Our networks team had a look and muticasting is now working!



  • @sebastian-roth Thanks for replying,

    We’ve tried on servral machines and still the same issue, even just multicasting to 1, Unicasting 1 of them works perfectly even at the same speed multicast achives, which is weird?

    the log from /var/log/fog/multicast.log.udpcast.1 shows:

    ~~
    Timeout notAnswered=[0] notReady=[0] nrAns=1 nrRead=1 nrPart=2 avg=830
    Dropping client #0 because of timeout
    Disconnecting #0 (10.255.0.122)
    bytes= 27 293 398K re-xmits=0107680 ( 0.5%) slice=0112 - 1
    Timeout notAnswered=[1] notReady=[1] nrAns=0 nrRead=0 nrPart=1 avg=830

    Dropping client #1 because of timeout
    Disconnecting #1 (10.255.0.121)
    bytes= 27 293 398K re-xmits=0107680 (  0.5%) slice=0112 -   1
    Transfer complete.
    
    Again sorry for the novice questions, Windows Admin here :P

  • Developer

    @NateUH Pretty sure there is one client having a major (disk?) issue. Try multicasting in different groups. So for example if you want to image 20 in one go, just do 10 as first half and the second batch after that. I’d expect to only have the issue with one of the smaller groups. Split the issue group again and follow on till you figure out which client exactly is causing this.



  • @george1421 thanks for getting back to us i have checked the hardware and they are i7s with samsung evo pro SSDs so pretty beefy
    The issue seems to be that every multicast session gets around the same point and dies

    I have looked into the logs and it shows client#0 ect timed out
    Ive attached some images. Sorry if i am terrible at explaining !

    The middle image shows how the network traffic all dies0_1527695957844_040EBB75-D831-449E-BBC2-9587B8A9B0D3.jpeg 1_1527695957845_7F75E97D-B311-45A3-8867-D38C132AAAE3.jpeg 2_1527695957845_D22CC0F1-9AA1-4724-A54D-4A7BC8AE8193.jpeg


  • Moderator

    @nateuh Remember that your multicast stream will transmit as fast as your slowest computer in the multicast group. So if you have 5 quad core i7s computers with nvme drives and one computer with a Pentium 4 with a 5400 RPM hard drive, the imaging will only go as fast as the Pentium 4 can take in the image. So its possible that one of your target systems is causing this issue too.



  • This post is deleted!

Log in to reply
 

448
Online

6.2k
Users

13.6k
Topics

128.0k
Posts