Surface Pro 4 kernel issue



  • Hello,

    We have quite a fleet of Surface Pro 4 tabets and were able to image them quite well using the 4.12.3 64 bit kernel.

    However after a recent firmware/bios update this is no longer possible.

    we are able to pxe boot into the menu and select and image.

    when the system tries to copy the image I receive the following errors:

    Fatal:Kernel too old.
    Kernel panic - not syncing: Attempted to init! exitcode=0x00007f00.

    I can provide a foto of the full errormessage if required.

    Unfortunately none of the newer kernels currently work on the Surface Pro 4. (screen just goes black and nothing happens).



  • @george1421

    I’ll get back to you about the booting from USB thing later.

    To answer your questions in the second post:

    1. the device lists the system UEFI version as 106.1624.768
    2. 1.5.2 (as a troubleshooting step i did update fog from the git repository)
    3. I’ve tried all kernels from 4.12.3 and upwards
      the complete list is:
      4.12.3
      4.13.4
      4.15.2
      4.16.6

  • Moderator

    I do have one debugging idea that we can try: https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image

    I’ll IM you a link to get you jump started.

    The idea is to see if we can get those surface pros to boot FOS from the usb drive. This will tell us if its a linux kernel issue or an iPXE handoff issue.

    From the link I’m going to send you, “burn” that image to a usb flash drive (512MB or larger, yes its tiny). Then you need to update the bzImage, bzImage32, init.xz, init_32.xz with the latest kernels and inits from here
    https://fogproject.org/kernels
    https://fogproject.org/inits

    Then usb boot your surface pro and select option #6 for debug. Hopefully that should drop you to a linux kernel prompt on the target computer. If it does then we might have an iPXE issue and not kernel related with the surface pro 4.


  • Moderator

    The error message you posted is basically telling you the initis (init.xz) has a minimum supported kernel level embedded in it. So the kernel and the inits are tied together.

    So an update to the Surface Pro’s broke uefi booting?

    1. What is the current version of the broken uefi firmware installed?
    2. What version # of fog are you using?
    3. What is the latest FOG kernel you tried?

    The developers might not have a solution right away since FOG relies on other FOSS projects.


Log in to reply
 

450
Online

6.2k
Users

13.6k
Topics

128.1k
Posts