PXE boot freeze on Random Computers Using FOG 1.5.2 & kernel Version 1.5.2



  • Having issue when computers boot from pxe. They randomly freeze and do not continue to boot. They stop at different points when loading PXE. I am not sure how to proceed in troubleshooting this issue, any help will be appreciated. please see my configuration below, please let me know if you have additional questions.

    Current Configuration:

    Two server configuration, one acting as Storage Node, running Centos 7.4.1708. Both are running four NIC Bonded LACP. Firewall & SELinux are both disabled. Option 66 and 67 configured for infoblox appliance for my network segment. The PXE boot file currently configured is ipxe.pxe.

    Clients:

    All the Bios and NIC Firmwares are updated to the current versions. PXE are configured to legacy mode.

    HP Elitedesk 800 G1 mini Tower & All in One
    HP Elitedesk 800 G2 All in One
    HP Elitedesk 8300 mini tower & All in One
    HP Elitedesk 8200 mini tower



  • @kleber I’d recommend removing the background image via the GUI under Settings | iPXE General Config. I just removed the background image name from that field entirely. The default background prevented certain machines from being able to boot for me as UEFI. Figure its a quick enough thing to check.

    Are there other machines that do boot ok with your setup or are you not able to boot any machine via iPXE?

    Do the machines you have issues on have any BIOS settings specific to PXE booting (enabling it, authentication, etc)? If you you may want to check the configuration there.

    Have you tried UEFI boot instead of BIOS boot, I have found sometimes the error is more descriptive in one vs the other (or even that one way has no error and the other does). I have found it especially helpful to have a camera/phone camera with high speed video recording, ie 120/240 fps and record the screen after I make my selection to catch any brief messages on screen.



  • @george1421

    Sorry it took me so long to get back to you, I tried using the file you suggested and to no avail. The same problem occurs. I also used a different fog server and it had the same behavior. The computers randomly freeze loading pxe drivers.


  • Moderator

    @kleber said in PXE boot freeze on Random Computers Using FOG 1.5.2 & kernel Version 1.5.2:

    @george1421

    I tried different version of the kernel and they all do the same. I am willing to try different version of the PXE files

    As I posted, the kernel is not at issue here. You are not getting past the iPXE boot menu startup. Please download the fog 1.4.4 version of iPXE here: https://drive.google.com/open?id=1TzCfwv7BOysbAjQuJxx3DDNUv1OowOPl This file is undionly.kpxe since it looks like you are booting in bios mode on those screen shots. Save the original file and then drop this one in place and see if pxe booting works. You should get to the FOG iPXE menu if everything goes right.



  • @george1421

    I tried different version of the kernel and they all do the same. I am willing to try different version of the PXE files


  • Moderator

    @wayne-workman Actually its not getting that far as FOS so testing the kernels will not help (just yet). It looks like iPXE is hanging setting up the network interface. Looking on rom-o-matic, it looks like iPXE in FOG is 2 commits behind current. I can seem to find the change log for iPXE to see what was addressed in those changes.

    @Kleber I do have access to FOG’s 1.4.4 version of the iPXE files if you want to test those to see if you have better joy than with 1.5.2’s versions.



  • @kleber Can you try kernel 4.13.4 both 32 and 64 bit please?



  • @wayne-workman Hello, sorry it took me so long to get back to you, Here are the pictures you requested.

    0_1523913644137_Computers Freezing.JPG



  • @kleber Can we get a photograph of a monitor when the freeze happens on one of these please? Please be sure that the photo is well focused, close enough that we can read any text, and free of glares that blot out text.



  • @wayne-workman

    I tried the kernel you suggested and it did not solve the problem. I also tried changing the pxe boot in the DHCP to these:

    undionly.kpxe
    ipxe.pxe
    ipxe.kkpxe

    These did not work with the suggested kernel.

    Thanks



  • Thanks for the quick reply I will try to play with the kernels.



  • @kleber Others have had similar problems - it’s been suggested by @Sebastian-Roth that it could be ramdisk or ram related I think. One fellow solved his issue by using the next-to-last kernel (via kernel update in your web GUI).


 

360
Online

41.8k
Users

12.3k
Topics

116.0k
Posts