Restart loop after deploying snapin



  • Hello everyone

    I freshly installed the Fog-Server so i’m new to this.

    I wanted to test it and tried to install java with a snapin.
    The connection between the server and client is working but after the necessary reboot the task is still on the status “queued” and after 2 - 3 minutes it automatically reboots the client and repeats it until the task is cancelled.
    obviously it didnt install the software.
    My thought is that the task doesnt have the right permissions and cant install the software but since the task is still queued it will try it over and over again.

    I already checked the permissions on the host and the parameters of the script, disabled the firewall to see if its blocking something but nothing i did helped.

    Did anyone have this issue at the start as well?



  • @tom-elliott sorry about that!

    0_1523945512782_9e3dcf56-182d-47e1-937a-824dd9f19c3a-grafik.png

    So only to get it right, the id i want to get here is 2 on this host.
    I’m getting the same result as the last time:

    0_1523945594808_21b5b555-73b6-45f0-b8f2-2c64bbc261b4-grafik.png


  • Senior Developer

    @raviolipizza host Id is not the host name. You can find the is by going to the host. Look in the url, the id=# ( the # is the id)



  • @tom-elliott There is no task anymore for that host on the task page and I’m getting the following when im executing your query:

    0_1523857652116_fog_tasks.PNG


  • Senior Developer

    If no tasks are there, can you run this query: (chaning {hostID} to the id of the host you’re having the problem with.

    select * from tasks where taskHostID='{hostID}' and taskStateID NOT IN ('4','5')\G
    

  • Senior Developer

    Mind taking a look at your Tasks page? Is anything still there for that host? I can’t replicate the problem with a plain jane snapin task, or a deploy+snapin task.

    This really seems to be a hanging task for that machine.


  • Senior Developer

    @raviolipizza I took a look at your client logs, and it appears to be a bug with the server ( @Tom-Elliott ). The other option is that you do actually have an imaging task pending, but the computer isn’t set to boot to PXE.

    This is my theory based on the log: Snapins are being registered as a task reboot (they shouldn’t be), here’s why:

    • You stated that the reboot loop once you cancel the Snapin
    • In the log, the client reboots 8 times because of a pending imaging task:
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     13.04.2018 07:48 Client-Info Client Version: 0.11.15
     13.04.2018 07:48 Client-Info Client OS:      Windows
     13.04.2018 07:48 Client-Info Server Version: 1.5.0
     13.04.2018 07:48 Middleware::Response Success
     13.04.2018 07:48 TaskReboot Restarting computer for task
     13.04.2018 07:48 Power Creating shutdown command in 60 seconds
     13.04.2018 07:48 Bus Emmiting message on channel: Power
    ------------------------------------------------------------------------------
    
    • Therefore the server is telling the client there is a pending task that requires booting into FOS.
    • On reboot, iPXE doesn’t register that there’s a task to boot into FOS
    • So my best guess is that when talking to the client, the server must be including snapin tasks as a “You need to restart into FOS” task

  • Developer

    @raviolipizza Yeah that looks weird. I think we need to get @joe-schmitt involved here.



  • @Sebastian-Roth i tried it again a few minutes ago. in the new logfile im uploading right now there is the same error as in the last one again but right next to it there is another part with the title “Authentication” and that one looks just fine…
    0_1523599029464_fog.log



  • @Sebastian-Roth of course. like i already see, it got some problems with the certificate and the authentication but i kinda dont see where exactly is the problem or how i can solve it. the logininformation shouldnt be the problem but i dont know what exactly i have to do about the certificate message
    .0_1523540554614_fog.log


  • Developer

    @raviolipizza Can you please provide a client log file? You find that in C:\fog.log or in the FOG client program install path depending on your selection when installing the client.


 

406
Online

41.6k
Users

12.1k
Topics

114.4k
Posts