Fog Clamav


  • Testers

    Clamav doesnt work on my current setup.
    I booted a PC in Debug and ran fog.av It seems to have a problem mounting clamav.

     ==================================
       ===        ====    =====      ====
       ===  =========  ==  ===   ==   ===
       ===  ========  ====  ==  ====  ===
       ===  ========  ====  ==  =========
       ===      ====  ====  ==  =========
       ===  ========  ====  ==  ===   ===
       ===  ========  ====  ==  ====  ===
       ===  =========  ==  ===   ==   ===
       ===  ==========    =====      ====
       ==================================
       ===== Free Opensource Ghost ======
       ==================================
       ============ Credits =============
       = https://fogproject.org/Credits =
       ==================================
       == Released under GPL Version 3 ==
       ==================================
       Version: 1.5.0-RC-11
     * Mounting Clamav...................................
    Done
     * Press [Enter] key to continue
    
     * Adding clamav to path.............................Failed
     * Press [Enter] key to continue
    
    ##############################################################################
    #                                                                            #
    #                         An error has been detected!                        #
    #                                                                            #
    ##############################################################################
    Cannot find clamav binaries to run task. (/bin/fog.av)
       Args Passed:
    
    Kernel variables and settings:
    loglevel=4 initrd=init.xz root=/dev/ram0 rw ramdisk_size=127000 web=http://xxx.xxx.xxx.xxx/fog/ consoleblank=0 rootfstype=ext4 mac=00:00:00:00:00 ftp=xxx.xxx.xxx.xxx storage=xxx.xxx.xxx.xxx:/images/dev/ storageip=xxx.xxx.xxx.xxx osid=9 irqpoll hostname=PC3306 isdebug=yes
     * Press [Enter] key to continue
    

    here is the ouput of /tmp/mount-output

    mount: can't find /opt/fog/clamav in /etc/fstab
    

    Any input would be greatly appreciated.
    Thanks!



  • Rather than changing FOS /etc/fstab file, I believe it would be better to pass it as a kernel argument like clamMount=x.x.x.x:/some/clam/av/dir and have the script mount that dynamically. Then it can be user adjustable like image mounts are already.


 

385
Online

41.2k
Users

11.6k
Topics

110.7k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.