Client 0.11.12, Windows 10 1709 - Reboot fails



  • FogClient 0.11.12, Windows 10 1709 - Reboot fails after joining domain

    Regulary the reboot fails after joining domain.
    Sometimes the service fails to start (even after reboot) until it is started manually.

    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     16.01.2018 03:41 Client-Info Client Version: 0.11.12
     16.01.2018 03:41 Client-Info Client OS:      Windows
     16.01.2018 03:41 Client-Info Server Version: 1.4.4
     16.01.2018 03:41 Middleware::Response Success
     16.01.2018 03:41 HostnameChanger Checking Hostname
     16.01.2018 03:41 HostnameChanger Hostname is correct
     16.01.2018 03:41 HostnameChanger Attempting to join domain
     16.01.2018 03:41 HostnameChanger Success, code =  0
     16.01.2018 03:41 Power Creating shutdown request
     16.01.2018 03:41 Power Parameters: /r /c "Host joined to Active Directory, restart required" /t 0
     16.01.2018 03:41 Bus Emmiting message on channel: Power
     16.01.2018 03:41 Power Attempt 1/6 to shutdown computer
     16.01.2018 03:41 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 03:46 Power Attempt 2/6 to shutdown computer
     16.01.2018 03:46 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 03:51 Power Attempt 3/6 to shutdown computer
     16.01.2018 03:51 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 03:56 Power Attempt 4/6 to shutdown computer
     16.01.2018 03:56 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 04:01 Power Attempt 5/6 to shutdown computer
     16.01.2018 04:01 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 04:06 Power Attempt 6/6 to shutdown computer
     16.01.2018 04:06 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 04:11 Power Gracefull shutdown requests failed, attempting to force shutdown
     16.01.2018 04:11 Power Attempt 1/3 to shutdown computer
     16.01.2018 04:11 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 04:16 Power Attempt 2/3 to shutdown computer
     16.01.2018 04:16 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 04:21 Power Attempt 3/3 to shutdown computer
     16.01.2018 04:21 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 04:26 Power Force shutdown requests failed, bypassing any shutdown blocks
     16.01.2018 04:26 Power Attempt 1/3 to shutdown computer
     16.01.2018 04:26 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 04:31 Power Attempt 2/3 to shutdown computer
     16.01.2018 04:31 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 04:36 Power Attempt 3/3 to shutdown computer
     16.01.2018 04:36 Power --> API call returned 1, will re-attempt in 5 minutes
     16.01.2018 04:41 Power ERROR: Failed to bypass shutdown blocks, entering saftey net to ensure a shutdown
     16.01.2018 04:41 Power Issued shutdown request, will re-issue in 5 minutes
     16.01.2018 04:46 Power Issued shutdown request, will re-issue in 5 minutes```

  • Senior Developer

    @uwpviolator You should be able to use the new client, but it won’t automatically update. As far as the communications between the client the server, nothing has changed.

    The only other difference, your devices won’t automatically update to 0.11.13, unless you download the files from github, place them in place of your current files (under /var/www/fog/client/), and then edit the /var/www/fog/lib/fog/system.class.php FOG_CLIENT_VERSION line to 0.11.13.



  • @joe-schmitt Thank you. Question we are still on 1.4.4 can I use the new client with that or do we need to update the server?


  • Senior Developer

    @TrialAndError @UWPVIOLATOR v0.11.13 of the client (in the newest RC) patches the win1709 issues, thank you for your help debugging this!



  • @joe-schmitt
    I only testest the nightly.

    Downloading the SmartiInstaller.exe again is not possible because a trojan “FUERBOOS” is recognized.


  • Senior Developer

    @TrialAndError to be clear, its the nightly build I posted that works, and not stock 0.11.12?



  • I can confirm: on a clean Windows 10 1709 installation the client now works.

    The problem is now only my problem. Thread can be marked solved.



  • @uwpviolator said in Client 0.11.12, Windows 10 1709 - Reboot fails:

    @joe-schmitt First try it broke Windows. Cant event get past setup.

    I did not remove the old client before installing this one. After I removed it then installed the new one it appears to work.


  • Senior Developer

    For anyone watching the thread, I’m in contact with @UWPVIOLATOR about the issue.



  • @joe-schmitt First try it broke Windows. Cant event get past setup.


  • Senior Developer

    @UWPVIOLATOR can you try this build: https://build.jbob.io/Client/nightly/02-05-win1709-01/SmartInstaller.exe ?

    @TrialAndError that’s actually good news, it means we can reliably replicate the issue, and its causing an error we can trace as well. I’ll send you a PM about this, but it’d be extremely helpful if I could remote into a computer to further debug on a machine with the issue.



  • @joe-schmitt I installed your nightly client build. It does not work and I can not even start the service. Gives me this error.

    0_1517598099489_cf389cdc-902b-4f72-9bc3-47529daeca29-image.png



  • @joe-schmitt
    I manually stopped/started FOGService but no effect.


  • Senior Developer

    @TrialAndError if you set the service to delayed start, or manually stop and start up the client after boot, then does it work?



  • @joe-schmitt

    Sorry,

    my machine still does not reboot. The desktop client shows up and vanishes but no power event is executed.

    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     02.02.2018 09:07 Client-Info Client Version: 0.11.12
     02.02.2018 09:07 Client-Info Client OS:      Windows
     02.02.2018 09:07 Client-Info Server Version: 1.4.4
     02.02.2018 09:07 Middleware::Response Success
    ------------------------------------------------------------------------------
    
     02.02.2018 09:07 Service Sleeping for 132 seconds
     02.02.2018 09:08 Power Creating shutdown request
     02.02.2018 09:08 Power Parameters: /r /c "FOG PowerManagement" /t 0
     02.02.2018 09:08 Bus Emmiting message on channel: Power
     02.02.2018 09:08 Power Attempt 1/6 to shutdown computer
     02.02.2018 09:08 Power --> API call returned 0, will re-attempt in 5 minutes
     02.02.2018 09:09 Power ERROR: Could not create shutdown command from request
     02.02.2018 09:09 Power ERROR: Die Laufzeitbindung kann für einen NULL-Verweis nicht ausgeführt werden.
    

  • Senior Developer

    @TrialAndError @UWPVIOLATOR @x23piracy @dclark I believe I have isolated the issues with Windows 1709 and patched them. Could you try installing this build of the client on a few machines to test? (You may need to hit Reset Encryption Data for the hosts if you are uninstalling an existing FOG Client and installing this build). With any luck it will fix all issues with the service failing to start, and not shutting down the computer correctly.

    https://build.jbob.io/Client/nightly/02-01-2018-win1709-04/SmartInstaller.exe

    NOTE: This is a nightly build and is not production compatible! Imaging it may produce security warnings from Windows or your anti virus software.



  • @joe-schmitt

    “power restart” did restart my machine. Success!


  • Senior Developer

    @UWPVIOLATOR @x23piracy after running the debugger in the prior post, can you also try installing this build of the client on a few machines: https://build.jbob.io/Client/nightly/01-32-2018-win-dependencies-01/SmartInstaller.exe ?

    It likely wont fix the shutdown issue, but it should allow the client to consistently start up with Windows.


  • Senior Developer

    @UWPVIOLATOR @x23piracy can you try the following stops on a problematic machine?

    • In an administrative CMD, stop the fogservice if it is still running: net stop fogservice
    • Download and extract this file anywhere on the machine: PowerDebugger.zip
    • Run the Debugger.exe contained in the extracted folder as Administrator
    • Type the following commands into the debugger’s prompt (one at a time, and pressing enter after each line)
    bus mode server
    power restart
    

    The debugger will then schedule the client’s restart process in 60 seconds. Can you let me know if it successfully restarts the machine? If not I’ll need the full output of the Debugger window.



  • @Joe-Schmitt Another thing I am seeing is on 2 different models. HP Elitebook 840 G1 and a HP Elitedesk 8300. The 840 will start the fog service, name and join domain but not do the final reboot. The 8300 doesn’t start FOG. Setupcomplete.cmd worked as the FOG service is set to Automatic but again its a reboot to start up.


 

331
Online

41.5k
Users

11.9k
Topics

113.2k
Posts