Not able to finish client registration



  • Server: Cent OS 6.8
    Fog v: 1.4.4
    Kernel: 4.13.4

    Recently upgraded from Fog 1.2 to 1.4.4. The client will pxe boot to registration page. As soon as I choose any option like quick registration, deploy image, full registration. The next window starts to capture the client information, bzImage and init start to load and then Fog quits and the client will restart.

    I can change kernels, all ftp permissions are correct. No matter the kernel the same result. Thanks for your help



  • @sebastian-roth @george1421

    Without your guidance i would have not been able to provide that information to you. Linux is still relatively unknown to me. I know what I am able to google, read in your wiki, or do as you posted here. Everyone’s help was much appreciated.


  • Developer

    @joyboy11111 @george1421 Yeah, great you guys have already solved this. That’s why I keep asking people to take videos or capture network packets. As only if we see what’s really going on we can drive the right way. By simply asking questions this would have taken us many more days to figure out…


  • Moderator

    @joyboy11111 That is why having screen shots and videos are very important step in debugging. The answer to your issue was only on 7 frames of your video. Knowing how FOG/FOS boots and connecting with the video was the answer.

    I’m glad you have it going now.



  • @george1421 Look at you!! you are a genius. Rookie mistake, FOG_TFTP_PXE_KERNEL: bzImage_4.1.2 was the issue. Set as you listed above, presto FOG is happy again. Thank You.


  • Moderator

    @joyboy11111 Well I just have to double check the video to see. And again it says bzImage_4.1.2 ok. So it says it transferred something, but you don’t have bzImage_4.1.2 in the services directory at all. Very strange.

    Here is what I want you to do.

    1. Go to the fog webgui
    2. Go into fog settings.
    3. Scroll down to TFTP Server
    4. Confirm the following fields.
      FOG_TFTP_PXE_KERNEL: bzImage
      FOG_TFTP_PXE_KERNEL_32: bzImage32
    5. If they are not setup like above, please correct
    6. Save the settings
    7. Reboot the target computer repeating the same steps you posted in the video.



  • Moderator

    @joyboy11111 So what I’m seeing here is that the system is pxe booting correctly into the fog ipxe menu, when you pick quick registration the target computer loads bzImage and init.xz then either FOS blows up or just terminates existing to booting the first hard drive. It never appears that the FOS actually boots, but aborts immediately.

    [edit] ok what is that? scrubbing the video frame by frame, at 15 seconds, why does it say bzImage_4.1.2? It appears someone as change fog’s default settings and possibly the default boot kernel for FOS?

    We need you to post the output of this command executed on your fog server.
    ls -la /var/www/html/fog/service/ipxe




  • Developer

    @joyboy11111 From the little information we’ve gathered so far I think those are several different issues - all hardware related.

    I tried to deploy an image from the registration screen and the screen that follows is a black screen with the cursor blinking.

    I think you need to take a video of that process so we know exactly what you mean. From my point of view there no way to “deploy an image from the registration screen”. I think this is just some wording issue when I don’t properly get what you mean. You can try to describe in more detail but I reckon taking a video will make it much more easy to understand.



  • Does the blinking cursor happen after it is done imaging?



  • I have tested on 3 models:

    HP Mini 400 g3 Skylake
    HP Mini 400 g3 Cabby
    Both of the HP models go back to a regular windows boot, these models have not been registered
    Lenovo m700 Skylake is registered and Fog recognizes this. I tried to deploy an image from the registration screen and the screen that follows is a black screen with the cursor blinking.
    I deleted the lenovo machine from host management and tried to register the client. Same result, blank screen with cursor blinking.


  • Developer

    @joyboy11111 Do you see this happening on different client hardware? How many different have you tested yet? Or do you only have one model available? Just trying to figure out how to tackle this.


 

331
Online

41.4k
Users

11.8k
Topics

112.2k
Posts