Ubuntu 17.10 Desktop PXE boot - No Internet



  • So here is the issue. I finally got Ubuntu 17.10 Desktop to boot up over PXE, but after it loads I don’t have internet. To be honest, it appears as if the network adapter didn’t load at all. What am I doing wrong? Here is my advanced menu entry for ubuntu:

    :ubuntu
    kernel http://${fog-ip}/${fog-webroot}/images/ISO/LINUX/ud1710x64/casper/vmlinuz.efi || read void
    initrd http://${fog-ip}/${fog-webroot}/images/ISO/LINUX/ud1710x64/casper/initrd.lz || read void
    imgargs vmlinuz.efi initrd=initrd.lz root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/media/images/ISO/LINUX/ud1710x64 ip=dhcp splash quiet -- || read void
    boot || goto failed
    goto start
    

    Also, what type of code is the advanced menu options? It annoys me that I have to rely on everyone else’s code instead of knowing it good enough to just put in what I need when I need it.
    Thanks for the help everyone.



  • you can ping 8.8.8.8 it’s a DNS issue not your config ! because your only not able to resolve


  • Moderator

    @steven-attaway Yes I agree that http would be faster. We have seen issues with apache redirection breaking hosting other files on the fog http server. That is why I switched to another protocol to provide consistency. So yes http, is much faster than tftp. But you statement makes me think you are doing this activity for imaging, but for some other activity (maybe akin to LTSP )?? Or if you are making a thin client setup there are other options.

    As for the speed issue with tftp vs http. It would be interesting to see if switching the boot protocol from http, to nfs could yield similar transfer rates. But if http is working for you, then keep moving forward with it.

    In regards to loading from dvd vs pxe booting. The only thing you are doing with pxe booting is transferring the kernel and initrd from the fog server instead of loading them from the local dvd rom. Once the kernel is booted it connects to the dvd files via nfs. There should be no real difference between networking capabilities. In regards to not being able to resolve dns names, I would check what the /etc/resolv.conf file is setup to. That file is responsible for configuring the dns lookups.



  • @george1421 OK, so I ended up using your method, but then went back to my method of using http instead of tftp. I found http loaded almost 30 secs. to a minute faster. Here’s my code for that:

    :ubuntu
    kernel http://${fog-ip}/${fog-webroot}/images/ISO/LINUX/ud1710x64/casper/vmlinuz.efi
    initrd http://${fog-ip}/${fog-webroot}/images/ISO/LINUX/ud1710x64/casper/initrd.lz
    imgargs vmlinuz.efi root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/images/ISO/LINUX/ud1710x64 quiet splash ip=dhcp rw
    boot || goto failed
    goto start
    

    Which loaded great, but this brings me back to my original issue. No Internet, Kind of. So I technically am getting internet, but DNS doesn’t seem to be loading correctly. I can ping 8.8.8.8 all day long, but if I try to ping www.google.com, it fails.0_1510327017024_20171110_090539.jpg
    So then I was going to go into the network settings to confirm the DNS settings and I get this:0_1510327079423_20171110_090456.jpg
    If I load everything from a CD or USB it all loads great, if I load from PXE it does the same thing every time. Thoughts?


  • Moderator


  • Moderator

    I am currently in the process of downloading Ubuntu 17.10 Desktop to confirm the settings. I’ll create a post in the tutorial thread with how I get it configured. Its a better way than just guessing at the settings.

    Also thank you for testing on the ubuntu installer side. I’ll get that post updated with the proper info too.


  • Moderator

    To keep your configuration in line with the totorial lets do the following:

    Move your iso content from /images/ISO/LINUX/ud1710x64 to /images/os/ubuntu/ud1710x64

    Then create the tftp directory

    mkdir /tftpboot/os
    mkdir /tftpboot/os/ubuntu
    mkdir /tftpboot/os/ubuntu/ud1710x64
    
    cp /images/os/ubuntu/ud1710x64/casper/vmlinuz.efi  /tftpboot/os/ubuntu/ud1710x64
    cp /images/os/ubuntu/ud1710x64/casper/initrd.lz  /tftpboot/os/ubuntu/ud1710x64
    

    Now in the webgui

    kernel tftp://${fog-ip}/os/ubuntu/ud1710x64/casper/vmlinuz.efi
    initrd tftp://${fog-ip}/os/ubuntu/ud1710x64/casper/initrd.lz
    imgargs vmlinuz initrd=initrd.gz root=/dev/nfs netboot=nfs nfsroot=${fog-ip}:/images/os/ubuntu/ud1710x64/ locale=en_US.UTF-8 ip=dhcp rw


  • Moderator

    Ok give me a minute. We may need to meld the configurations.

    My docs use nfs all the way. You are mixing http and nfs. The http means that you have to put your files under /var/www/html to be able to access them.



  • @george1421 Alright, so I did everything you said on the first post and it did fail with me too. I went to http://archive.ubuntu.com and downloaded the netboot kernel (linux) and the netboot initrd (initrd.gz), but now it goes straight to the Ubuntu Installer. I’m actually wanting the live desktop.


  • Moderator

    @steven-attaway Suggestion, follow this post: https://forums.fogproject.org/topic/10944/using-fog-to-pxe-boot-into-your-favorite-installer-images/6

    Just as a word of caution, this post worked for me properly when I wrote the tutorial. I did have one feedback stating that the stock ubuntu kernel won’t netboot, you need the ubuntu netboot kernel and initrd for that. https://forums.fogproject.org/topic/11027/problems-with-using-fog-to-pxe-boot-into-your-favorite-installer

    If you would, please follow my tutorial exactly and test it. If it doesn’t work then please use the kernel and initrd that was referenced in the second link.

    I need your help to improve the quality of the tutorial before the instructions get moved into the wiki.


Log in to reply
 

427
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.