Problems with using-fog-to-pxe-boot-into-your-favorite-installer

  • @george1421 excelent guide, all the linux guides was very good, had some problems with ubuntu because i did not use the vmlinuz and initrd from “” which might be nice to have in the guide.
    im not sure if i have done something wrong following your Windows 10 guide, but i manage to boot into windows, but dont get past some driver issues in windows “A media driver your computer needs is missin. i also had to use tftp instead of nfs, because it was not supported… do you know whats going on hereg”

  • I just wanted to add to this -
    If you have an antique server that totally and completely lacks UEFI support (such as my ML350 Gen8) then you can just follow the instructions that @george1421 posted for Windows ISO’s to boot any (most) ISO’s in legacy mode. I just tested it with VMWare 6.7U2 on the HP ML350 Gen8, worked flawlessly.

  • I hate to beat a dead horse, but I just wanted to say thank you for this in depth tutorial. It is amazing. Thank you!

  • @george1421 Fantastic!!! I got Mint running and booting live over the network. Thank you so much for the info.

    For everyone’s use I created:

    /images/os/mint where I used 7z to extract the entirety of the mint.iso
    /tftpboot/mint where I placed the vimlinuz and initrd.lz from the casper folder in the previously mentioned extracted iso.

    My menu item in PXE is now this:

    kernel tftp://${fog-ip}/mint/vmlinuz
    initrd tftp://${fog-ip}/mint/initrd.lz
    imgargs vmlinuz initrd=initrd.lz root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/images/os/mint systemd.mask=tmp.mount ip=dhcp rw

    Boots great!! ClamAV scanning of Windows drives here I come!

  • Moderator

  • Hey peeps,

    I’ve managed to get the installer portion running using a plethora of info out there but what really worked for me is this:

    Downloaded vmlinuz and initrd.gz from the netboot version of Ubuntu and placed them into the tftp root folder:

    Ubuntu Netboot

    Created a folder in /images/os called ubuntu and used 7z to extract Ubuntu 18.04 iso into this folder.

    My menu entry now looks like this:

    kernel tftp://${fog-ip}/ubuntu/vmlinuz
    initrd tftp://${fog-ip}/ubuntu/initrd.gz
    imgargs vmlinuz initrd=initrd.gz root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/images/os/ubuntu splash ip=dhcp rw

    It now boots on any machine into an Ubuntu Installer BUT!

    This is great but not my final wish.

    Is there a way to avoid the straight to install process and at least load a Live CD so that I could use Ubuntu to say scan the PC’s drive with clamav?

    Any help would be great!


  • Moderator

    @Gamienator Thank you for the feedback and info, I will get the tutoral updated right away.

  • Hi there,

    I just noticed that on Linux Mint 19 and newer it’s not possible to boot anymore before you change the Boot Parameter! I got it going on after setting this:

    imgargs vmlinuz root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/var/www/html/iso/mint/ locale=de_DE.UTF-8 keyboard-configuration/layoutcode=de ip=dhcp toram -- || read void

    Keep in mind, I got a different folder! But the parameter toram is damn important, otherwise it’s not able to mount /tmp and goes into emergency mode!

    Maybe you want to update the wiki?

  • @george1421 I symlinked my /tftpboot to var/www/html/fog/ so that everything i do under tftpboot in the os folder is available via http.

    Turns out this works…

    kernel http://${fog-ip}/fog/os/win/wimboot pause gui
    initrd --name segmono_boot.ttf http://${fog-ip}/fog/os/win/winpe/amd64/media/Boot/Fonts/segmono_boot.ttf segmono_boot.ttf
    initrd --name segoe_slboot.ttf http://${fog-ip}/fog/os/win/winpe/amd64/media/Boot/Fonts/segoe_slboot.ttf segoe_slboot.ttf
    initrd --name segoen_slboot.ttf http://${fog-ip}/fog/os/win/winpe/amd64/media/Boot/Fonts/segoen_slboot.ttf segoen_slboot.ttf
    initrd --name wgl4_boot.ttf http://${fog-ip}/fog/os/win/winpe/amd64/media/Boot/Fonts/wgl4_boot.ttf wgl4_boot.ttf
    initrd --name BCD http://${fog-ip}/fog/os/win/winpe/amd64/media/Boot/BCD BCD
    initrd --name boot.sdi http://${fog-ip}/fog/os/win/winpe/amd64/media/Boot/boot.sdi boot.sdi
    initrd --name boot.wim http://${fog-ip}/fog/os/win/winpe/amd64/media/sources/boot.wim boot.wim
    boot || goto MENU

    Had to add the 4 lines for fonts and now it boots in UEFI. I am amazed this was the issue and only on this machine. The fonts btw where in the locations, so its not like moving them into tftpboot was a problem. It was explicitly placing the initrd lines for the fonts in the ipxe entry that made it work…go figure.

  • Moderator

    @zer0cool said in Problems with using-fog-to-pxe-boot-into-your-favorite-installer:

    http://${fog-ip}/fog/os/win/winpe/amd64/media/Boot/boot.sdi boot.sdi

    This is a risky path to place your files in. At the very least I would move them out of the /var/www/html/fog directory. The fog installer has been known to remove unexpected files in its path. My instructions suggest to use tftp protocol for testing.

  • @george1421 Hey, re: our pm’s with winpe and UEFI, I am still having trouble. Let me know if you would rather I create a new post for my issue or if its ok to carry on here.

    kernel http://${fog-ip}/fog/os/win/wimboot gui
    initrd --name BCD http://${fog-ip}/fog/os/win/winpe/am64/media/Boot/BCD BCD
    initrd --name boot.sdi http://${fog-ip}/fog/os/win/winpe/amd64/media/Boot/boot.sdi boot.sdi
    initrd --name boot.wim http://${fog-ip}/fog/os/win/winpe/amd64/media/sources/boot.wim boot.wim
    boot || goto MENU

    It loads the files, has about a dozen lines about patching the WIM file, says its loading ‘bootx64.efi’ and then just reboots (machine makes a single beep). It never gets to loading the winpe environment. BIOS it boots fine and moves on to winpe.

    I tried with/without:

    • ‘gui’ (on the kernel line)
    • ‘pause’ (on kernel line)
    • ‘rawbcd’ (on gui line)

    None of the above changed anything. I also rebuilt my winpe files using copype amd64 /path and still had same issue. When re-creating (using copype) I didnt even bother adding the commands to connect to network and run installer.

    I have seen others add 4 lines for fonts, I am going to give that a shot too. I also am searching for another viable test box to ensure its not just the specific hardware I am using.

    I am running copype on a Windows Server 2016 box with newest MDT and ADK. wimboot is latest, 2.6.0 I think (on FOG machine).

    Any help would be awesome, Thanks!

    EDIT: ok must be something about the Dell Precision Tower 3620. UEFI boot worked on an R620. I even added the latest Dell Winpe 10 drivers to the boot.wim and still get the crash when UEFI booting. Still could use a solution, but it may end up just being that this specific model is allergic to ipxe/winpe

  • Moderator

    @taspharel What are you having issues with, with SystemRescueCD? I just downloaded the ISO and you should be able to extract it and make it boot via pxe. There is a kernel file and an initrd file.

    I’m currently in the process of downloading ubuntu desktop 17.10.1 to see if there is a difference.

  • I seem to have a similar problem when trying to run System Rescue Disk via PXE. Also something about not finding root or along those lines.

    Will try booting on another machine to make sure that its not related to the Lenovo Laptop I am using …

  • Yes.

    the DVD is extracted to /images/os…
    The Kernel and init are in the tftpboot-path

    The kernel and init load when I select the Ubuntu Entry in my FOG Menu, but after that when Ubuntu seems to take over -> error.

  • Moderator

    @taspharel So you have the kernel and init in the /tftpboot/os/… path and the entire DVD in the /images/os/… path?

  • My fog ipxe menu item has the following parameters:

    kernel tftp://${fog-ip}/os/ubuntu/Desk17.10/vmlinuz.efi
    initrd tftp://${fog-ip}/os/ubuntu/Desk17.10/initrd.lz
    imgargs vmlinuz.efi root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/images/os/ubuntu/Desk17.10/locale=de_AT.UTF-8 keyboard-configuration/layoutcode=de quiet splash ip=dhcp rw
    boot || goto MENU

  • Moderator


    Please post what you have for your fog ipxe menu configuration. The error basically means that the kernel doesn’t understand the virtual hard drive (initrd.lz)

  • Hi George1421.

    Thanks for the great tutorials.

    Two questions:

    Do you have an up to date tutorial for using SystemRescueCD (recent version is 5.2.2 i believe)

    And more pressing:

    When I follow your Ubuntu 17.10 Desktop instructions, everything works fine until I actually try to boot, when the boot process starts I get a Kernel panic:

    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,255)

    Then some more lines and at the end again the same error message.

    Any idea on what could be causing this?

    Edit: Just noticed that I used 17.10.1, not 17.10, will try with 17.10 and report back - aaand, there is no 17.10 “non-.1” on the official ubuntu download page :(

  • This post is deleted!

Log in to reply