HP ProBook 470 G4

  • via FOG 1.4.4 and kernel

    I can UEFI PXE (ipxe.efi) boot this laptop fine, but when it comes to actually doing any work with say, Deploy Image I wind up with: ok
    bzImage... ok
    init.xz... ok
    Could not boot: No such device (http://ipxe.org/2c0408087)

    Legacy PXE booting (undionly,kpxe) it will image fine.

    I will have this laptop for just today so I don’t know if I’ll be able to do any troubleshooting.

  • Moderator

    @tom-elliott Just looking at rom-o-matic 1b67a is the latest release. I’m not in a place right now to see what boot version is in 1.4.4. I can check later tonight. But I would suspect that 1.5.0RC9 will have the fixed version of ipxpe where/when/since ipxe7156.efi was removed from fog.

  • ipxe.efi (1b67a) is the latest from the github repo linked above.

  • Senior Developer

    So we can solve this, or 1b67a is very old ipxe file?

  • Good news everyone!

    ipxe.efi (1b67a) works.

  • No. Secure boot is not on.

    ipxe7156.efi works. ugh.

  • Developer

    @sudburr Possibly secure boot is on??

    And by the way, … which iPXE is used here??

    We have seen an issue with a device from ASUS, see here: https://forums.fogproject.org/topic/9361/could-not-boot-no-such-device (here the older ipxe7156 binary helped - though you can use those binaries in 1.4.4 we’ve tossed those out in the current working branch as the surface issue was resolved in the latest iPXE version some weeks ago. So you can also try the latest iPXE binary from the github repo)

  • Firmware is latest yes. 1.06

  • Moderator

    @sudburr Hmm well that ipxe boot menu looks OK. Its still not clear why its getting the boot device failure. Have you checked to see if you have the latest firmware on that device?

  • Results

    set fog-ip
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web= consoleblank=0 rootfstype=ext4 mac=48:ba:4e:51:d9:e2 ftp= storage= storageip= osid=9 irqpoll hostname=48ba4e51d9e2 chkdsk=0 img=Win_10x64_C_20170314_UEFI imgType=n imgPartitionType=all imgid=77 imgFormat=0 PIGZ_COMP=-3 type=down
    imgfetch init_32.xz

    Then I:

    1. Created a host entry for the client computer
    2. Switched client back to UEFI
    3. Scheduled a deploy from FOG to client computer
    4. Client computer picked up task but then fails again with same error after init.xz

  • Moderator

    @sudburr well lets see what happens here.

    Schedule a deploy on this specific computer again in uefi mode.

    Don’t pxe boot the computer, but key in the following into a browser:<mac_addr_of_probook>

    Post the results here.

  • It IS an odd one.

    1. In UEFI mode
      a. Perform Full Host Registration and Inventory (init.xz… then returns to menu)
      b. Quick Registration and Inventory (init.xz… then returns to menu)
      c. Deploy Image ( see error above )
      d. Join Multicast Session (same as Deploy Image)
      e. Client System Information (init.xz… then returns to menu)

    2. In Legacy mode
      … waiting on other stuff right now… will edit this ina few minutes.

  • Moderator

    @sudburr said in HP ProBook 470 G4:

    You have a contradiction here.

    Lets take a step back. If the laptop is in uefi mode, can you register it?

    Or do you get a no such device error?

    Or does it image fine but on reboot you get a no such device when exiting from the fog iPXE menu?

Log in to reply