1.4.4 install fails - add-apt-repository: command not found



  • I upgraded my server from 14 to Ububtu 16.04. I am reinstalling fog and keep getting the error message

    …/lib/common/functions.sh: line 616: add-apt-repository: command not found

    Seems simple enough until I try and fix the issue. I get the following

    The following additional packages will be installed:
    python-apt
    The following packages will be REMOVED:
    apt gnupg gnupg-agent pinentry-curses

    Which warns that it could be potentially harmful to continue. I decided to continue and indeed apt was broken and updates or installs were no longer possible including completing the Fog installation.

    What could be wrong or what have I missed?



  • @sebastian-roth said in 1.4.4 install fails - add-apt-repository: command not found:

    apt-get install software-properties-common

    I may have to go with the 2nd fix and get newer packages from Yakkety to resolve the issue. This server is our office Domain controller as well as imaging server. So breaking the Samba shares and logins will have my team up in arms come Monday morning.

    So sad they let this bug slip through. My plan of upgrading all my remote servers and installing Fog has hit a major road bump.

    I am going to create a VM and install the latest version of Zentyal from the ISO and see if that makes any difference.

    Thank you for all your patience and invaluable assistance. Above and Beyond by far!


  • Developer

    @Sanga-Collins LOL, now that we know what’s wrong it was easy to find other people being in the same situation: https://forum.zentyal.org/index.php?topic=31231.0

    From my point of view this is something Zentyal is doing wrong and they should fix it. For now you can live with disabling that repo I reckon.

    Edit: And another one here: https://forum.zentyal.org/index.php?topic=30815.0
    If you are keen to stay with Zentyal you can follow those instructions, download newer Yakkety package versions from launchpad and install those by hand. Very ugly and I am sure it’ll break something else very soon. Don’t go there if you don’t really know what you do.


  • Developer

    @Sanga-Collins Sorry, my fault. Should have been apt-cache policy ... or apt policy ... works just as well.

    Now we’re getting closer. It’s coming from that zentyal repository… So edit your /etc/apt/sources.list and comment (put a # hash tag in front of) that line “deb http://archive.zentyal.org/zentyal …”

    apt-get clean
    apt-get autoclean
    apt-get update
    apt-get install software-properties-common
    


  • @sebastian-roth said in 1.4.4 install fails - add-apt-repository: command not found:

    apt-get policy gnupg

    Turns out the command was apt policy gnupg. The results are below

    apt policy gnupg
    gnupg:
      Installed: 2.1.15-1ubuntu6
      Candidate: 2.1.15-1ubuntu6
      Version table:
     *** 2.1.15-1ubuntu6 500
            500 http://archive.zentyal.org/zentyal 5.0/main amd64 Packages
            100 /var/lib/dpkg/status
         1.4.20-1ubuntu3.1 500
            500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
            500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
         1.4.20-1ubuntu3 500
            500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    

  • Developer

    @Sanga-Collins What do you get from apt-get policy gnupg?

    Edit: The version 2.1.15-1ubuntu6 of gnupg kind of looks like it came from ubuntu zesty (check the version numbers here: https://packages.ubuntu.com/search?keywords=gnupg). I still don’t know how this could happen. Maybe you tried upgrading to 17.04 at some stage but then went back to 16.04???



  • apt-get clean had no results, apt-cache show gnupg results are below.

    # apt-get clean
    # apt-cache show gnupg
    Package: gnupg
    Source: gnupg2
    Version: 2.1.15-1ubuntu6
    Architecture: amd64
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Installed-Size: 1738
    Depends: gnupg-agent (= 2.1.15-1ubuntu6), libassuan0 (>= 2.0.1), libbz2-1.0, libc6 (>= 2.15), libgcrypt20 (>= 1.7.0), libgpg-error0 (>= 1.14), libksba8 (>= 1.3.4), libreadline7 (>= 6.0), libsqlite3-0 (>= 3.7.15), zlib1g (>= 1:1.1.4)
    Recommends: dirmngr (= 2.1.15-1ubuntu6), gnupg-l10n (= 2.1.15-1ubuntu6)
    Suggests: parcimonie, xloadimage
    Breaks: debsig-verify (<< 0.15), dirmngr (<< 2.1.0~), gnupg2 (<< 2.1.11-7+exp1), libgnupg-interface-perl (<< 0.52-3), libgnupg-perl (<= 0.19-1), libmail-gnupg-perl (<= 0.22-1), monkeysphere (<< 0.38~), php-crypt-gpg (<= 1.4.1-1), python-apt (<= 1.1.0~beta4), python-gnupg (<< 0.3.8-3), software-properties-common (<= 0.96.24.3)
    Replaces: gnupg2 (<< 2.1.11-7+exp1)
    Provides: gpg
    Multi-Arch: foreign
    Homepage: https://www.gnupg.org/
    Priority: optional
    Section: utils
    Filename: pool/main/g/gnupg2/gnupg_2.1.15-1ubuntu6_amd64.deb
    Size: 777960
    SHA256: d86136b86e8e352c329336466efbf6faf0d029968322a58b2289b3a4aa6c4498
    SHA1: 7c75fd806197e6ccd33b40b135e79a5af7bb333d
    MD5sum: 3213eab4f9fd733fb28995e9852f1c0c
    Description: GNU privacy guard - a free PGP replacement
     GnuPG is GNU's tool for secure communication and data storage.
     It can be used to encrypt data and to create digital signatures.
     It includes an advanced key management facility and is compliant
     with the proposed OpenPGP Internet standard as described in RFC4880.
     .
     This package contains /usr/bin/gpg and some helper utilities like
     gpgconf and kbxutil.
    Description-md5: e0a75e34d2b98be880e3fca6a5088ca5
    Original-Maintainer: Debian GnuPG Maintainers <pkg-gnupg-maint@lists.alioth.debian.org>
    
    Package: gnupg
    Architecture: amd64
    Version: 1.4.20-1ubuntu3.1
    Multi-Arch: foreign
    Priority: important
    Section: utils
    Origin: Ubuntu
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Original-Maintainer: Debian GnuPG-Maintainers <pkg-gnupg-maint@lists.alioth.debian.org>
    Bugs: https://bugs.launchpad.net/ubuntu/+filebug
    Installed-Size: 1680
    Depends: gpgv, libbz2-1.0, libc6 (>= 2.15), libreadline6 (>= 6.0), libusb-0.1-4 (>= 2:0.1.12), zlib1g (>= 1:1.1.4)
    Suggests: gnupg-curl, gnupg-doc, libpcsclite1, parcimonie, xloadimage | imagemagick | eog
    Filename: pool/main/g/gnupg/gnupg_1.4.20-1ubuntu3.1_amd64.deb
    Size: 625938
    MD5sum: 955b23eb62539452a8aa37e34e6f77c1
    SHA1: c4a2dce178bc097fdef9bee47fd205ff4d8656f8
    SHA256: 19c1ccd4e3a24184a35e7d601418b2a1c473ec9c15662580dc74a91d5f8eaea6
    Homepage: https://www.gnupg.org
    Description-en: GNU privacy guard - a free PGP replacement
     GnuPG is GNU's tool for secure communication and data storage.
     It can be used to encrypt data and to create digital signatures.
     It includes an advanced key management facility and is compliant
     with the proposed OpenPGP Internet standard as described in RFC 4880.
     .
     GnuPG 1.4 is the standalone, non-modularized series. In contrast to
     the version 2 series, shipped with the gnupg2 package, it comes
     with no support for S/MIME and some other tools useful for desktop
     environments, but also with less dependencies.
     .
     The gnupg package is built without libcurl. So it does not support
     HKPS keyservers. Install the gnupg-curl package if you want to use
     the keyserver helper tools built with libcurl and supporting HKPS.
    Description-md5: f9c3b47becaeff9b3854707a8cb94146
    Task: minimal
    Build-Essential: yes
    Supported: 5y
    
    Package: gnupg
    Priority: important
    Section: utils
    Installed-Size: 1680
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Original-Maintainer: Debian GnuPG-Maintainers <pkg-gnupg-maint@lists.alioth.debian.org>
    Architecture: amd64
    Version: 1.4.20-1ubuntu3
    Depends: gpgv, libbz2-1.0, libc6 (>= 2.15), libreadline6 (>= 6.0), libusb-0.1-4 (>= 2:0.1.12), zlib1g (>= 1:1.1.4)
    Suggests: gnupg-curl, gnupg-doc, libpcsclite1, parcimonie, xloadimage | imagemagick | eog
    Filename: pool/main/g/gnupg/gnupg_1.4.20-1ubuntu3_amd64.deb
    Size: 625630
    MD5sum: ace943be4e385a91b6d709c78a77f0fb
    SHA1: b045d34360f8eb41360a4c480f165237826ae18b
    SHA256: 55342635cea65fd4f8f18bfc3a0c3113f3de6f5d7a755562ebbab7ba75a9dbd0
    Description-en: GNU privacy guard - a free PGP replacement
     GnuPG is GNU's tool for secure communication and data storage.
     It can be used to encrypt data and to create digital signatures.
     It includes an advanced key management facility and is compliant
     with the proposed OpenPGP Internet standard as described in RFC 4880.
     .
     GnuPG 1.4 is the standalone, non-modularized series. In contrast to
     the version 2 series, shipped with the gnupg2 package, it comes
     with no support for S/MIME and some other tools useful for desktop
     environments, but also with less dependencies.
     .
     The gnupg package is built without libcurl. So it does not support
     HKPS keyservers. Install the gnupg-curl package if you want to use
     the keyserver helper tools built with libcurl and supporting HKPS.
    Description-md5: f9c3b47becaeff9b3854707a8cb94146
    Multi-Arch: foreign
    Homepage: https://www.gnupg.org
    Bugs: https://bugs.launchpad.net/ubuntu/+filebug
    Build-Essential: yes
    Origin: Ubuntu
    Supported: 5y
    Task: minimal
    

  • Developer

    @sanga-collins Maybe it just needs a cleanup of the apt DB: apt-get clean, then try again installing the packages…

    As well run apt-cache show gnupg and post results.



  • @sebastian-roth said in 1.4.4 install fails - add-apt-repository: command not found:

    apt-cache showpkg gnupg

    this command provided a lot of information, but I am not sure where to begin breaking it down. Here are the results.

    apt-cache showpkg gnupg
    Package: gnupg
    Versions:
    2.1.15-1ubuntu6 (/var/lib/apt/lists/archive.zentyal.org_zentyal_dists_5.0_main_binary-amd64_Packages) (/var/lib/dpkg/status)
     Description Language:
                     File: /var/lib/apt/lists/archive.zentyal.org_zentyal_dists_5.0_main_binary-amd64_Packages
                      MD5: e0a75e34d2b98be880e3fca6a5088ca5
    
    1.4.20-1ubuntu3.1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_binary-amd64_Packages) (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_xenial-security_main_binary-amd64_Packages)
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-amd64_Packages
                      MD5: f9c3b47becaeff9b3854707a8cb94146
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-i386_Packages
                      MD5: f9c3b47becaeff9b3854707a8cb94146
     Description Language: en
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_i18n_Translation-en
                      MD5: f9c3b47becaeff9b3854707a8cb94146
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_binary-amd64_Packages
                      MD5: f9c3b47becaeff9b3854707a8cb94146
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_binary-i386_Packages
                      MD5: f9c3b47becaeff9b3854707a8cb94146
    
    1.4.20-1ubuntu3 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-amd64_Packages)
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-amd64_Packages
                      MD5: f9c3b47becaeff9b3854707a8cb94146
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-i386_Packages
                      MD5: f9c3b47becaeff9b3854707a8cb94146
     Description Language: en
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_i18n_Translation-en
                      MD5: f9c3b47becaeff9b3854707a8cb94146
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_binary-amd64_Packages
                      MD5: f9c3b47becaeff9b3854707a8cb94146
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_binary-i386_Packages
                      MD5: f9c3b47becaeff9b3854707a8cb94146
    
    
    Reverse Depends:
      gnupg-dbg,gnupg 1.4.20-1ubuntu3.1
      libknewstuff3-4,gnupg
      apt,gnupg
      playonlinux,gnupg
      pepperflashplugin-nonfree,gnupg
      python-simplestreams,gnupg
      oem-config-remaster,gnupg
      libknewstuff3-4,gnupg
      libknewstuff2-4,gnupg
      gnupg-curl,gnupg
      evolution,gnupg
      enigmail,gnupg 2
      gnupg:i386,gnupg
      snapd,gnupg
      python3-simplestreams,gnupg
      livecd-rootfs,gnupg
      libdpkg-perl,gnupg
      gpgv,gnupg
      seahorse-daemon,gnupg 1.4.7
      dpkg-dev,gnupg
      debootstrap,gnupg
      apt,gnupg
      primesense-nite-nonfree,gnupg
      playonlinux,gnupg
      pepperflashplugin-nonfree,gnupg
      zescrow-client,gnupg
      wsl,gnupg
      wotsap,gnupg
      wl-beta,gnupg
      wl,gnupg
      uck,gnupg
      ubuntu-core-libs,gnupg
      ubuntu-cloud-keyring,gnupg
      torbrowser-launcher,gnupg
      topal,gnupg
      tla,gnupg
      tin,gnupg
      sqwebmail,gnupg
      sitesummary-client,gnupg
      sitesummary,gnupg
      signing-party,gnupg
      semi,gnupg
      echolot,gnupg 1.0.7
      rhn-client-tools,gnupg
      reportbug,gnupg
      repo,gnupg
      rephrase,gnupg
      python3-gnupg,gnupg
      python-simplestreams,gnupg
      python-gnupg,gnupg
      python-dput,gnupg
      pius,gnupg
      pidgin-openpgp,gnupg
      php-crypt-gpg,gnupg
      pgpgpg,gnupg
      pay-service,gnupg
      pass,gnupg
      paperkey,gnupg
      paperkey,gnupg
      packaging-dev,gnupg
      oem-config-remaster,gnupg
      nn,gnupg
      monkeysphere,gnupg 1.4.10
      monkeysign,gnupg
      mini-buildd,gnupg
      mew-beta,gnupg
      mew,gnupg
      metche,gnupg
      mandos-client,gnupg 2
      mandos,gnupg 2
      lurker,gnupg
      libzypp,gnupg
      libroar2,gnupg
      libpgp-sign-perl,gnupg
      libpar-perl,gnupg
      libmodule-signature-perl,gnupg
      libmail-gnupg-perl,gnupg
      libknewstuff3-4,gnupg
      libknewstuff2-4,gnupg
      libguestfs-tools,gnupg
      libgnupg-perl,gnupg
      libgnupg-interface-perl,gnupg
      libcrypt-gpg-perl,gnupg
      kuvert,gnupg 1.0.6
      kup-server,gnupg
      kgpg,gnupg
      keyringer,gnupg
      jetring,gnupg
      jenkins-debian-glue-buildenv,gnupg
      ircmarkers,gnupg
      inn2,gnupg
      inn,gnupg 1.0.5
      ilohamail,gnupg
      hdup,gnupg
      gpg-remailer,gnupg
      gozerbot,gnupg
      gnupg-pkcs11-scd,gnupg
      gnupg-curl,gnupg
      gnumed-server,gnupg
      gnumail.app,gnupg
      git-remote-gcrypt,gnupg
      git-crypt,gnupg
      git-annex,gnupg
      fossil,gnupg
      exmh,gnupg
      evolution,gnupg
      emdebian-archive-keyring,gnupg
      debian-keyring,gnupg 1.0.6-4
      duply,gnupg
      dpkg-sig,gnupg
      diffoscope,gnupg
      debsigs,gnupg
      debsig-verify,gnupg
      debpartial-mirror,gnupg
      debomatic,gnupg
      debmirror,gnupg
      debian-ports-archive-keyring,gnupg
      gnupg-dbg,gnupg 1.4.20-1ubuntu3
      debian-archive-keyring,gnupg
      debarchiver,gnupg
      clamav-unofficial-sigs,gnupg
      cedar-backup3,gnupg
      cedar-backup2,gnupg
      bsdowl,gnupg
      bootmail,gnupg
      bikeshed,gnupg
      aptly,gnupg
      add-apt-key,gnupg
      0install-core,gnupg
      gnupg:i386,gnupg
      ubuntu-minimal,gnupg
      spamassassin,gnupg
      python3-simplestreams,gnupg
      mutt,gnupg
      livecd-rootfs,gnupg
      libdpkg-perl,gnupg
      initramfs-tools-ubuntu-core,gnupg
      gpgv,gnupg
      gnupg-doc,gnupg
      libgpgme11,gnupg 2
      gnupg-agent,gnupg
      dput,gnupg
      dpkg-dev,gnupg
      devscripts,gnupg
      debootstrap,gnupg
      byobu,gnupg
      apt,gnupg
      gnupg-agent,gnupg 2.1.15-1ubuntu6
    Dependencies:
    2.1.15-1ubuntu6 - gnupg-agent (5 2.1.15-1ubuntu6) libassuan0 (2 2.0.1) libbz2-1.0 (0 (null)) libc6 (2 2.15) libgcrypt20 (2 1.7.0) libgpg-error0 (2 1.14) libksba8 (2 1.3.4) libreadline7 (2 6.0) libsqlite3-0 (2 3.7.15) zlib1g (2 1:1.1.4) debsig-verify (3 0.15) dirmngr (3 2.1.0~) gnupg2 (3 2.1.11-7+exp1) libgnupg-interface-perl (3 0.52-3) libgnupg-perl (1 0.19-1) libmail-gnupg-perl (1 0.22-1) monkeysphere (3 0.38~) php-crypt-gpg (1 1.4.1-1) python-apt (1 1.1.0~beta4) python-gnupg (3 0.3.8-3) software-properties-common (1 0.96.24.3) dirmngr (5 2.1.15-1ubuntu6) gnupg-l10n (5 2.1.15-1ubuntu6) parcimonie (0 (null)) xloadimage (0 (null)) gnupg2 (3 2.1.11-7+exp1) gnupg2:i386 (3 2.1.11-7+exp1) gnupg2:i386 (3 2.1.11-7+exp1) python-apt:i386 (1 1.1.0~beta4) dirmngr:i386 (3 2.1.0~) gnupg:i386 (32 (null)) monkeysphere:i386 (3 0.38~) software-properties-common:i386 (1 0.96.24.3) debsig-verify:i386 (3 0.15) python-gnupg:i386 (3 0.3.8-3) libgnupg-interface-perl:i386 (3 0.52-3)
    1.4.20-1ubuntu3.1 - gpgv (0 (null)) libbz2-1.0 (0 (null)) libc6 (2 2.15) libreadline6 (2 6.0) libusb-0.1-4 (2 2:0.1.12) zlib1g (2 1:1.1.4) gnupg-curl (0 (null)) gnupg-doc (0 (null)) libpcsclite1 (0 (null)) parcimonie (0 (null)) xloadimage (16 (null)) imagemagick (16 (null)) eog (0 (null)) gnupg:i386 (32 (null))
    1.4.20-1ubuntu3 - gpgv (0 (null)) libbz2-1.0 (0 (null)) libc6 (2 2.15) libreadline6 (2 6.0) libusb-0.1-4 (2 2:0.1.12) zlib1g (2 1:1.1.4) gnupg-curl (0 (null)) gnupg-doc (0 (null)) libpcsclite1 (0 (null)) parcimonie (0 (null)) xloadimage (16 (null)) imagemagick (16 (null)) eog (0 (null)) gnupg:i386 (32 (null))
    Provides:
    2.1.15-1ubuntu6 - gnupg:i386 (= 2.1.15-1ubuntu6) gpg (= )
    1.4.20-1ubuntu3.1 - gnupg:i386 (= 1.4.20-1ubuntu3.1)
    1.4.20-1ubuntu3 - gnupg:i386 (= 1.4.20-1ubuntu3)
    Reverse Provides:
    gnupg:i386 1.4.20-1ubuntu3.1 (= 1.4.20-1ubuntu3.1)
    gnupg:i386 1.4.20-1ubuntu3 (= 1.4.20-1ubuntu3)
    

    Let me know if you need any additional information.

    Thanks


  • Developer

    @Sanga-Collins Please run as well apt-cache showpkg gnupg and post here again.



  • @sebastian-roth said in 1.4.4 install fails - add-apt-repository: command not found:

    apt-get --dry-run -o Debug::pkgDepCache::AutoInstall=1 -o Debug::pkgProblemResolver=1 install software-properties-common

    Here is what I got when executing the commands you provided (good to know apt has a dry run feature :)

    apt-get --dry-run -o Debug::pkgDepCache::AutoInstall=1 -o Debug::pkgProblemResolver=1 install software-properties-common
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Starting pkgProblemResolver with broken count: 1
    Starting 2 pkgProblemResolver with broken count: 1
    Investigating (0) gnupg [ amd64 ] < 2.1.15-1ubuntu6 > ( utils )
    Broken gnupg:amd64 Breaks on software-properties-common [ amd64 ] < none -> 0.96.20.7 > ( admin ) (<= 0.96.24.3)
      Considering software-properties-common:amd64 9998 as a solution to gnupg:amd64 115
      Removing gnupg:amd64 rather than change software-properties-common:amd64
    Investigating (0) libgpgme11 [ amd64 ] < 1.8.0-3ubuntu2 > ( libs )
    Broken libgpgme11:amd64 Depends on gnupg [ amd64 ] < 2.1.15-1ubuntu6 > ( utils ) (> 2)
      Considering gnupg:amd64 115 as a solution to libgpgme11:amd64 3
    Broken libgpgme11:amd64 Depends on gnupg2 [ amd64 ] < none -> 2.1.11-6ubuntu2 > ( utils ) (> 2.0.4)
      Considering gnupg2:amd64 2 as a solution to libgpgme11:amd64 3
      Try Installing gnupg2 [ amd64 ] < none -> 2.1.11-6ubuntu2 > ( utils ) before changing libgpgme11:amd64
        Installing gnupg-agent as Depends of gnupg2
          Installing pinentry-curses as Depends of gnupg-agent
            Installing libassuan0 as Depends of pinentry-curses
            Installing libc6 as Depends of pinentry-curses
              Installing libgcc1 as Depends of libc6
                Installing gcc-6-base as Depends of libgcc1
            Installing libgpg-error0 as Depends of pinentry-curses
            Installing libncursesw5 as Depends of pinentry-curses
              Installing libtinfo5 as Depends of libncursesw5
             Removing: pinentry-curses
          Installing libassuan0 as Depends of gnupg-agent
          Installing libgcrypt20 as Depends of gnupg-agent
          Installing libnpth0 as Depends of gnupg-agent
          Installing libreadline6 as Depends of gnupg-agent
           Removing: gnupg-agent
      Or group remove for libgpgme11:amd64
    Investigating (0) pinentry-curses [ i386 ] < none -> 0.9.7-3 > ( utils )
    Broken pinentry-curses:i386 Depends on libassuan0 [ i386 ] < none -> 2.4.2-2 > ( libs ) (>= 2.0.1)
      Considering libassuan0:i386 0 as a solution to pinentry-curses:i386 -1
      Holding Back pinentry-curses:i386 rather than change libassuan0:i386
    Investigating (0) gnupg-agent [ i386 ] < none -> 2.1.11-6ubuntu2 > ( utils )
    Broken gnupg-agent:i386 Depends on pinentry-curses [ i386 ] < none -> 0.9.7-3 > ( utils )
      Considering pinentry-curses:i386 -1 as a solution to gnupg-agent:i386 -1
      Holding Back gnupg-agent:i386 rather than change pinentry-curses:i386
    Broken gnupg-agent:i386 Depends on pinentry [ i386 ] < none ->  > ( none )
      Considering pinentry-tty:i386 0 as a solution to gnupg-agent:i386 -1
      Holding Back gnupg-agent:i386 rather than change pinentry:i386
      Or group keep for gnupg-agent:i386
    Broken gnupg-agent:i386 Depends on libassuan0 [ i386 ] < none -> 2.4.2-2 > ( libs ) (>= 2.3.0)
      Considering libassuan0:i386 0 as a solution to gnupg-agent:i386 -1
      Holding Back gnupg-agent:i386 rather than change libassuan0:i386
    Investigating (1) samba-dsdb-modules [ amd64 ] < 2:4.6.7+dfsg-1ubuntu2 > ( libs )
    Broken samba-dsdb-modules:amd64 Depends on libgpgme11 [ amd64 ] < 1.8.0-3ubuntu2 > ( libs ) (>= 1.2.0)
      Considering libgpgme11:amd64 3 as a solution to samba-dsdb-modules:amd64 3
      Removing samba-dsdb-modules:amd64 rather than change libgpgme11:amd64
    Investigating (1) gnupg2 [ amd64 ] < none -> 2.1.11-6ubuntu2 > ( utils )
    Broken gnupg2:amd64 Depends on gnupg-agent [ amd64 ] < 2.1.15-1ubuntu6 > ( utils ) (= 2.1.11-6ubuntu2)
      Considering gnupg-agent:amd64 5 as a solution to gnupg2:amd64 2
      Holding Back gnupg2:amd64 rather than change gnupg-agent:amd64
    Investigating (1) zentyal-samba [ amd64 ] < 5.0.10 > ( web )
    Broken zentyal-samba:amd64 Depends on samba-dsdb-modules [ amd64 ] < 2:4.6.7+dfsg-1ubuntu2 > ( libs )
      Considering samba-dsdb-modules:amd64 3 as a solution to zentyal-samba:amd64 0
      Removing zentyal-samba:amd64 rather than change samba-dsdb-modules:amd64
    Investigating (2) apt [ amd64 ] < 1.2.24 > ( admin )
    Broken apt:amd64 Depends on gnupg [ amd64 ] < 2.1.15-1ubuntu6 > ( utils )
      Considering gnupg:amd64 115 as a solution to apt:amd64 5134
      Added gnupg:amd64 to the remove list
    Broken apt:amd64 Depends on gnupg2 [ amd64 ] < none -> 2.1.11-6ubuntu2 > ( utils )
      Considering gnupg2:amd64 2 as a solution to apt:amd64 5134
      Try Installing gnupg2 [ amd64 ] < none -> 2.1.11-6ubuntu2 > ( utils ) before changing apt:amd64
        Installing gnupg-agent as Depends of gnupg2
          Installing pinentry-curses as Depends of gnupg-agent
            Installing libassuan0 as Depends of pinentry-curses
          Installing libassuan0 as Depends of gnupg-agent
          Installing libgcrypt20 as Depends of gnupg-agent
          Installing libnpth0 as Depends of gnupg-agent
      Fixing apt:amd64 via keep of gnupg:amd64
    Investigating (2) gnupg [ amd64 ] < 2.1.15-1ubuntu6 > ( utils )
    Broken gnupg:amd64 Depends on gnupg-agent [ amd64 ] < 2.1.15-1ubuntu6 > ( utils ) (= 2.1.15-1ubuntu6)
      Considering gnupg-agent:amd64 5 as a solution to gnupg:amd64 5134
      Added gnupg-agent:amd64 to the remove list
    Broken gnupg:amd64 Breaks on software-properties-common [ amd64 ] < none -> 0.96.20.7 > ( admin ) (<= 0.96.24.3)
      Considering software-properties-common:amd64 9998 as a solution to gnupg:amd64 5134
      Removing gnupg:amd64 rather than change software-properties-common:amd64
    Investigating (2) pinentry-curses [ i386 ] < none -> 0.9.7-3 > ( utils )
    Broken pinentry-curses:i386 Depends on libassuan0 [ i386 ] < none -> 2.4.2-2 > ( libs ) (>= 2.0.1)
      Considering libassuan0:i386 0 as a solution to pinentry-curses:i386 -1
      Holding Back pinentry-curses:i386 rather than change libassuan0:i386
    Investigating (2) gnupg-agent [ i386 ] < none -> 2.1.11-6ubuntu2 > ( utils )
    Broken gnupg-agent:i386 Depends on pinentry-curses [ i386 ] < none -> 0.9.7-3 > ( utils )
      Considering pinentry-curses:i386 -1 as a solution to gnupg-agent:i386 -1
      Holding Back gnupg-agent:i386 rather than change pinentry-curses:i386
    Broken gnupg-agent:i386 Depends on pinentry [ i386 ] < none ->  > ( none )
      Considering pinentry-tty:i386 0 as a solution to gnupg-agent:i386 -1
      Holding Back gnupg-agent:i386 rather than change pinentry:i386
      Or group keep for gnupg-agent:i386
    Broken gnupg-agent:i386 Depends on libassuan0 [ i386 ] < none -> 2.4.2-2 > ( libs ) (>= 2.3.0)
      Considering libassuan0:i386 0 as a solution to gnupg-agent:i386 -1
      Holding Back gnupg-agent:i386 rather than change libassuan0:i386
    Investigating (3) apt [ amd64 ] < 1.2.24 > ( admin )
    Broken apt:amd64 Depends on gnupg [ amd64 ] < 2.1.15-1ubuntu6 > ( utils )
      Considering gnupg:amd64 9998 as a solution to apt:amd64 5134
    Broken apt:amd64 Depends on gnupg2 [ amd64 ] < none -> 2.1.11-6ubuntu2 > ( utils )
      Considering gnupg2:amd64 2 as a solution to apt:amd64 5134
      Try Installing gnupg2 [ amd64 ] < none -> 2.1.11-6ubuntu2 > ( utils ) before changing apt:amd64
        Installing gnupg-agent as Depends of gnupg2
          Installing pinentry-curses as Depends of gnupg-agent
            Installing libassuan0 as Depends of pinentry-curses
          Installing libassuan0 as Depends of gnupg-agent
          Installing libgcrypt20 as Depends of gnupg-agent
          Installing libnpth0 as Depends of gnupg-agent
      Or group remove for apt:amd64
    Investigating (3) apt-utils [ amd64 ] < 1.2.24 > ( admin )
    Broken apt-utils:amd64 Depends on apt [ amd64 ] < 1.2.24 > ( admin ) (= 1.2.24)
      Considering apt:amd64 5134 as a solution to apt-utils:amd64 56
      Removing apt-utils:amd64 rather than change apt:amd64
    Investigating (3) pinentry-curses [ i386 ] < none -> 0.9.7-3 > ( utils )
    Broken pinentry-curses:i386 Depends on libassuan0 [ i386 ] < none -> 2.4.2-2 > ( libs ) (>= 2.0.1)
      Considering libassuan0:i386 0 as a solution to pinentry-curses:i386 -1
      Holding Back pinentry-curses:i386 rather than change libassuan0:i386
    Investigating (3) gnupg-agent [ i386 ] < none -> 2.1.11-6ubuntu2 > ( utils )
    Broken gnupg-agent:i386 Depends on pinentry-curses [ i386 ] < none -> 0.9.7-3 > ( utils )
      Considering pinentry-curses:i386 -1 as a solution to gnupg-agent:i386 -1
      Holding Back gnupg-agent:i386 rather than change pinentry-curses:i386
    Broken gnupg-agent:i386 Depends on pinentry [ i386 ] < none ->  > ( none )
      Considering pinentry-tty:i386 0 as a solution to gnupg-agent:i386 -1
      Holding Back gnupg-agent:i386 rather than change pinentry:i386
      Or group keep for gnupg-agent:i386
    Broken gnupg-agent:i386 Depends on libassuan0 [ i386 ] < none -> 2.4.2-2 > ( libs ) (>= 2.3.0)
      Considering libassuan0:i386 0 as a solution to gnupg-agent:i386 -1
      Holding Back gnupg-agent:i386 rather than change libassuan0:i386
    Done
    The following packages were automatically installed and are no longer required:
      libassuan0 libksba8 libnpth0 zentyal-dns
    Use 'apt autoremove' to remove them.
    The following packages will be REMOVED:
      apt apt-utils gnupg gnupg-agent libgpgme11 pinentry-curses samba-dsdb-modules zentyal-samba
    The following NEW packages will be installed:
      software-properties-common
    WARNING: The following essential packages will be removed.
    This should NOT be done unless you know exactly what you are doing!
      apt gnupg (due to apt)
    0 upgraded, 1 newly installed, 8 to remove and 9 not upgraded.
    Remv apt-utils [1.2.24]
    Remv apt [1.2.24]
    Remv zentyal-samba [5.0.10]
    Remv samba-dsdb-modules [2:4.6.7+dfsg-1ubuntu2]
    Remv libgpgme11 [1.8.0-3ubuntu2]
    Remv gnupg [2.1.15-1ubuntu6]
    Remv gnupg-agent [2.1.15-1ubuntu6]
    Remv pinentry-curses [1.0.0-2]
    Inst software-properties-common (0.96.20.7 Ubuntu:16.04/xenial-updates [all])
    Conf software-properties-common (0.96.20.7 Ubuntu:16.04/xenial-updates [all])
    

    dpkg --configure -a returned no results. And finally

    apt-cache showpkg software-properties-common
    Package: software-properties-common
    Versions:
    0.96.20.7 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_binary-amd64_Packages) (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_binary-i386_Packages) (/var/lib/dpkg/status)
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-amd64_Packages
                      MD5: d19f432480048ad00ac5c2bfd116cd00
     Description Language: en
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_i18n_Translation-en
                      MD5: d19f432480048ad00ac5c2bfd116cd00
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_binary-amd64_Packages
                      MD5: d19f432480048ad00ac5c2bfd116cd00
    
    0.96.20 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-amd64_Packages) (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-i386_Packages)
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_binary-amd64_Packages
                      MD5: d19f432480048ad00ac5c2bfd116cd00
     Description Language: en
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_main_i18n_Translation-en
                      MD5: d19f432480048ad00ac5c2bfd116cd00
     Description Language:
                     File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_main_binary-amd64_Packages
                      MD5: d19f432480048ad00ac5c2bfd116cd00
    
    
    Reverse Depends:
      gnupg,software-properties-common 0.96.24.3
      ubuntu-mate-welcome,software-properties-common
      software-properties-kde,software-properties-common
      software-properties-gtk,software-properties-common
      cloud-init,software-properties-common
      ubuntu-touch,software-properties-common
      ubuntu-mate-welcome,software-properties-common
      software-properties-kde,software-properties-common
      phablet-tools-citrain,software-properties-common
      ubuntu-server,software-properties-common
      software-properties-gtk,software-properties-common
      cloud-init,software-properties-common
    Dependencies:
    0.96.20.7 - python3:any (2 3.3.2-2~) python3 (0 (null)) python3-gi (0 (null)) gir1.2-glib-2.0 (0 (null)) python-apt-common (2 0.9) python3-dbus (0 (null)) python3-software-properties (5 0.96.20.7) ca-certificates (0 (null)) python-software-properties (3 0.85) python3-software-properties (3 0.85) python3-software-properties:i386 (3 0.85) python-software-properties (3 0.85) python3-software-properties (3 0.85) python3-software-properties:i386 (3 0.85)
    0.96.20 - python3:any (2 3.3.2-2~) python3 (0 (null)) python3-gi (0 (null)) gir1.2-glib-2.0 (0 (null)) python-apt-common (2 0.9) python3-dbus (0 (null)) python3-software-properties (5 0.96.20) ca-certificates (0 (null)) python-software-properties (3 0.85) python3-software-properties (3 0.85) python-software-properties (3 0.85) python3-software-properties (3 0.85) python3-software-properties:i386 (3 0.85) python3-software-properties:i386 (3 0.85)
    Provides:
    0.96.20.7 -
    0.96.20 -
    Reverse Provides:
    

    Was the results from running the last command


  • Developer

    @sanga-collins: Give this monster of a command a try: apt-get --dry-run -o Debug::pkgDepCache::AutoInstall=1 -o Debug::pkgProblemResolver=1 install software-properties-common

    As well try dpkg --configure -a to see if there is still some package left unconfigured. Plus, run apt-cache showpkg software-properties-common so we see the package dependencies.

    Post the full outputs again. Hopefully we can figure out what would be causing the removal of apt on your system.



  • Thanks for the pointers. I do believe the server upgrade did cause majority of the issues I am facing. I’ll try a few more things this weekend to fix it when I can take advantage of down time. If that does not work I’ll just make a new one and migrate.

    Thanks for the assistance!


  • Moderator

    @sanga-collins I always recommend migrating to a new OS instead of upgrading the OS because of issues like this. We have a migration guide here: https://wiki.fogproject.org/wiki/index.php?title=Migrate_FOG So if we are not able to figure out what is botched on your fog server, you can just migrate.



  • @sebastian-roth said in 1.4.4 install fails - add-apt-repository: command not found:

    cat /etc/apt/sources.list /etc/apt/sources.list.d/* && apt-get update && apt-get dist-upgrade

    To upgrade I used apt-get dist-upgrade which seemed to go through without a problem. Here are the results of the commands you requested.

    thanks

    # cat /etc/apt/sources.list /etc/apt/sources.list.d/* && apt-get update && apt-get dist-upgrade
    # Zentyal
    deb http://archive.zentyal.org/zentyal 5.0 main extra
    
    # deb cdrom:[Ubuntu-Server 14.04 LTS _Trusty Tahr_ - Release amd64 (20140416.2)]/ trusty extras main restricted
    
    # deb cdrom:[Ubuntu-Server 14.04 LTS _Trusty Tahr_ - Release amd64 (20140416.2)]/ trusty extras main restricted
    
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://us.archive.ubuntu.com/ubuntu/ xenial main restricted
    # deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
    # deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://us.archive.ubuntu.com/ubuntu/ xenial universe
    # deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
    deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates universe
    # deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://us.archive.ubuntu.com/ubuntu/ xenial multiverse
    # deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
    deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
    # deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
    
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://us.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    # deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
    
    
    deb http://security.ubuntu.com/ubuntu xenial-security main restricted
    # deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
    deb http://security.ubuntu.com/ubuntu xenial-security universe
    # deb-src http://security.ubuntu.com/ubuntu trusty-security universe
    deb http://security.ubuntu.com/ubuntu xenial-security multiverse
    # deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu trusty partner
    # deb-src http://archive.canonical.com/ubuntu trusty partner
    
    ## Uncomment the following two lines to add software from Ubuntu's
    ## 'extras' repository.
    # deb https://packages.elastic.co/elasticsearch/2.x/debian stable main # disabled on upgrade to xenial
    deb https://packages.elastic.co/elasticsearch/2.x/debian stable main
    # deb https://packages.elastic.co/elasticsearch/2.x/debian stable main # disabled on upgrade to xenial
    # deb https://packages.graylog2.org/repo/debian/ stable 2.0 # disabled on upgrade to xenial
    deb https://packages.graylog2.org/repo/debian/ stable 2.0
    # deb https://packages.graylog2.org/repo/debian/ stable 2.0 # disabled on upgrade to xenial
    # deb http://repo.mongodb.org/apt/debian wheezy/mongodb-org/3.0 main # disabled on upgrade to xenial
    deb http://repo.mongodb.org/apt/debian wheezy/mongodb-org/3.0 main
    # deb http://repo.mongodb.org/apt/debian wheezy/mongodb-org/3.0 main # disabled on upgrade to xenial
    # deb http://archive.zentyal.org/zentyal 4.2 main extra # disabled on upgrade to xenial
    deb http://archive.zentyal.org/zentyal 4.2 main extra
    # deb http://archive.zentyal.org/zentyal 4.2 main extra # disabled on upgrade to xenial
    Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
    Get:2 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
    Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
    Hit:4 http://archive.zentyal.org/zentyal 5.0 InRelease
    Get:5 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
    Get:6 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [642 kB]
    Get:7 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [609 kB]
    Get:8 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [540 kB]
    Get:9 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [515 kB]
    Fetched 2,613 kB in 1s (2,357 kB/s)
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    

  • Developer

    @Sanga-Collins To me this sounds as if your package lists are screwed. How did you do the upgrage from 14.04 to 16.04?

    Please run cat /etc/apt/sources.list /etc/apt/sources.list.d/* && apt-get update && apt-get dist-upgrade and post the full output here.



  • @sebastian-roth said in 1.4.4 install fails - add-apt-repository: command not found:

    apt-get install software-properties-common

    Thanks for the reply. I had followed the steps to clean up packages and find any errors so now I am at the point where I get the following.

    apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    

    Running the command to install software-properties-common is what leads to the strange warning message as shown below. Its very strange and I am at a loss as to how to get past it.

    # apt-get install software-properties-common
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libassuan0 libksba8 libnpth0
    Use 'sudo apt autoremove' to remove them.
    The following packages will be REMOVED:
      apt apt-utils gnupg gnupg-agent pinentry-curses
    The following NEW packages will be installed:
      software-properties-common
    WARNING: The following essential packages will be removed.
    This should NOT be done unless you know exactly what you are doing!
      apt gnupg (due to apt)
    0 upgraded, 1 newly installed, 5 to remove and 0 not upgraded.
    Need to get 9,452 B of archives.
    After this operation, 6,900 kB disk space will be freed.
    You are about to do something potentially harmful.
    To continue type in the phrase 'Yes, do as I say!'
     ?]
    

  • Developer

    @Sanga-Collins You posted the output which is really great but would be even better if you could post the commands used as well. Mostly when something is wrong with debian-based package system you start by running apt-get -f install and see what you are at.

    The command add-apt-repository is part of the package called ‘software-properties-common’. So run apt-get install software-properties-common to install that. This should be done by the installer so I guess there is something really wrong.


Log in to reply
 

456
Online

39179
Users

10827
Topics

103019
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.