Stuck at bzimage and init load



  • Hi,

    So just got some fresh Dell 7480 laptops that I’m trying to image with Windows 10. Ran into some troubles and figured I should update from Fog 1.2 to Fog 1.4.4. Continued to have the problem so I updated the kernel to the latest and again still having the issue. It starts the PXE boot and says ok next to loading bzimage3 and init.xz but then just hangs with a blinking cursor on the next line.


  • Developer

    @jflanagin Any news on this?


  • Developer

    @jflanagin I need to ask you a few more questions. What kind of network adapter do you use with those machines? Do they have an internal network adapter or do you need to use any of these USB network adapters?

    You can try undionly.kkpxe (note the double ‘k’) or ipxe.pxe or ipxe.kpxe to see if any of these will help. Please also make yourself aware of what (U)EFI really is and see if you want to go that way as legacy BIOS will be gone sooner or later anyway. For that you’d have to install the OS in UEFI mode as well. So it’s kind of a bigger step to go. You can’t just switch legacy BIOS to UEFI and back in the firmware without breaking the installed OS. Make sure you understand what this is about as it is very important. If you are keen to try UEFI, you could just switch over in the firmware settings and see if you can PXE boot that way but using ipxe.efi binary this time! If it doesn’t hang you can see if you wanna go that route (re-install OS in UEFI mode and all that…)



  • @george1421

    So I just tried a e5520 that have imaged before and it’s getting stuck in the same exact spot.


  • Moderator

    @jflanagin You can support all other hardware except the 7480 (or the 8th generation devices? The reason why I ask is the latest generation is the new Kaby Lake chip sets, where the older (i.e. Circa 2016) is the Sky Lake design. The Kaby Lake chips may be too new to have proper linux support. I am speaking totally off the top without a foundation yet.

    But we have someone else on the forums with a 7050 that uses Kaby Lake chips that is seeing random freezes during registration and imaging.

    We may need to get the @Developers involved with some custom debug FOS kernels to help debug exactly where its hanging.

    Something you can do is ensure you are on the latest release of the firmware for the 7480 and watch the dell site to see if newer releases are offered. I suspect we are going to see quite a bit of churn with firmware updates like we saw with the 7470/7270 generation.



  • @george1421

    1. I believe Legacy
    2. Secure Boot is Disabled
    3. 66 is my FOG server IP and 67 is undionly.kpxe
    4. Yes

  • Moderator

    @jflanagin Can we get a bit more information on this?

    1. You say you have a 7480, is that device in bios (legacy) or uefi mode?
    2. If in uefi mode, is secure boot disabled?
    3. What precisely do you have configured for dhcp option 66 {next-server} and dhcp option 67 {boot-file}?
    4. Is it accurate to say you ARE running FOG 1.4.4?

Log in to reply
 

520
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.