Image upload stops at 80% hung_task_timeout



  • Trying to upload an image and it got about 80% then the error below shows on screen and it never finishes.

    HP 6000 single disk. chkdsk has been run.

    What is process pigz and why is it hungup?

    Frustrating!

    [COLOR=black][FONT=Tahoma][2640.688033] INFO: task pigz:284 blocked for more than 120 seconds
    [2640.688075] “echo 0 > proc/sys/kernel/hung_task_timeout_secs” disables this message.[/FONT][/COLOR]



  • Nope - plenty of disk space - 2TB currently holding one lonesome image. It starts after about 8 seconds, long pause then jumps to 11 seconds (or so) and upload speed drops, then jumps to 16 seconds, long pause, speed drops - does several times, then very long pause and I get the above message.


  • Developer

    There is something stopping it at 13%. Out of disk space?

    There is only so much i can do with 21 words of information :)



  • Mine ends up stopping around 13%. It isn’t the image. It’s every image I try from every computer I try.


  • Developer

    It stops at 80% because it’s an incomplete image. Filesystem problems would be my guess.

    chkdsk /x c:

    Resysprep, reupload image



  • I am having the same problem. I uploaded one image (desktop) and everything went fine. I came back a week later to upload another (laptop) and I got message above. So after hours of research I ended up reloading my Fog Server and started completely over. So I uploaded one image (laptop) and it went great then tried to upload the other (desktop) now I am getting the same message again. I traded cables, switches, put the fog server hard drive into another machine and changed all the eth0 settings to eth1 and still the same message. Help :)



  • Pigz is multithreaded gzip. The three potential issues that come to mind are:
    [LIST=1]
    []The server you’re uploading to is out of space
    [
    ]The host you’re uploading from has a bad sector or some other hard drive issue
    [*]Networking issue that prevented pigz from writing out to the server
    [/LIST]
    Have you tried to upload more than once? Does it happen at the same point every time?


 

456
Online

41.5k
Users

12.0k
Topics

113.5k
Posts