Upgrade to debian 9



  • Server
    • FOG Version: Running Version 1.4.2
    • OS: Debian 8
    Description

    Hello,
    I actually use Fog 1.4.2 on a clean Debian 8 installation.
    I’m upgrading all my servers to Debian 9 and i was wondering if Fog will works with changes on Debian 9 :
    PHP 7
    mysql => maria db.

    Can i upgrade my saver without risk about php7 and mariadb ?
    Does someone already made it ?

    Many thanks for your hrlp.


  • Developer

    @plegrand Thanks for reporting back on this. Marked as solved.



  • Boot PXE OK
    Capture OK
    Deploy OK



  • @wayne-workman i used " your packages line" and it seems to work.
    Then now i have to test pxe boot, capture and deploy !!

    THanks for your help



  • @wayne-workman sure. i will use your line


  • Moderator

    @plegrand You’ll also need to empty out the packages line - since that stuff has php5 in it.



  • @wayne-workman i will do that


  • Moderator

    @plegrand said in Upgrade to debian 9:

    Why my file (from 1.4.4 version) keep php5 packages instead of php7

    You can just change it from 5 to 7 and the installer will install the new stuff I think.



  • @wayne-workman Hmm strange. Why my file (from 1.4.4 version) keep php5 packages instead of php7
    Anyway i will try with this file monday.
    Thanks for your help


  • Moderator

    @plegrand said in Upgrade to debian 9:

    @wayne-workman and could you tell me what version of Fog you use ?

    I use all of them (see my signature).

    Here’s a copy of the /opt/fog/.fogsettings file from a Debian9 box that had a clean install of 1.4.4 last night.

    ## Start of FOG Settings
    ## Created by the FOG Installer
    ## Find more information about this file in the FOG Project wiki:
    ##     https://wiki.fogproject.org/wiki/index.php?title=.fogsettings
    ## Version: 1.4.4
    ## Install time: Sat 26 Aug 2017 04:08:09 AM CDT
    ipaddress='10.0.0.39'
    copybackold='0'
    interface='ens3'
    submask='255.255.255.0'
    routeraddress='10.0.0.1'
    plainrouter='10.0.0.1'
    dnsaddress='208.67.222.222'
    username='fog'
    password='qAW1Q5ednQ3LS0ywmMMn9woirwwcMHu/7S9ZbJE7lvY='
    osid='2'
    osname='Debian'
    dodhcp='N'
    bldhcp='0'
    dhcpd=''
    blexports='1'
    installtype='N'
    snmysqluser='root'
    snmysqlpass=''
    snmysqlhost='localhost'
    installlang='0'
    storageLocation='/images'
    fogupdateloaded=1
    docroot='/var/www/'
    webroot='/fog/'
    caCreated='yes'
    startrange=''
    endrange=''
    bootfilename='undionly.kpxe'
    packages='apache2 bc build-essential cpp curl g++ gawk gcc gzip htmldoc lftp libapache2-mod-php7.0 libc6 libcurl3 m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php7.0 php7.0-bcmath php7.0-cli php7.0-curl php7.0-fpm php7.0-gd php7.0-json php7.0-mbstring php7.0-mcrypt php7.0-mysql php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g '
    noTftpBuild=''
    notpxedefaultfile=''
    sslpath='/opt/fog/snapins/ssl/'
    backupPath='/home/'
    php_ver='7.0'
    php_verAdds='-7.0'
    sslprivkey='/opt/fog/snapins/ssl//.srvprivate.key'
    ## End of FOG Settings
    


  • @wayne-workman and could you tell me what version of Fog you use ?


  • Moderator

    @plegrand yeah one second.



  • @wayne-workman may be could you give me a copy of the .fogsettings file from a fresh install on Debian 9 ?
    Thanks


  • Moderator

    @plegrand Debian 9 would have to use the php 7 packages. I can assure you that the installer works on a clean installation of Debian 9, but I’ve not tested an upgrade from older Debian 8. If you look in my signature, you’ll see some automated tests centered around the fog installer. All those tests are with 100% clean OSs/installs.

    In the past, people who have upgraded their OSs on FOG servers have had mixed success. When it goes right, everything is just peachy. When it goes wrong we spend days - sometimes weeks - helping these people figure out the problems. I’d say it’s been about a 60/40 split, 40 being failure.

    If you want to avoid the risks of upgrading, this is an article outlining step-by-step how to migrate: https://wiki.fogproject.org/wiki/index.php?title=Migrate_FOG



  • This is exactly that i wanted to ask :
    Do i have to modify manually this line then remove php5 packages and replace by php7.0 package .

    https://wiki.fogproject.org/wiki/index.php?title=.fogsettings#packages

    i will try on Monday and will report here the result


  • Moderator

    @plegrand said in Upgrade to debian 9:

    repo=“php-${php_ver}”

    I use the latest RC, and I’ve not the repo=“php-${php_ver}”

    Can you check the packages config ? have you ?
    packages=‘apache2 bc build-essential cpp curl g++ gcc gzip htmldoc lftp libapache2-mod-php5 libc6 libcurl3 m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php5 php5-cli php5-curl php5-fpm php5-gd php5-json php5-mcrypt php5-mysqlnd php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g’

    In my case I have php5 packages…


  • Moderator

    @plegrand You have to remove the php5 packages from the packages= line in /opt/fog/.fogsettings file, I believe.



  • @ch3i the only problem for the moment is for the upgrade

    ./installfog.sh
    
     * Packages to be installed:
    
    	apache2 bc build-essential cpp curl g++ gcc gzip htmldoc lftp libapache2-mod-php5 libc6 libcurl3 m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php5 php5-cli php5-curl php5-fpm php5-gd php5-json php5-mcrypt php5-mysqlnd php7.0-bcmath php7.0-mbstring php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g 
    
    
     * Skipping package:   apache2.................................(Already Installed)
     * Skipping package:   bc......................................(Already Installed)
     * Skipping package:   build-essential.........................(Already Installed)
     * Skipping package:   cpp.....................................(Already Installed)
     * Skipping package:   curl....................................(Already Installed)
     * Skipping package:   g++.....................................(Already Installed)
     * Skipping package:   gcc.....................................(Already Installed)
     * Skipping package:   gzip....................................(Already Installed)
     * Skipping package:   htmldoc.................................(Already Installed)
     * Skipping package:   lftp....................................(Already Installed)
     * Skipping package: libapache2-mod-php5.......................(Does not exist)
     * Skipping package:   libc6...................................(Already Installed)
     * Skipping package:   libcurl3................................(Already Installed)
     * Skipping package:   m4......................................(Already Installed)
     * Skipping package:   mysql-client............................(Already Installed)
     * Skipping package:   mysql-server............................(Already Installed)
     * Skipping package:   net-tools...............................(Already Installed)
     * Skipping package:   nfs-kernel-server.......................(Already Installed)
     * Skipping package:   openssh-server..........................(Already Installed)
     * Installing package: php5....................................Failed! (Will try later)
     * Skipping package: php5-cli..................................(Does not exist)
     * Skipping package: php5-curl.................................(Does not exist)
     * Skipping package: php5-fpm..................................(Does not exist)
     * Skipping package: php5-gd...................................(Does not exist)
     * Skipping package: php5-json.................................(Does not exist)
     * Skipping package: php5-mcrypt...............................(Does not exist)
     * Skipping package: php5-mysqlnd..............................(Does not exist)
     * Installing package: php7.0-bcmath...........................OK
     * Skipping package:   php7.0-mbstring.........................(Already Installed)
     * Skipping package:   php-gettext.............................(Already Installed)
     * Skipping package:   sysv-rc-conf............................(Already Installed)
     * Skipping package:   tar.....................................(Already Installed)
     * Skipping package:   tftpd-hpa...............................(Already Installed)
     * Skipping package:   tftp-hpa................................(Already Installed)
     * Skipping package:   unzip...................................(Already Installed)
     * Skipping package:   vsftpd..................................(Already Installed)
     * Skipping package:   wget....................................(Already Installed)
     * Skipping package:   xinetd..................................(Already Installed)
     * Skipping package:   zlib1g..................................(Already Installed)
     * Updating packages as needed.................................OK
     * Installing now everything is updated........................Failed!
    

    As said in https://forums.fogproject.org/topic/6285/php-7-0-0-finally-released/15
    i add this lines :

    php_ver="7.0"
    php_verAdds="-7.0"
    repo="php-${php_ver}"
    

    But it doesn’t change anything
    Any idea ?


  • Moderator

    @plegrand Good news !



  • It seems that during upgrade debian remove some php5 packages but doesn’t reinstall them in php7 version.
    After reinstall them it seems to works

    aptitude install php7.0-mysql libapache2-mod-php7 php7.0 php7.0-curl php7.0-curl php7.0-fpm php7.0-gd php7.0-mcrypt
    

    I have now to test pxe boot capture and deploy


Log in to reply
 

428
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.