Hp 440 G4 boot issue



  • Hello Everyone,

    Sorry if this isn’t exactly related to FOG, but my school district is having trouble setting up the HP 440 G4s we purchased. We are going to use FOG to image them as soon as we can so that’s why I’m posting this issue here.

    The school district I work for ordered 125 HP 440 G4s and we’re having a problem setting them up. We want to have the devices boot in this order: USB, PXE, and then the SSD. So far we’ve gone into the BIOS menu unchecked all the boxes in the secure boot configuration menu and configured legacy support to “Legacy Support Enable and Secure Boot Disable” we then save and exit. When the device reboots we go back into the BIOS menu and navigate to boot options, uncheck fast boot, and uncheck UEFI boot. Under the legacy boot order list we change it to USB, PXE, then the SSD.

    Now when we boot the devices it will go into the PXE boot, but if we’re directed connected to the network it will circle boot the PXE indefinitely. If we unplug the devices from the network they will boot into PXE, but then no other boot device will be found and it will sit at a screen indicating so. We need to know how to fix this and make it so we can have the devices read the SSD after the PXE boot. The BIOS on all the machines is v. 01.06 which was released in June of 2017. If anyone can offer any help or advice it would be greatly appreciated. Thank you


  • Moderator

    @mrcur Great!! rEFInd is a great boot loader (once you tell it where to and not to look).


  • Testers

    @george1421 That did the trick. Thanks @george1421!


  • Testers

    @george1421 I get a warning about CSM not being available but hitting enter allows the laptop to boot. I suppose I need to remove the “hdbios” and “biosexternal”.


  • Testers

    @george1421 That’s apparently the default in my conf file. I’ll set it back to refind and see what it does.


  • Moderator

    @mrcur Then edit /var/www/html/fog/service/ipxe/refind.conf

    comment out

    # scanfor internal
    

    and uncomment

    scanfor internal,hdbios,external,biosexternal
    

    that should tell it to look in more places to see if it can find a boot device. rEFInd is a good choice to set as your global uefi exit mode. Its a real good boot loader (akin to grub)


  • Moderator

    @mrcur ok set exit mode for uefi to rEFInd. Let me look through the config file. I should be in /var/www/html/fog/service/ipxe directory.


  • Testers

    @george1421 It’s UEFI (the HP 440 G4).


  • Moderator

    @mrcur What type of hardware (uefi / bios-legacy) are you having issues with?

    If its uefi, you will probably want to use rEFInd as your exit mode. You may need to tweak the refind.conf file to search for more devices if its not locating the hard drive.

    As for a kernel update not important. This is still in iPXE, not FOS. So the iPXE boot code is in charge.


  • Testers

    @george1421 Having tried each of the exit types without success, any other suggestions? Perhaps a kernel update?



  • @computercolin
    Just my $.02 worth… IF you are forcing a network boot it may loop as well. At least on our DELLs if you hit F3 to FORCE network boot and then try to boot to HDD/SSD it wont find it. Now this is also using DNSMASQ to send a boot menu and options. Not a straight DHCP.

    If allowed to pick up network boot automatically(even at first option) it works normally.

    This is all before fog menu comes up, purely the pxe/ipxe boot process.

    Jason


  • Moderator

    Perhaps a picture would help clarify what exactly happens.

    What’s your DHCP server setup like?


  • Moderator

    Just so I’m clear, the 440s pxe boot just fine to the FOG iPXE boot menu is that correct.

    But the problem comes when the timeout on the iPXE menu reaches 0 it doesn’t boot from the hard drive? It tries to just pxe boot again, like the target computer just rebooted and never loads from the hard drive?

    If this is true, then your exit mode from FOG is not set correctly. 90% of the time SANBOOT works great for locating the hard drive. Other times not so good. What I would do is change the bios exit mode from one system to the other FOG exit modes to see if it can locate the hard drive.

    The other option is if you don’t need unattended imaging, you can always set the format to be usb,ssd and then when you want to image (you have to be in front of the computer) but boot the computer and press the F12 key to get the boot menu. From there you can pick network boot.

    You can also leave the target computers in uefi mode if you just disable secure boot and then send the uefi kernel [ipxe.efi] to the target computer. But of course you must have a uefi based system image to deploy to that target computer.


Log in to reply
 

506
Online

38925
Users

10691
Topics

101434
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.