New to imaging Macs through FOG



  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu 16.04
    Client
    • Service Version:
    • OS: Mac OS X 10.12 Sierra
    Description

    Hey everyone, I’m new to attempting to boot a Mac to FOG, and eventually capturing the image for deployment. I’ve done it with Windows machines but I understand with Macs that it’s a bit more involved. Would someone be able to point me in the right direction as to the best standard to do this? Thank you very much in advance, we’re in a mixed environment using Windows server 2012 R2 for DHCP and DNS and end users that are Windows 10, 7, and OS X 10.10-.12, but I’m only concerned with Sierra devices.


  • Developer

    @CoolbluHat Good to hear that you got a little further. I might ask you to stop there and think it all over. Imaging the laptops over wireless? Do you really want this? Plus all the mess with two interfaces in the FOG server which you already see is causing a headache.
    In case you really wanna go the wireless way I’d recommend setting up your FOG server to only have one leg - in that wireless network segment. Up till now we’ve never had anyone trying to image over wireless and we don’t have the wireless drivers included in the FOS kernel. So you will hit a wall there too.

    I tried an ethernet to thunderbolt network connection, but the boot up doesn’t try to set up a DHCP address through that network method.

    What going wrong when you try PXE booting on the thunderbolt NIC? Please describe what’s happening and possibly also post a picture of the error if you run into one. Seems to work: https://vimeo.com/95132633



  • @Sebastian-Roth Thank you for the tips and tricks. So I’ve gotten past the TFTP failures, it’s finding the server now. To answer your question, yes they are on two different subnets. I tried an ethernet to thunderbolt network connection, but the boot up doesn’t try to set up a DHCP address through that network method. It forces me to use a wireless connection, which I’ve set up to be available and connected when I start the boot-up process on the laptop. What I did to resolve the TFTP issue was use the secondary NIC on our Ubuntu server, set the static ip address to match that of the subnet that the laptop is connecting to via WiFi. But now I’m running into an http Timeout, it’s pointing to the primary NIC that I created the server on. Is it possible for FOG to utilize two Ip addresses for web management? I only see the ability to change it to one IP address, but if it can manage multiple addresses on it’s respective NICs, I might just be able to get this Mac fully connected to FOG.

    Many thanks again in advance.


  • Developer

    @CoolbluHat Wohooo, you are on the right track I reckon! So far to me this looks like you don’t have that special Mac OS X issue where a firmware update broke the network card. At least you seem to get an IP address via DHCP which is definitely a first great step. To get one step further you need to add option 66 (next server) to your Windows DHCP server because iPXE is using that information to find your FOG server and go ahead. Check out this wiki article on how to configure your Windows DHCP server.

    Don’t get confused by it saying that you should set option 67 (boot file name). By blessing your client you kind of made the first hurdle without having to provide option 67. I think you could even go without the vendor class policy if you only PXE boot those Mac OS X clients. But I guess it’s definitely worth doing it right from scratch as described in the wiki.

    The tftp://xx.xx.xx.xx/default.ipxe…Connection timed out is strange. Is your FOG server on a different subnet? Or maybe you just had a typo in the IP?

    Please let us know if you need more information or assistance. As well it would be great to hear if you got it working.



  • @TaTa @Sebastian-Roth Thank you for this help so far. After I attempted the steps above, I receive an error on the laptop:

    iPXE 1.0.0+ (356f) – Open Source Network Boot Firmware – http://ipxe.org
    Features: DNS FTP HTTP HTTPS iSCSI NFS TFTP SRP VLAN AoE EFI Menu
    Configuring (net0 aa:bb:cc:dd:ee:ff)…ok
    Received DHCP answer on interface net0
    Please enter tftp server: xx.xx.xx.xx (I entered the ip address of our fog server)
    tftp://xx.xx.xx.xx/default.ipxe…Connection timed out (http://ipxe.org/4c126092)
    Chainloading failed, hit ‘s’ for the iPXE shell; reboot in 10 seconds

    I’ve also blessed the laptop before attempting to boot to the EFI USB device, after running csrutil on Recovery-boot startup. Both commands completed successfully when I ran them; so are my next step(s) to try the other *.efi files in the tftpboot directory of the server and re-name them to bootx64.efi?

    Thank you all in advance for this help.



  • @CoolbluHat as Sebastian Roth said, you need to bless your clients (SIP must be disabled) or you can create a bootable usb

    1. Format USB as FAT32
    2. create folders in USB drive EFI\BOOT
    3. Copy ipxe.efi in your tftpboot directory in your FOG server to EFI\boot and rename this file to bootx64.efi (try different *.efi files if this one does not work)

    Prepare to upload image:
    Like you do for Windows machines, create a standard image, add a new host for this Mac
    create a new image in Image Management. Select Apple Mac OS, Multiple Partition Image - Single Disk
    Schedule an image capture
    Boot up this Mac using USB (hold down alt and select EFI).

    You might need to grow the disk if you download the image to a bigger drive.

    This method does not work for all Macs at least does not work on my MacBook Air early 2014 but worked on MacBook Air late 2015 using thunderbolt to ethernet with ssd formatted in 4K cluster size and most of the models with a built-in Ethernet card.


  • Developer

    @CoolbluHat Just wanted to add that you’ll probably need to ‘bless’ your clients (see in the wiki article) when using windows DHCP server for PXE booting.


  • Moderator

    @CoolbluHat Start here: https://wiki.fogproject.org/wiki/index.php?title=FOG_on_a_MAC

    I couldn’t offer you much assistance since I’ve never FOG’d a Mac before.
    The best I can recommend is use Google to search through the forums for keywords (other than Mac because mac addresses).

    Google’s direct search engine is better at searching and displaying than the forums search is.
    Go to google.com and do it like this to search only this site:
    site:forums.fogproject.org "osx"
    Another example:
    site:forums.fogproject.org "imac"


Log in to reply
 

375
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.