Location plugin not working after update to 1.4.4



  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu 16.04.2 LTS
    Client
    • Service Version: 0.11.12
    • OS: All
    Description

    Location plugin not working after update to 1.4.4

    After the upgrade the location plugin does not work as expected.
    It does not take care of the site and always take the 1st node available instead of the location setted one.
    I have remove and reinstalled the plugin related to this topic (https://forums.fogproject.org/topic/10364/issues-after-upgrading-from-1-4-3-to-1-4-4/6) and executed the command but no luck. Still taking the 1st node.

    i have 2 storage nodes in the same storage group, and each one on different location.
    What i’am doing wrong?

    Thanks


  • Senior Developer

    For reference, setting master node to a group should reset all nodes to the group to no longer be master and define the chosen item. That said, when paired with the Location Plugin, there’s a hook to “trick” the nodes in a location to believe they are also master nodes to enable multicast to happen, maybe this is what made the GUI appear to have two master nodes in a single group?


  • Senior Developer

    @Wayne-Workman Sorry didn’t see this till now, no, that is still the case.



  • @Quazz said in Location plugin not working after update to 1.4.4:

    You have set two different nodes as master node in the same Storage Group. This will cause all sorts of issues, only one node can be master node in a group.

    This is off topic a bit but, I believe a couple years ago, @Tom-Elliott had the GUI setup so it wouldn’t allow you to set more than one master per group. I guess that’s not the case anymore?



  • Thanks for all your answers!!

    I know that my configuration is not standard but i am quite sure that was working for the deploy part:

    My Fog Server is a VM that has not enough space to store images.
    Only the Synology Nodes stores the images, snappins and tftp files.
    I know that Synology Node cannot perform replication so i have made the replication by CloudShare Sync.

    The workaround i have applied to deploy or capture my images since the problem appeared is to disable the storage node of the remote site when i make a deploy or capture.

    I have tried to capture an image in this way and deploy on the other site ans it works.
    Only the location is not working.

    0_1499949064352_588a53eb-a90e-4d91-a8fc-d0674cf989c7-image.png


  • Senior Developer

    Image Captures are ALWAYS done to the Master Node in a group. Based on the Pictures I’m seeing, UN-002 CDF (location) is NOT a master node. However, when replication occurs it should be placed on UN-002 CDF’s defined storage location.

    You MIGHT have to restart the Master node’s FOGImageReplicator/FOGSnapinReplicator services for the change to take effect.


  • Moderator

    @Al.cmb Just for clarity in your picture (referenced by this post) if you have a NAS as a master node replication will not happen to other storage nodes in the storage group. If a FOG server (normal install) is the master node in a storage group then replication happens. Just be aware of this. It doesn’t explain your current issue though.


  • Moderator

    Cross linking threads, the experience seems to be similar: https://forums.fogproject.org/topic/10432/i-would-like-a-add-a-new-hdd



  • How can i debug that?
    Log files to check or anything else?


  • Moderator

    @Al.cmb As George said, image capture always goes to the Master node of the Group. The Master then copies it over to the rest of the group via the Image Replication service.

    If this is not the desired behavior, then you will need another Group.

    Deployment should work as expected, though, so that’s odd.



  • Sorry that was for tests. I have corrected that but still the same issue:
    0_1499943058405_241dcd8c-32f8-4528-9b6e-e3796b8d4519-image.png
    0_1499943070466_2b7bbd8f-7d89-4d2c-922b-60325884c493-image.png


  • Moderator

    You have set two different nodes as master node in the same Storage Group. This will cause all sorts of issues, only one node can be master node in a group.



  • The 2 cases: Deploy and Capture.
    This is my config. As you can see i have set UN002-CDF as location (that contains UN-Syno2) and the working node is wrong (UN-Syno1 the other location)
    0_1499941500080_41afa921-63bd-4256-ab45-25182508a660-image.png
    0_1499941478364_ee34bff2-3e2c-4845-85f7-1c4f10326165-image.png
    0_1499941403552_f093fad7-258b-4586-b8b8-b7f858e60366-image.png
    0_1499941630462_addc38df-ad8e-4a2c-8572-735f3d3f2c1f-image.png


  • Moderator

    Is this for capture or deploy?

    For image capture the master node in the storage group is always used.


 

502
Online

41.8k
Users

12.3k
Topics

116.1k
Posts