Clonezilla Boot problem



  • Hi members,

    I am new to fog project and trying to boot the clonezilla from it.

    I have created the menu entry and using the following parameters.

    :Clonezilla
    echo Starting CloneZilla with default options
    kernel http://${fog-ip}/fog/service/ipxe/clonezilla/vmlinuz
    initrd http://${fog-ip}/fog/service/ipxe/clonezilla/initrd.img
    imgargs vmlinuz boot=live config noswap nolocales edd=on nomodeset ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_keymap="" ocs_live_batch=“no” ocs_daemonon=“ssh” usercrypted=Kb/VNchPYhuf6 ocs_lang="" vga=788 nosplash noprompt fetch=http://${fog-ip}/fog/service/ipxe/clonezilla/filesystem.squashfs
    boot || goto failed
    goto start

    :CLONEZILLA
    kernel http://${fog-ip}/fog/service/ipxe/clonezilla/vmlinuz
    initrd http://${fog-ip}/fog/service/ipxe/clonezilla/initrd.img
    imgargs vmlinuz boot=live username=user fetch=http://${fog-ip}/fog/service/ipxe/clonezilla/filesystem.squashfs locale=en_US.UTF-8 keyboard-layouts=NONE
    boot || echo failed to boot
    prompt
    goto MENU

    I have got these parameters from Forum.

    Now when I am selecting the Clonezilla on boot menu it gives me the below error.

    0_1497877024604_error.png

    Please let me know that what is wrong with the config.

    Your help is appreciated.

    Regards,



  • @Sebastian-Roth

    Yes I tried the below code which you have given and it works, Many thanks.

    kernel http://${fog-ip}/fog/service/ipxe/clonezilla/vmlinuz
    initrd http://${fog-ip}/fog/service/ipxe/clonezilla/initrd.img
    imgargs vmlinuz initrd=initrd.img boot=live username=user union=overlay config components quiet noswap edd=on nomodeset nodmraid locales= keyboard-layouts= ocs_live_run="ocs-live-general" ocs_live_extra_param="" ocs_live_batch=no net.ifnames=0 nosplash noprompt fetch=http://${fog-ip}/fog/service/ipxe/clonezilla/filesystem.squashfs
    boot || goto MENU
    

    and yes it is all about the putting right parameters.

    Regards,


  • Developer

    @deepak727 Tried it myself… This worked like a charm in a virtualbox VM:

    kernel http://${fog-ip}/fog/service/ipxe/clonezilla/vmlinuz
    initrd http://${fog-ip}/fog/service/ipxe/clonezilla/initrd.img
    imgargs vmlinuz initrd=initrd.img boot=live username=user union=overlay config components quiet noswap edd=on nomodeset nodmraid locales= keyboard-layouts= ocs_live_run="ocs-live-general" ocs_live_extra_param="" ocs_live_batch=no net.ifnames=0 nosplash noprompt fetch=http://${fog-ip}/fog/service/ipxe/clonezilla/filesystem.squashfs
    boot || goto MENU
    

    Your first two parameter sets were missing the very important union=overlay. The one you found on the clonezilla website was right, you just needed to exchange ‘http://’ for ‘tftp://’… So this works just as well for me:

    initrd http://${fog-ip}/fog/service/ipxe/clonezilla/initrd.img
    chain -ar http://${fog-ip}/fog/service/ipxe/clonezilla/vmlinuz initrd=initrd.img boot=live username=user union=overlay config components quiet noswap edd=on nomodeset nodmraid locales= keyboard-layouts= ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_batch=no net.ifnames=0 nosplash noprompt fetch=http://${fog-ip}/fog/service/ipxe/clonezilla/filesystem.squashfs
    boot || goto MENU
    

    It’s all about the right parameters.



  • @Sebastian-Roth

    I am using clonezilla 2.5.0-25 the latest stable release. On there website for the PXE boot options they are suggesting to have below settings.

    label Clonezilla-live
    MENU LABEL Clonezilla Live (Ramdisk)
    KERNEL vmlinuz
    APPEND initrd=initrd.img boot=live username=user union=overlay config components quiet noswap edd=on nomodeset nodmraid locales= keyboard-layouts= ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_batch=no net.ifnames=0 nosplash noprompt fetch=tftp://$serverIP/filesystem.squashfs

    But this is TFTP based

    Ref : http://clonezilla.org/livepxe.php

    and I am using this with

    initrd http://${fog-ip}/fog/service/ipxe/clonezilla/initrd.img
    imgfetch http://${fog-ip}/fog/service/ipxe/clonezilla/filesystem.squashfs
    chain -ar http://${fog-ip}/fog/service/ipxe/clonezilla/vmlinuz boot=live username=user union=overlay config components quiet noswap edd=on nomodeset nodmraid locales= keyboard-layouts= ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_batch=no net.ifnames=0 nosplash noprompt initrd=initrd.img
    

    Please let me know what should be correct parameters.

    @Junkhacker

    I have checked the file integrity and there is no problem in it.


  • Developer

    @deepak727 Which version of clonezilla are you trying to boot? Looks like different versions need different parameters… https://sourceforge.net/p/clonezilla/discussion/Clonezilla_live/thread/0f8505b0/ and https://sourceforge.net/p/drbl/discussion/Help/thread/a70b3897/


  • Developer

    @deepak727 “junk in compressed archive” you may want to verify the integrity of your files



  • Hi @Junkhacker

    I have gone through the post and used the following code.

    initrd http://${fog-ip}/fog/service/ipxe/clonezilla/initrd.img
    imgfetch http://${fog-ip}/fog/service/ipxe/clonezilla/filesystem.squashfs
    chain -ar http://${fog-ip}/fog/service/ipxe/clonezilla/vmlinuz boot=live username=user union=overlay config components quiet noswap edd=on nomodeset nodmraid locales= keyboard-layouts= ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_batch=no net.ifnames=0 nosplash noprompt initrd=initrd.img
    

    Now I am getting the below error

    0_1497882326553_error1.png

    Regards,


  • Developer



  • Hi @Wayne-Workman

    Thanks for the response.

    I have checked in my configuration, I have no clue from where those two commas (noatime,dirs=live…) are coming from.

    You can see the parameters which I have posted, it doesn’t have those commas or a option of noatime.

    Regards,


  • Moderator

    There’s two commas in a row in the error, that’s probably related. Most likely meaning there’s two commas somewhere when maybe there should only be one or none.


Log in to reply
 

339
Online

38727
Users

10554
Topics

99921
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.