Not a fog bug - Setting up and starting MySQL hangs - Arch Linux


  • Moderator

    Server
    • FOG Version: 1.4.2
    • OS: Latest Arch
    Description

    Not a fog bug, but I’m putting this here so we can track it and others can find it.

    During installation of any branch (working, dev-branch, master), FOG installer hangs at Setting up and starting MySQL

    Looking deeper into it, MariaDB is crashing. Errors:

    WARNING: The host 'Arch' could not be looked up with resolveip.
    This probably means that your libc libraries are not 100 % compatible
    with this binary MariaDB version. The MariaDB daemon, mysqld, should work
    normally with the exception that host name resolving will not work.
    This means that you should use IP addresses instead of hostnames
    when specifying MariaDB privileges !
    Installing MariaDB/MySQL system tables in '/var/lib/mysql' ...
    2017-06-17 14:18:12 140206427066304 [Note] /usr/sbin/mysqld (mysqld 10.1.24-MariaDB) starting as process 894 ...
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: innodb_empty_free_list_algorithm has been changed to legacy because of small buffer pool size. In order to use backoff, increase buffer pool at least up to 20MB.
    
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: Using mutexes to ref count buffer pool pages
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: The InnoDB memory heap is disabled
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: Compressed tables use zlib 1.2.11
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: Using Linux native AIO
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: Using SSE crc32 instructions
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: Initializing buffer pool, size = 128.0M
    2017-06-17 14:18:12 140206427066304 [Note] InnoDB: Completed initialization of buffer pool
    2017-06-17 14:18:13 140206427066304 [Note] InnoDB: Highest supported file format is Barracuda.
    2017-06-17 14:18:13 140206427066304 [Note] InnoDB: 128 rollback segment(s) are active.
    2017-06-17 14:18:13 140206427066304 [Note] InnoDB: Waiting for purge to start
    2017-06-17 14:18:13 140206427066304 [Note] InnoDB:  Percona XtraDB (http://www.percona.com) 5.6.36-82.0 started; log sequence number 1616799
    2017-06-17 14:18:13 140205812004608 [Note] InnoDB: Dumping buffer pool(s) not yet started
    170617 14:18:15 [ERROR] mysqld got signal 11 ;
    This could be because you hit a bug. It is also possible that this binary
    or one of the libraries it was linked against is corrupt, improperly built,
    or misconfigured. This error can also be caused by malfunctioning hardware.
    
    To report this bug, see https://mariadb.com/kb/en/reporting-bugs
    
    We will try our best to scrape up some info that will hopefully help
    diagnose the problem, but since we have already crashed, 
    something is definitely wrong and this may fail.
    
    Server version: 10.1.24-MariaDB
    key_buffer_size=16777216
    read_buffer_size=262144
    max_used_connections=0
    max_threads=153
    thread_count=0
    It is possible that mysqld could use up to 
    key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 137013 K  bytes of memory
    Hope that's ok; if not, decrease some variables in the equation.
    
    Thread pointer: 0x0
    Attempting backtrace. You can use the following information to find out
    where mysqld died. If you see no messages after this, something went
    terribly wrong...
    stack_bottom = 0x0 thread_stack 0x48400
    

    I’ve created an issue with the MariaDB team here:
    https://jira.mariadb.org/browse/MDEV-13116

    You can also monitor the issue on the fog testing dashboard here:
    http://perpetuum.io:20080/fog_distro_check/installer_dashboard.html


  • Moderator

    This appears to be resolved now.
    I’m going to guess that someone over at Arch Linux botched a build of some package & didn’t know until a day later & fixed it.


  • Developer


Log in to reply
 

359
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.