SOLVED Installing FOG on Debian Stretch fails


  • Server
    • FOG Version: 1.4.0
    • OS: Debian Stretch (9.0)
    Description

    Downloaded the latest tarball of the install. Extracted, ran the installfog.sh command. After confirming, I wait for it to install packages, and it fails to install php5 and its modules.

    Debian Stretch does not have php version 5 available anymore.

    Is there a known fix to get the install script to run? Will it work with PHP 7? This is a brand new VM, no other changes made.


  • @plegrand said in Installing FOG on Debian Stretch fails:

    Is it possible to only upgrade debian , or is it better to reinstall everything from scratch ?

    You could do either. There are pros and cons for both. That said - I don’t test upgrading Debian that already has FOG installed - I only test installing fog on upgraded Debian. And upgrading always involves some risk.


  • @plegrand it works now, on version 1.4.3


  • @Tom-Elliott Just for information :
    Is it possible to only upgrade debian , or is it better to reinstall everything from scratch ?


  • I don’t know why this was reported like this should’ve been fixed already. (No I don’t keep track of all Distribution release dates.)

    I’ve fixed, and tested, the installer under Debian 9 RC-4. Knowing Debian tends to be very stable, I think this is suitable enough.

    The working branch contains these fixes if you MUST install fog on Debian 9.


  • Debian 9 has been added to the daily tests. You can see the daily test results using the dashboard link in my signature.


  • Debian 9 stable is not yet released. However, looks like they will release next week. So I’ll get this worked into our daily tests.

268
Online

9.5k
Users

15.9k
Topics

147.5k
Posts