PXE Boot Problems



  • Server
    • FOG Version: 1.4.0
    • OS: Ubuntu 14.04
    Client
    • Service Version: 0.11.12
    • OS: Windows 7 Pro
    Description

    I seem to be experiencing issues with PXE booting on one segment of our network. I don’t know whether it’s network related or not. I have other machines near by that seem to network boot fine. I can boot the same machine type from another segment of our network fine as well.

    Here are the errors…

    0_1495743813520_PXEBootError1.jpg

    This one never finishes loading. It locks at the step below.
    0_1495743824572_PXEBootError2.jpg

    Thanks!!


  • Developer

    @Joe-Gill said in PXE Boot Problems:

    I can boot the same machine type from another segment of our network fine as well.

    For the first picture: So why should it be an iPXE issue then? This sounds really weird. Is this issue reproducible?

    For the second picture: I suppose this model does not properly PXE boot in a different network segment, right? As George said, try different iPXE binaries (find them /tftpboot on your server) to see if one of them works…


  • Moderator

    @Joe-Gill You have to know what hardware you are using, but the default setting for pxe booting (at least for bios mode) is undionly.kpxe. That is the most generic and universal driver. There are other boot files on your fog server in the /tftpboot directory. There is one specific for realtek chips, as well as intel network chips. You just update/replace undionly.kpxe in your dhcp option 67 with one of the other iPXE kernels.



  • @Joseph-Hales

    I have not tried a different kernel yet.

    Is their a wiki on how to change the PXE kernel?

    Thanks!

    Joe Gill
    Townsend K12 Schools


  • Testers

    I second the suggestion of getting a USB NIC to resolve the issue these also come in handy if you need to image a Surface or other PC tablet that does not have a built in wired NIC. On the HP PXE issue have you tried a different kernel I have resolved this issue before that way.


  • Moderator

    @Joe-Gill PXE booting is not supported over wifi AFAIK. BUT you could either pxe boot off a supported usb 2.0 to ethernet adapter, or usb boot either iPXE or FOS to get you going.



  • @george1421

    Well the firmware upgrade did not resolve the issue. I did notice their was an old post on this subject from 2005. It sounds as though the HP NIC’s didn’t function the best with FOG PXE booting. I only have 3 of these machines so I may just rebuild them the long way. At this point, it probably makes most since.

    Is their any way possible to PXE boot to a wireless card? They have one of those as well…

    Any other ideas, please shoot them my way. Thanks!

    Cheers,

    Joe Gill
    Townsend K-12 Schools



  • @george1421

    Good call! I’ll try that.


  • Moderator

    @Joe-Gill firmware is all up to date on these??



  • @george1421

    The funny thing is they all share the same switch as other models that PXE boot fine. All of the ports are configured the same way.


  • Moderator

    In your first picture. If you have another computer (or the same with a windows OS loaded) from that specific network jack. Can you ping the fog server at 172.16.1.17? (assuming that is your fog server’s IP address).

    If so can you then install the tftp client on that windows box and try to use tftp to get…

    Wait that has to work because iPXE is loading, and that is delivered via tftp.

    Does the network switch where this computer is plugged into have spanning tree enabled? AND you are not using one of the fast spanning tree protocols like RSTP Fast-STP or what ever your switch manufacture calls it in their hardware?


Log in to reply
 

445
Online

39003
Users

10717
Topics

101764
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.