Join domain active directory -- Error



  • Server
    • FOG Version: 1.4.0
    • OS: Ubuntu 16.04
    Client
    • Service Version: 0.11.12
    • OS: Windows 7
    Description

    Not able to join domain…when i look into “FOG System Settings” – Active Directory Defaults

    **On FOG_AD_DEFAULT_USER if we enter “domain\username” (double slash)
    is coming (e.g.domain\\username ) if give again save changes "domain\\\\username " (four slash)is coming, IF again give save changes “domain\\\\\\\\username” (eight slash) is coming

    Please check0_1495713814891_fog-ad-error.JPG



  • @Tom-Elliott super g8


  • Senior Developer

    @Satheesh Not will, already did :)



  • @Avaryan : Yes I have tried by removing domain in FOG_AD_DEFAULT_USER it’s worked. Tom Elliott will find the solution for this.


  • Senior Developer

    So I found the thing adding the slashes erroneously. It should be fixed in the working branch if you’d like to install it to give it a shot.


  • Senior Developer

    The correct method is to do the non-domain setting though FOG does support this capability.

    The problem is how php deals with escape characters, however. The \ is the default escape character in PHP. Because of this, to display a single \ you must actually display \\. This is great for non-input fields, but in text fields it shows the raw data. Unfortunately there’s not a pretty way to handle this :(.



  • @Satheesh So, I just checked my 1.4.0 test server and had the same thing. My only thought is that maybe they don’t want you putting DOMAIN\ into that field. There is the FOG_AD_DEFAULT_DOMAINNAME above it. Probably goes there.

    So…
    FOG_AD_DEFAULT_DOMAINNAME = DOMAIN
    FOG_AD_DEFAULT_USER = USER

    edit: Just checked my live server and I do not have the domain name in the user field. For domainname field I have domain.com


Log in to reply
 

389
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.