Sysprep - Windows could not complete the installation



  • Server
    • FOG Version:
    • OS:
    Client
    • Service Version:
    • OS:
    Description

    Hi all,
    I’ve just built an image in a Hyper-V VM, set-up an unattend.xml file using the Windows System Image Manager and set the VM to sysprep. However, upon boot I now receive: “Windows could not complete the installation. To install Windows on this computer, restart the installation”. This then loops repeatedly, until I open a command prompt and start ms oobe to bypass the user account screen.
    Has anyone come across this before? I know how to fix it, but how do I prevent it in the first place? I can post my unattend.xml file if it helps.



  • It appears it’s an issue with the Unattend.xml file. I’ve tried one that has worked in the past and that’s absolutely fine.

    Thanks for the help, gents!



  • @george1421 Sorry; to clarify: the FOG client is installed from the setup.cmd script. The fog.postdownload script calls fog.postclient, which copies the setup.cmd script from the FOG server across to the Windows installation and then appends the .cmd script with the instructions to install the FOG client.
    That step isn’t being hit yet, though.

    I don’t think it could be drivers considering this is a Hyper-V VM… I haven’t had to install any.
    Checking the sysprep error log in C:\Windows\System32\Sysprep\Panther, it says:
    "[0x0f0043] SYSPRP WinMain: The sysprep dialog box returned FALSE.
    (This repeats for 5 lines)
    [0x0f00a4] SYSPRP WinMain: Unable to parse command-line arguments to sysprep;m GLE = 0x0

    @sudburr I don’t have any anti-virus installed on the image.



  • Antivirus can also do this. Have you tried letting the original VM boot?


  • Moderator

    @RobTitian16 said in Sysprep - Windows could not complete the installation:

    I haven’t installed the FOG client on this system (it’s installed using a postdownload script on the FOG server)

    Just to reconfirm, you have not installed the FOG client on your reference image? We have seen if the fog client is enabled, it starts doing its job before OOBE is setup causing the error you posted. Its not possible to install the FOG Client using the postdownload script. The post download script runs in linux and the fog client is windows.

    I HAVE seen this error happen when a driver either isn’t installed or breaks the install and causes OOBE to reboot unexpectedly. When this happens you can press Sift (or Ctrl) F10 to get a windows command prompt and then inspect the unattend install logs. Just google the error message you have and there are exact instructions on using the F10 key to get a command prompt open and which logs to review. This is not a FOG issue but a windows OOBE issue.



  • @Psycholiquid I’m capturing a Windows 10x64 system.
    I put the system into Audit mode to build the image, copied the unattend.xml file across and then told it to perform a sysprep with the out of box experience. I also checked the ‘generalize’ box.

    I haven’t installed the FOG client on this system (it’s installed using a postdownload script on the FOG server) and I haven’t installed any drivers, either (I intend to install them using a postdownload script depending what machine it is).


  • Testers

    Might help to know the OS your capturing. Windows 10 and Windows 7 act completely different in regards to unattend.xml files.


  • Senior Developer

    This can happen for any number of reasons.

    In particular, if the FOG Client hasn’t been disabled, this problem may occur as the client may cause the device to reboot before sysprep has finished.

    I’ve also seen this happen because when you went to capture the image, before you created the task the system rebooted and started going into windows, was then caught and powered off, then captured.

    Drivers can cause this problem as well.


Log in to reply
 

330
Online

38724
Users

10553
Topics

99906
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.