Problem with Fog 1.3.5 install-- Setting up and Starting MySql...........FAILED! :(



  • Aloha,

    Im trying to install the newest version of fog, but it is giving me this error. See attached. Any ideas on how to fix it. I am using “sudo” to run the installation files.

    Thank you very much,
    F

    0_1494531992190_fog.JPG

    Server
    • FOG Version: 1.3.5
    • OS: Linux 18.1 32
    Client
    • Service Version:
    • OS:
    Description

  • Senior Developer

    @safari2010 On screen where it’s giving the long warning, please say yes.



  • @Tom-Elliott

    So Im getting this now when I install, this is under master and working checkouts’

    Somehow the install fails. 0_1495523016993_Capture2.JPG

    Last few lines from the past failures-- looks like its pointing to PHP.

    Selecting previously unselected package xinetd.
    (Reading database … (Reading database … 5% (Reading database … 10% (Reading database … 15% (Reading database … 20% (Reading database … 25% (Reading database … 30% (Reading database … 35% (Reading database … 40% (Reading database … 45% (Reading database … 50% (Reading database … 55% (Reading database … 60% (Reading database … 65% (Reading database … 70% (Reading database … 75% (Reading database … 80% (Reading database … 85% (Reading database … 90% (Reading database … 95% (Reading database … 100% (Reading database … 234861 files and directories currently installed.)
    Preparing to unpack …/xinetd_1%3a2.3.15-6_i386.deb …
    Unpacking xinetd (1:2.3.15-6) …
    Processing triggers for man-db (2.7.5-1) …
    Processing triggers for doc-base (0.10.7) …
    Processing 1 added doc-base file…
    Registering documents with scrollkeeper…
    Processing triggers for ureadahead (0.100.0-19) …
    Processing triggers for systemd (229-4ubuntu12) …
    Setting up xinetd (1:2.3.15-6) …
    Processing triggers for systemd (229-4ubuntu12) …
    Processing triggers for ureadahead (0.100.0-19) …
    ii zlib1g:i386 1:1.2.8.dfsg-2ubuntu4.1 i386 compression library - runtime
    Reading package lists…
    Building dependency tree…
    Reading state information…
    Package libapache2-mod-php5 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Package php5 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package ‘libapache2-mod-php5’ has no installation candidate
    E: Package ‘php5’ has no installation candidate
    Reading package lists…
    Building dependency tree…
    Reading state information…
    Package libapache2-mod-php5 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Package php5 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package ‘libapache2-mod-php5’ has no installation candidate
    E: Package ‘php5’ has no installation candidate



  • Thanks Tom. OK I will use Fedora. Ive attached some screenshots, is this typical? This is with ubuntu (i will change to fedora after this)

    0_1495521242114_Capture1.JPG

    Im seeing this in other OS but this is a clean install using a empty VM, so Im not sure what its referring too about apache2. I dont recall seeing this error before. I did manage to get it running just once.

    Thanks,
    Francis


  • Senior Developer

    @safari2010 It should work.

    You can just get the last few lines of the error logs to post here as that’s where the error most likely occurs.

    I assure you, however, it does work and installs properly according to our nightly tests.

    Moving to Ubuntu will work, but if you’re willing to make the move, I’d suggest using Debian, CentOS, or Fedora as the base os for the server. Ubuntu has its own set of problems that will seemingly come from you doing nothing.



  • @george1421 @Tom-Elliott

    So sorry, I thought this was done- but using the git checkout master or git checkout working im getting fail on PHP5.

    OS is Linux 18.1 32 bit.

    At this point I will try using UBUNTU. I’m thinking this maybe a Mint issue

    How do I post an error log here? It says there is character limit so I can paste it there.

    Thank You.



  • @Tom-Elliott and @george1421 — perhaps if we get some extra funding ;) That said, if you come to hawaii for a conference. Hit me up and i will be happy to show you the beautiful Big Island!!!

    Again, Thank you for all you do!


  • Senior Developer

    @george1421 ME TOO? lol.


  • Moderator

    @safari2010 If you send the plane tickets, I will personally come out and inspect your FOG setup if you like :-)

    Just be aware that this command will install the working branch (think of it as alpha code). You probably only want to use this branch if instructed by one of the developers.
    git checkout working

    And this command will get the latests Release Candidate (RC) release
    git checkout dev-branch

    And finally this one is for the stable releases
    git checkout master

    Just be aware that FOG 1.4.0 (stable) was released over this past weekend



  • Aloha and Mahalo Tom and George1421!

    Your instructions worked and now we are able to use fog here in Hawaii!

    Commands I used for those having issues:

    sudo -i

    sudo apt-get update && apt-get install git

    git clone https://github.com/FOGProject/fogproject.git /opt/fogproject
    cd /opt/fogproject

    git checkout working
    git pull
    cd bin
    ./installfog.sh


  • Moderator

    @Tom-Elliott I grabbed a copy of their Xfce, I’ll get it worked in.


  • Senior Developer

    So not really a “bug” as Mint wasn’t natively supported. However, I have now incorporated Linux Mint support to the installers.

    @Wayne-Workman If you wanted to create a linux mint installer to your automated tests we should be able to do so now. It works alongside of Ubuntu so shouldn’t be too hard to integrate.


  • Senior Developer

    @safari2010 woudl you mind installing the working branch now?

    I added Mint to the “ubuntu” lists, and this hopefully will mean things will work for you natively now.

    git checkout working
    git pull
    cd bin
    ./installfog.sh -y
    


  • @george1421 Hi I tried this solution… I hit the same issue.

    same error on * Setting up and starting MySQL…FAILED>

    Thank you for your help.

    Below are the contents of the error log:

    /usr/bin/lsb_release
    /bin/systemctl
    Ign:1 http://packages.linuxmint.com serena InRelease
    Hit:2 http://packages.linuxmint.com serena Release
    Hit:4 http://archive.ubuntu.com/ubuntu xenial InRelease
    Get:5 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
    Hit:6 http://archive.canonical.com/ubuntu xenial InRelease
    Get:7 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
    Get:8 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
    Fetched 306 kB in 2s (150 kB/s)
    Reading package lists…
    …/lib/common/functions.sh: line 611: python-software-properties: command not found
    11 May 12:14:56 ntpdate[19388]: the NTP socket is in use, exiting
    Generating locales (this might take a while)…
    en_US.UTF-8… done
    Generation complete.
    Executing: /tmp/tmp.USDICWlVmI/gpg.1.sh --keyserver
    hkp://keyserver.ubuntu.com:80
    –recv-keys
    E5267A6C
    gpg: requesting key E5267A6C from hkp server keyserver.ubuntu.com
    gpg: key E5267A6C: public key “Launchpad PPA for Ondřej Surý” imported
    gpg: Total number processed: 1
    gpg: imported: 1 (RSA: 1)
    You are about to add the following PPA:
    Co-installable PHP versions: PHP 5.6, PHP 7.0, PHP 7.1 and most requested extensions are included.

    PLEASE DON’T USE PHP 5.4 OR PHP 5.5. The PHP 5.5 and later are no longer supported with security updates, therefore they are not included in this repository.

    You can get more information about the packages at https://deb.sury.org

    BUGS&FEATURES: This PPA now has a issue tracker: https://deb.sury.org/#bug-reporting

    PLEASE READ: If you like my work and want to give me a little motivation, please consider donating regularly: https://donate.sury.org/

    WARNING: add-apt-repository is broken with non-UTF-8 locales, see https://github.com/oerdnj/deb.sury.org/issues/56 for workaround:

    LC_ALL=C.UTF-8 add-apt-repository ppa:ondrej/php

    More info: https://launchpad.net/~ondrej/+archive/ubuntu/php
    ii unzip 6.0-20ubuntu1 i386 De-archiver for .zip files
    UnZip 6.00 of 20 April 2009, by Debian. Original by Info-ZIP.

    Usage: unzip [-Z] [-opts[modifiers]] file[.zip] [list] [-x xlist] [-d exdir]
    Default action is to extract files in list, except those in xlist, to exdir;
    file[.zip] may be a wildcard. -Z => ZipInfo mode (“unzip -Z” for usage).

    -p extract files to pipe, no messages -l list files (short format)
    -f freshen existing files, create none -t test compressed archive data
    -u update files, create if necessary -z display archive comment only
    -v list verbosely/show version info -T timestamp archive to latest
    -x exclude files that follow (in xlist) -d extract files into exdir
    modifiers:
    -n never overwrite existing files -q quiet mode (-qq => quieter)
    -o overwrite files WITHOUT prompting -a auto-convert any text files
    -j junk paths (do not make directories) -aa treat ALL files as text
    -U use escapes for all non-ASCII Unicode -UU ignore any Unicode fields
    -C match filenames case-insensitively -L make (some) names lowercase
    -X restore UID/GID info -V retain VMS version numbers
    -K keep setuid/setgid/tacky permissions -M pipe through “more” pager
    -O CHARSET specify a character encoding for DOS, Windows and OS/2 archives
    -I CHARSET specify a character encoding for UNIX and other archives

    See “unzip -hh” or unzip.txt for more help. Examples:
    unzip data1 -x joe => extract all files except joe from zipfile data1.zip
    unzip -p foo | more => send contents of foo.zip via pipe into program more
    unzip -fo foo ReadMe => quietly replace existing ReadMe if archive file newer
    ii unzip 6.0-20ubuntu1 i386 De-archiver for .zip files
    Enter new UNIX password: Retype new UNIX password: passwd: password updated successfully
    Failed to stop FOGMulticastManager.service: Unit FOGMulticastManager.service not loaded.
    Failed to stop FOGImageReplicator.service: Unit FOGImageReplicator.service not loaded.
    Failed to stop FOGSnapinReplicator.service: Unit FOGSnapinReplicator.service not loaded.
    Failed to stop FOGScheduler.service: Unit FOGScheduler.service not loaded.
    Failed to stop FOGPingHosts.service: Unit FOGPingHosts.service not loaded.
    Failed to stop FOGSnapinHash.service: Unit FOGSnapinHash.service not loaded.
    Failed to stop FOGImageSize.service: Unit FOGImageSize.service not loaded.
    Failed to execute operation: No such file or directory
    Failed to stop mysql.service: Unit mysql.service not loaded.
    Failed to start mysql.service: Unit mysql.service not found.
    ● mysql.service
    Loaded: not-found (Reason: No such file or directory)
    Active: inactive (dead)
    Failed to execute operation: No such file or directory
    Failed to stop mysqld.service: Unit mysqld.service not loaded.
    Failed to start mysqld.service: Unit mysqld.service not found.
    ● mysqld.service
    Loaded: not-found (Reason: No such file or directory)
    Active: inactive (dead)
    Failed to execute operation: No such file or directory
    Failed to stop mariadb.service: Unit mariadb.service not loaded.
    Failed to start mariadb.service: Unit mariadb.service not found.
    ● mariadb.service
    Loaded: not-found (Reason: No such file or directory)
    Active: inactive (dead)


  • Senior Developer

    @safari2010 Forgive me for being obstinate, but knowing the full information is far more useful than partial bits.

    Know that i know this, I’d suggest as @george1421 is suggesting. Also, getting us the installer’s error log would be very useful.


  • Moderator

    @safari2010 said in Problem with Fog 1.3.5 install-- Setting up and Starting MySql...........FAILED! :(:

    sorry, 32 Bit. Serena

    Ok so this translates to Linux Mint 18.1 Serena 32Bit. (based on Ubuntu LTS 16.04)

    In the same directory as the installfog.sh there should be an error log or log directory. Inside that should be some install logs look for one that reflects the version of fog you are installing. See if there is any useful information you can glean from that log.

    IMO you should just jump to one of the dev releases like 1.4.0RC13. You an do that by following the upgrade to trunk wiki: https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk

    sudo apt-get update && apt-get install git
    
    sudo -i
    git clone https://github.com/FOGProject/fogproject.git /opt/fogproject
    cd /opt/fogproject
    git checkout dev-branch
    cd bin
    ./installfog.sh
    

    The one concern I have is that I’m not sure FOG is tested against the 32 bit version of linux any more. Either way the log file will give a better idea why the sql server setup is failing.



  • @Tom-Elliott

    Linux Mint- 18.1 32Bit.
    XCFE

    I will install ubuntu and try it from there. Thank You.


  • Senior Developer

    @safari2010 what is Serena? The installer is tested on fedora, centos, Ubuntu, and Debian. I don’t know what Serena is.



  • Hello Tom,
    Im still getting this problem… Is there anyway to download a older version of Fog, I never had trouble installing those.

    0_1494533049870_fog.JPG

    Thank You,
    F



  • sorry, 32 Bit. Serena


Log in to reply
 

457
Online

38959
Users

10706
Topics

101583
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.