Multiboot image question



  • Server
    • FOG Version: 1.3.5
    • OS: Ubuntu 16.04 LTS
    Client
    • Service Version:
    • OS:
    Description

    I wonder if it possible to capture and after it debloy multiboot image? What Operation system i have to use and what image type? I have win7 where i have installed ubuntu 16.04 so its dualbootable. When i tried i use capture first time, im getting error. http://imgur.com/a/wa7sh

    I have installed drivers and few softwares to my windows but nothing to ubuntu. Do i need to do something to them before?



  • @Tom-Elliott there were few corrupted files on windows and fixed them, and after those it worked fine


  • Senior Developer

    @killerm What ended up being the problem and how did you solve it?



  • I finally got it working! thank to everybody who helped



  • @Tom-Elliott
    i am changing image type because i want to see if it could been the issue here, but appeared it’s not.
    I’m gonna try those commands on Windows and Linux if it could solve problem (fsck and CHKDSK). I have used both OS’s and they were fine. What about if i syspre windows? I have no access to those computers in few days, but i will come back after trying a bit more!

    https://vimeo.com/215184091

    There is one more video about whole thing(from start to end(error))


  • Senior Developer

    @killerm You’re confusing your self, and probably others here.

    Why are you changing the image type around?

    Capturing an image means you need to ensure the disk is ready to be captured. The message you’re seeing is saying it can’t proceed BECAUSE the disk is not ready. It even tells you what you need to do. (Start windows and run chkdsk /f).

    Make sure the system is not in “hibernate”.

    Make sure the disk is actually okay.

    Maybe try resizable? (How many disks are on this system anyway?)



  • When i change image setting to operation syatem other and Image type raw Image it’s starting to imaging to hdd but it’s imaging whole hdd (500gb) and taking over 2h . And i dont need whole hdd image

    When using image settings as operation system other and Image type multipe partion Image - all disks (not resiszable ) it gived thoose errors



  • Just before error comes there this kinda picture
    http://m.imgur.com/29AEa9e

    Were do i check thoose setting, in terminal or on the server?


  • Moderator

    @killerm Looks like there’s plenty of space.

    So, for some reason FOG is unable to find the image store, I recommend you check your Storage Node settings



  • @Quazz
    http://m.imgur.com/LLK6miK this is what it is looking like after that command


  • Moderator

    @killerm Size of HDD isn’t the only factor. The default install might have only given the root partition 10GB for example, and given the rest to /home

    Try this command in terminal:

    df -h
    

    And paste output here.



  • Okey i try thoose image settings tomorrow probably. I think it’s not about disk space, i have 500gb hdd in use and there is nothing than Ubuntu and fog server. After that i tried capure a Windows 7 image and it went to server without problems. I had just an problem also with deploy image: http://imgur.com/a/tnfrE

    Could there problems be linked to each others…?


  • Moderator

    @Quazz said in Multiboot image question:

    Might be worthwhile to check the diskspace for /images though, as it suggests.

    Oops sorry I though you guys were doing that (multi boot).

    Thanks for reminding me about the disk space message. If the fog server isn’t out of space in the /images directory then the error message is a bit misleading (I know this). It actually means (if there is sufficient disk space) that Partclone aborted the image copy function unexpectedly. I have personally seen this. If you watch the Partclone function it will quickly display the error (< 2 seconds) just before exiting back to FOS. We saw this with a target computer with a bad sector on the hard drive. I’m not saying that is the case here but if you watch the partclone copy and are a quick read you can see the error. The other way to trap the error is to capture the image in debug mode. Then you can abort the upload and review the log file.


  • Moderator

    @george1421 I don’t use multiboot images, unfortunately. This seems to be a capturing issue, however.

    Might be worthwhile to check the diskspace for /images though, as it suggests.

    Other things to watch out for are the image settings, when set incorrectly it won’t work afaik.

    I think, but could be wrong, you should use OS type : Other and image type: Multiple Partition (non resizable)


  • Moderator

    I believe you will need to pick raw image format with an image type of other and finally pick single disk nonresizable. I’m not sure if the resizable code supports mixed OS deployments. @Senior-Developers (??)

    I think @Quazz does deploy a multiboot image (??). He may be able to provide exact guidance.


Log in to reply
 

375
Online

38981
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.