Share /images on NAS Synology



  • Server
    • FOG Version: 1.3.5
    • OS: Ubuntu
    Client
    • Service Version:
    • OS: MAC
    Description

    Hello

    I would like to paratage the folder /images on an external server so that it is stored on our Synology NAS. I have done sharing in NFS, it is well taken into account on the home page of the Storage Node. Unable to capture an image and have access to the active share.

    Below is the error message that I get :

    0_1493020542756_FullSizeRender.jpg

    0_1493020581162_Capture d’écran 2017-04-21 à 17.10.38.png

    0_1493020592797_Capture d’écran 2017-04-21 à 17.10.50.png

    0_1493020559532_Capture d’écran 2017-04-21 à 17.10.24.png

    Thank you for your help
    @+


    Bonjour

    J’aimerai paratager le dossier /images sur un serveur externe afin qu’il sois stocké sur notre NAS Synology. J’arrive a effectué le partage en NFS cela est bien pris en compte sur la page d’accueil du Storage Node. Mais impossible d’effectuer une capture d’image et ayant ce partage actif.

    Vous trouverez ci-dessous le message d’erreur que j’obtiens

    0_1493020542756_FullSizeRender.jpg

    0_1493020581162_Capture d’écran 2017-04-21 à 17.10.38.png

    0_1493020592797_Capture d’écran 2017-04-21 à 17.10.50.png

    0_1493020559532_Capture d’écran 2017-04-21 à 17.10.24.png

    Merci pour votre aide
    @+



  • Hey

    I found out where my error came from, here are the settings:

    Follow the tutorial of @george1421
    https://forums.fogproject.org/topic/9430/synology-nas-as-fog-storage-node/16

    On the Fog Web server

    0_1493113426231_Capture d’écran 2017-04-25 à 11.37.44.png

    On Nas Synology, here is the NFS configuration on all the files /volume1/images /volume1/tftpboot /volume1/snapins so that all posts find sharing Thanks @hfredh

    0_1493113614033_Capture d’écran 2017-04-25 à 10.39.05.png

    Thanks to all
    One can pass the subject in solved

    I keep you informed if I can deploy with this method normally there should be no problem

    @+


  • Moderator

    @melvinpaz Much better content this time. It provides a clearer picture of the rejection.

    I want you to remove the IP connection restriction on the nfs share for the synology nas. We need to remove all blocks to see if that is the cause of the connection rejection.



  • Hey @george1421

    I did exactly what you asked me and I manage to mount the share on the machine without any problem.

    Fog

    ubuntu@ubuntu-P5QL-PRO:/$ sudo umount /mnt 
    ubuntu@ubuntu-P5QL-PRO:/$ sudo mount -t nfs 10.9.153.249:/volume1/images /mnt
    ubuntu@ubuntu-P5QL-PRO:/$ ls -al /mnt/
    total 4
    drwxrwxrwx  1 root root    36 avril 24 14:23 .
    drwxr-xr-x 26 root root  4096 avril 25 10:00 ..
    drwxrwxrwx  1 1054 users   18 avril 24 14:24 dev
    ----------  1 root root     0 avril 24 14:23 .mntcheck
    

    0_1493109159132_Capture d’écran 2017-04-25 à 10.32.23.png

    By Contre by launching debug mode this is what I get on the station in debug mode

    0_1493109340869_IMG_4099.JPG

    I followed your advice @hfredh and I fall on the same error message. I tried with the 2 configurations in ip direct and with ips under networks

    1_1493109561261_Capture d’écran 2017-04-25 à 10.39.05.png

    0_1493109561260_Capture d’écran 2017-04-25 à 10.38.15.png

    Thank you for your help and suggestions

    @+



  • Bonjour,

    Nous utilisons aussi un serveur fog et des NAS Synology.
    Par l’interface web du NAS synology dans les règles NFS du partage. vous avez mis l’adresse IP du serveur fog. Mais chez nous nous indiquons le segment réseau des postes clients qui seront cloner qui accéderons au partage NFS mais pas le serveur fog

    Dans la copie écran ci-dessous nous avons mis l’ensemble des ip du sous réseau 10.56.2.XX des postes windows de notre réseau étudiant

    0_1493105449948_upload-ff612e13-78f4-4524-bf86-d00d61a35843

    si vous avez plusieurs sous-réseau il faudra ajouter une règle pour chaque, en espérant que cela règle votre problème.


  • Moderator

    @melvinpaz Please only post in english if you are posting images. It makes it easier on use dumb guys trying the find the important information. English/french is no issue is the mix in of the same pictures where I loose my spot.

    It looks like you have the settings right for the synology nas. The issue I see is that you can’t still connect from FOS to the nas /volume1/images/dev

    Can you from the fog linux console run the following command successfully?
    sudo mount -t nfs 10.9.153.249:/volume1/images/dev /mnt

    If you can do this, you have the nas configured correctly to share. The only exception is that root user may not be allowed to connect to this share (as the FOS engine will do).
    Issue the following command to unconnect the FOG server from the nas
    sudo umount /mnt

    The next part will be harder for you to do, but I’m sure you can do.

    On a target computer schedule a capture or deployment (either one it doesn’t matter), but before you select the schedule task button, make sure you enabled the debug checkbox. Then schedule the task.

    On the target computer pxe boot it, FOG will tell the target computer to do the task you defined above, BUT after a few enter key presses on the target computer FOS will give you a linux command prompt (on the target computer). From here we need to test if we can connect to your synology NAS via the command we used above. WARNING: The /mnt directory may not be on the FOS target computer so you may have to create the directory to be able to mount to it.



  • Hey @george1421

    10.9.153.249=NasSynology
    10.9.153.248=Fog

    When I followed your tutorial I had a problem with this line

    mount -t nfs <syno_nas_ip>:/volume1/snapins /mnt
    mkdir /mnt/ssl
    cp -R /opt/fog/ssl/* /mnt/ssl
    umount /mnt
    

    I did not find the /opt/fog/ssl directory in the computer with the Fog server so I copied the /opt/fog/snapins/ssl/

    Here is the error message I get

    0_1493043760821_IMG_4096.JPG

    More information.

    Fog

    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/exports
    /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
    
    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/fstab 
    10.9.153.249:volume1/images /images nfs default 0 0
    10.9.153.249:volume1/images/dev /images nfs default 0 0
    
    ubuntu@ubuntu-P5QL-PRO:/$ ls -al
    drwxrwxrwx   4 fog  root  4096 avril 20 16:17 images
    

    0_1493043703462_Capture d’écran 2017-04-24 à 16.21.18.png

    NasSynology

    0_1493044137031_Capture d’écran 2017-04-24 à 16.28.25.png

    0_1493044149940_Capture d’écran 2017-04-24 à 16.28.36.png

    ubuntu@UFRIngemedia:/volume1$ ls -al
    drwxrwxrwx+  1 root  root    36 Apr 24 14:23 images
    drwxrwxrwx+  1 root  root    18 Apr 24 14:24 snapins
    drwxrwxrwx+  1 root  root   808 Apr 24 14:26 tftpboot
    

    The configuration is the same for tftpboot and snapins files


    I then tried the following tutorial with @chris-dees et @george1421 https://forums.fogproject.org/topic/9422/setup-synology-diskstation-as-main-storage-for-fog-sever/12 and I come across the same type of error message

    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/exports
    /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
    
    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/exports
    /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
    

    0_1493044638460_IMG_4097.JPG

    Thank you for your help
    @+


    Hey @george1421

    10.9.153.249=NasSynology
    10.9.153.248=Fog

    Quand j’ai suivie votre tutoriel j’ai eu un soucis à cette ligne

    mount -t nfs <syno_nas_ip>:/volume1/snapins /mnt
    mkdir /mnt/ssl
    cp -R /opt/fog/ssl/* /mnt/ssl
    umount /mnt
    

    Je ne trouvé pas le répertoire /opt/fog/ssl dans l’ordinateur avec le serveur Fog j’ai donc copié le repertoire /opt/fog/snapins/ssl/

    Voici maintenant le message d’erreur que j’obtiens

    0_1493043760821_IMG_4096.JPG

    En complément d’information.

    Fog

    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/exports
    /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
    
    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/fstab 
    10.9.153.249:volume1/images /images nfs default 0 0
    10.9.153.249:volume1/images/dev /images nfs default 0 0
    
    ubuntu@ubuntu-P5QL-PRO:/$ ls -al
    drwxrwxrwx   4 fog  root  4096 avril 20 16:17 images
    

    0_1493043703462_Capture d’écran 2017-04-24 à 16.21.18.png

    NasSynology

    0_1493044137031_Capture d’écran 2017-04-24 à 16.28.25.png

    0_1493044149940_Capture d’écran 2017-04-24 à 16.28.36.png

    ubuntu@UFRIngemedia:/volume1$ ls -al
    drwxrwxrwx+  1 root  root    36 Apr 24 14:23 images
    drwxrwxrwx+  1 root  root    18 Apr 24 14:24 snapins
    drwxrwxrwx+  1 root  root   808 Apr 24 14:26 tftpboot
    

    La configuration est la même pour les fichier tftpboot et snapins


    J’ai ensuite essayé le tutoriel suivant avec @chris-dees et @george1421 https://forums.fogproject.org/topic/9422/setup-synology-diskstation-as-main-storage-for-fog-sever/12 et je tombe sur le même type de message d’erreur

    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/exports
    /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
    
    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/exports
    /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
    

    0_1493044638460_IMG_4097.JPG

    Merci pour votre aide
    @+


  • Moderator

    You might want to read over this: https://forums.fogproject.org/topic/9430/synology-nas-as-fog-storage-node

    You can not reshare a mounted external file system, i.e. share a mounted share. Your only option is to turn synology nas into a fog storage node.



  • Hey

    In addition information here are the access to the folder on our server with Fog installed

    ubuntu@ubuntu-P5QL-PRO:/$ ls -al
    drwxrwxrwx   1 fog  root   102 avril 21 17:23 images
    
    ubuntu@ubuntu-P5QL-PRO:/$ ls -al /images/
    drwxrwxrwx  1 fog  root  102 avril 21 17:23 .
    drwxr-xr-x 26 root root 4096 avril 21 17:08 ..
    drwxrwxrwx  1 fog  root    0 avril 21 17:23 dev
    drwxrwxrwx  1 fog  root   48 avril 21 15:41 dev.old
    drwxrwxrwx  1 fog  root   18 avril 21 09:32 install
    -rwxrwxrwx  1 fog  root    0 avril 21 17:23 .mntcheck
    drwxrwxrwx  1 fog  root   32 avril 21 10:29 postdownloadscripts
    
    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/fstab 
    10.9.153.249:volume1/fog /images nfs rw,auto 0 0
    
    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/exports
    /images *(rw,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /images/dev *(rw,sync,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    
    #/images 10.152.0/24(rw,all_squash,anonuid=1000,anongid=1000,sync,no_subtree_check)
    #/image/dev 10.153.249
    #/image 10.153.249
    

    In addition, here are the accesses to the shared folder on our Synology NAS server

    root@UFRIngemedia:/volume1/fog# ls -al
    drwxrwxrwx+ 1 1001 root 102 Apr 21 17:23 .
    drwxr-xr-x  1 root root 272 Apr 20 17:20 ..
    drwxrwxrwx+ 1 1001 root   0 Apr 21 17:23 dev
    drwxrwxrwx+ 1 1001 root  48 Apr 21 15:41 dev.old
    drwxrwxrwx+ 1 root root  50 Apr 20 17:17 @eaDir
    drwxrwxrwx+ 1 1001 root  18 Apr 21 09:32 install
    -rwxrwxrwx+ 1 1001 root   0 Apr 21 17:23 .mntcheck
    drwxrwxrwx+ 1 1001 root  32 Apr 21 10:29 postdownloadscripts
    
    root@UFRIngemedia:/volume1/fog# cat /etc/exports
    /volume1/fog	10.9.153.248(rw,async,no_wdelay,crossmnt,no_root_squash,insecure_locks,sec=sys,anonuid=1025,anongid=100)
    

    Thank you for your help
    @+


    Hey

    En complément d’information voici les accès au dossier sur notre serveur avec Fog d’installé

    ubuntu@ubuntu-P5QL-PRO:/$ ls -al
    drwxrwxrwx   1 fog  root   102 avril 21 17:23 images
    
    ubuntu@ubuntu-P5QL-PRO:/$ ls -al /images/
    drwxrwxrwx  1 fog  root  102 avril 21 17:23 .
    drwxr-xr-x 26 root root 4096 avril 21 17:08 ..
    drwxrwxrwx  1 fog  root    0 avril 21 17:23 dev
    drwxrwxrwx  1 fog  root   48 avril 21 15:41 dev.old
    drwxrwxrwx  1 fog  root   18 avril 21 09:32 install
    -rwxrwxrwx  1 fog  root    0 avril 21 17:23 .mntcheck
    drwxrwxrwx  1 fog  root   32 avril 21 10:29 postdownloadscripts
    
    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/fstab 
    10.9.153.249:volume1/fog /images nfs rw,auto 0 0
    
    ubuntu@ubuntu-P5QL-PRO:/$ cat /etc/exports
    /images *(rw,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /images/dev *(rw,sync,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    
    #/images 10.152.0/24(rw,all_squash,anonuid=1000,anongid=1000,sync,no_subtree_check)
    #/image/dev 10.153.249
    #/image 10.153.249
    

    En complément d’information voici les accès au dossier partagé sur notre serveur NAS Synology

    root@UFRIngemedia:/volume1/fog# ls -al
    drwxrwxrwx+ 1 1001 root 102 Apr 21 17:23 .
    drwxr-xr-x  1 root root 272 Apr 20 17:20 ..
    drwxrwxrwx+ 1 1001 root   0 Apr 21 17:23 dev
    drwxrwxrwx+ 1 1001 root  48 Apr 21 15:41 dev.old
    drwxrwxrwx+ 1 root root  50 Apr 20 17:17 @eaDir
    drwxrwxrwx+ 1 1001 root  18 Apr 21 09:32 install
    -rwxrwxrwx+ 1 1001 root   0 Apr 21 17:23 .mntcheck
    drwxrwxrwx+ 1 1001 root  32 Apr 21 10:29 postdownloadscripts
    
    root@UFRIngemedia:/volume1/fog# cat /etc/exports
    /volume1/fog	10.9.153.248(rw,async,no_wdelay,crossmnt,no_root_squash,insecure_locks,sec=sys,anonuid=1025,anongid=100)
    

    Merci pour votre aide
    @+


Log in to reply
 

328
Online

38724
Users

10553
Topics

99906
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.