Synology NAS as FOG Storage node


  • Moderator

    NOTE: Changes in FOG's code since this article was written have made it harder to use NAS' as storage node with FOG. If you use a NAS with FOG 1.5.x and beyond the FOG replicator will continue to cycle and recopy files over and over again.

    Part 1 NAS Setup

    So far I’ve setup what should work from the synology NAS side of the fog storage node. This has NOT been proven to work just yet. So far the synology nas has been configured to what “should work”. On my test NAS I’m using DSM 6.0.

    The following is just my short hand notes that will be used to create the actual tutorial. I’m out of time tonight to complete the docs for this.

    The first thing we need to do is setup our NAS with the required network shares. To do this you need access to the Synology NAS’s web console. Log into the web console as admin and do the following.

    1. Control Panel->Shared Folder
      Create new share
      Name: images
      Location: volume 1
      Checked Hide this shared folder in My Network Places
      Checked Hide sub-folders and files from users without permissions
      Press OK
      NFS Permission (tab)
      Create new Permission
      Hostname or IP: *
      Privilege: Read/Write
      Squash: No mapping
      Security: sys
      Checked Enable asynchronous
      Checked Allow users to access mounted subfolders

    2. Control Panel->Shared Folder
      Create new share
      Name: snapins
      Location: volume 1
      Checked Hide this shared folder in My Network Places
      Checked Hide sub-folders and files from users without permissions
      Press OK
      NFS Permision (tab)
      Create new Permission
      Hostname or IP: *
      Privilege: Read/Write
      Squash: No mapping
      Security: sys
      Checked Enable asynchronous

    3. Control Panel->Shared Folder
      Create new Share
      Name: tftpboot
      Location: volume 1
      Checked Hide this shared folder in My Network Places
      Checked Hide sub-folders and files from users without permissions
      Press OK
      NFS Permission (tab)
      Create new Permission (we only need this nfs shared for setting up the storage node)
      Hostname or IP: *
      Privilege: Read/Write
      Squash: No mapping
      Security: sys
      Checked Enable asynchronous

    4. Control Panel->File Services
      Select Win/Mac/NFS (tab)
      Checked Enable NFS

    5. Control Panel->File Services
      Select FTP (tab)
      Checked Enable FTP service (no encryption)
      Checked Use the default port range

    6. Control Panel->File Services
      Select TFTP (tab)
      Checked Enable TFTP service
      TFTP root folder: tftpboot (this is the share name we created above)

    7. Control Panel->User
      Select User (tab)
      Create user foguser
      Name: foguser
      Description: FOG User
      Password: fogremote1 (pick your own secure password)
      Conform Password: fogremote1
      Checked Disallow the user to change account password
      Press Next
      Join to group: users
      Press Next
      images: RW
      snapins: RW
      tftpboot: RO
      Press Next
      (Assign quota as needed)
      Press Next
      Assign application permissions: None
      Press Next
      Speed limiting: None
      Press Next
      Press Apply

    8. Control Panel->User
      Select the Advanced (tab)
      (scroll way at bottom)
      Under User Home
      Checked Enable user home service
      Press Apply

    That completes the setup of the Synology NAS.

    In the next part we’ll test the network shares we setup above and create the remaining flag files and directory structure needed to transform the Synology NAS into a FOG storage node.


  • Moderator

    @Vincent-Caraby Well lets see if I can explain this, but the answer is simple and complicated at the same time.

    The FOS engine connects to the master node as root so the synology nas needs to allow root to connect to the /volume1/images and /volume1/images/dev as root.

    Also the FOS engine will use ftp to connect to the NAS using the adminfog user and password you defined in the Storage Node configuration to move the files from /images/dev to /images directory.



  • @george1421

    Thanks, i see the red message at top of topic to late.
    I test this solution, it seem to be wright but i’m stuck on a permission problem.

    Setup my NAS storage node to master node. But when i would capture there a message “permission denied” when mounting file system.

    I don’t understand who on what give permission ? I suppose it’s my “adminfog” (fog server) to my NAS folders (images, snapins, tftpboot).

    Is there a file where i can configure this rigtly ? A bit lost and not linux expert, but i prefer use config files if possible.

    Some capture of my configuration :

    2_1534946534225_fog_capture_error_wo_ip.png

    1_1534946534225_config_storage_node.png

    0_1534946534223_config_node_list.png


  • Moderator

    @Vincent-Caraby First let me say that changes in the fog server makes using a non-fog NAS a problem if you have it configured as you have it now. The FOG replicator will continue to copy the image over and over again to your NAS.

    But let me tell you that you can do what I think you want. You must know that you can only capture images to a Master Node in a storage group. So in your settings change it so the NAS is the master node in your storage group, instead of the FOG server. This should make the images to go directly to the NAS and not FOG server.



  • Hi,

    First of all, thanks to george1421 and other users who deliver this solution.

    Before i say what is my problem, the existant :

    FOG serveur 1.5.4 on a Debian 9.4 with no graphical environment (terminal only) with 100Go disk. This debian is virtual on ESX6.5.0
    NAS : Synologie DS116 with plenty of space

    I’m a bit confuse.

    All opération discribe here works whell, but when i capture, the image is copied on FOG server. Then, after capture, image is automaticaly copied on NAS. But after copy on NAS was finish, she stay on my FOG server, so after two Win10 capture the server is full.

    What i miss out on ?
    Is the capture normally do directly on NAS without any write on Server ?

    Thanks in advance.



  • I would like to appreciate this nice little post, I wish I had stumbled upon this earlier. Last week I tried creating my Synology NAS as a storage node and it worked. Little did I know that was the beginning of my misery. Whole week I struggled in fixing the replication issues.
    Had I found this Thread earlier, I wouldn’t have attempted it.



  • @tom-elliott I just unchecked “Enable advanced sharing permissions in affected folders”:
    0_1530513445336_Capture111.PNG


  • Senior Developer

    @alex78 Can you tell us what you had missed originally and what you did to fix it? This could help another user down the road, so always good to share if you can.



  • I think it’s working thanks you :)



  • @george1421
    Ok, I am still checking all the steps of your tutorial and I will come back to you, if it not solved the problem or on the contrary if it solved it, thank you for your answer.


  • Moderator

    @alex78 Just be aware that changes in the FOG program make using a NAS as a storage node a bit more difficult.

    Did you complete all parts of the tutorial? With synology nas, typically the path would be /volume1/images/igmWindows it appears you have missed a setting someplace.



  • @george1421 Hello, i did all the things you say, but i stay with this error, and i don’t know what this means:
    0_1530264310568_ok.PNG

    Did someone known this problem ?



  • @george1421 yes. That way the fog server considers /images local so the “defaultmember” pie chart works just fine.


  • Moderator

    @KKTwenty101 said in Synology NAS as FOG Storage node:

    @george1421 I “cheesed” the dashboard in our FOG by mounting the image folder on the FOG server as NFS from my synology NAS (rather than add another storage node). Using an 815+ here and have been for a while.

    ^^Please explain this^^

    If I understand correctly you have an nfs share on your nas, and you mounted that nfs share over the /images directory on your fog server. And the fog server is sharing out the /images directory on your fog server??



  • @george1421 I “cheesed” the dashboard in our FOG by mounting the image folder on the FOG server as NFS from my synology NAS (rather than add another storage node). Using an 815+ here and have been for a while.



  • @george1421 thanks for your reply…
    it was my fault: I had entered the wrong path in the configuration…
    working late at night is not a good idea!!
    thaks a lot!


  • Moderator

    @brusa.matteo Hmm I didn’t see your post from a few days ago, sorry.

    You are getting a permission denied message. This sounds like you don’t have the nfs permissions setup correctly on your NAS.

    Specifically in this section

    NFS Permission (tab)
    Create new Permission
    Hostname or IP: *
    Privilege: Read/Write
    Squash: No mapping
    Security: sys
    Checked Enable asynchronous
    Checked Allow users to access mounted subfolders



  • Hello, so…
    the sync between the default repository and the synology works.
    Now I’ve moved the synology storage on another storage group, because I want to use only it since the default (fog server) has not enough space for my pourpose…
    The snapins creation and distribution works fine (i can create snapins only on the synology and deploy them from the synology)
    But…trying to capture an image (setted to stay on the synology storage) I receive an error:

    mounting x.x.x.x:/fog_images/dev on /images failed: Permission denied

    have you any suggestions?



  • hello, I’m trying to use this…and when the sync starts the error I receive is: mirror: Access failed: 550 No such file or directory. (/volume9/fog_images/test01) test01 is the test images I’ve created…
    all the other point ar ok as the guide…


  • Moderator

    @VincentJ Just for clarity the issue I’m working on is the dashboard reporting only works correctly if the storage node is a “real” fog server. If that isn’t a problem then a NAS will work perfectly.

    The only caveat to using a NAS as your primary storage is that multicast deployments will not work at all. If you only do unicast imaging then again, there is no problem using a NAS in this manner.


 

405
Online

8.4k
Users

12.5k
Topics

117.7k
Posts