Uefi pxe will not connect...Nevermind User Error...

  • Server
    • FOG Version: 1.4 RC-6
    • OS: Ubuntu 16.04 LTS

    I upgraded FOG, I had Version 1.3 RC-16 and I was able to boot to uefi for my Inspiron 7000 series using ipxe.efi as the boot file and the ethernet adapter as the dell ethernet adapter. I can boot fine using undionly.kpxe for my E5420/E5430 series computers. I am at a loss for what to try next I checked the .fogsettings file, default.ipxe, and the storage node and the server ip is correct in all the locations. I have tried intel.efi and ipxe7156.efi to no avail. nothing else has been changed that I know of. Any help would be appreciated.

  • Nevermind disregard this post I switched out the adapter and now it is booting. thanks for your time.

  • Sorry for the confusion yeah the Inspirons are using a usb ethernet adapter, realtek that is dell branded to be specific. I just mentioned the XX20/30 series to show that using undionly.pxe works on some machines to help narrow the possibilities of what is wrong.

    the 7000 series no longer boots to the pxe menu it stops at “Start PXE over IPV4” unfortunately there is no error message.

    I have also tried the realtek.efi file since the initial post and that still did not boot.

  • Moderator

    Does this Inspiron have a usb ethernet adapter (that part is not clear).

    Yes you will need undionly.kpxe for the XX20 and XX30 if you are in bios mode. The XX20s don’t support uefi pxe booting, but the XX30s should.

    What doesn’t work with ipxe.efi? Where is the error?

    Can you post a clear screen shot of the error (sometimes the context of the error holds more value than the error message) taken with a mobile phone?

Log in to reply