Replicating to lower-size hard drive



  • Server
    • FOG Version: 1.3.4
    • OS: Debian 8
    Client
    • Service Version: N/A
    • OS: Windows 7 POSReady
    Description

    Hi,

    I am currently deploying 17 new computers. I created the image from one of the computers, and deployed it successfully to 15 of the 16 computers.
    On that computer, the SSD drive is sightly different, and seems to be of a lower size.
    When I try to restore, I get the following error:

    No image file(s) found that would match the partition(s) to be restored
    

    I started a debug restore session and was able to debug the problem a little bit further.
    From what I was able to diagnose, Fog restores the GPT partition table from the master image. However, as the drives have a slightly different size, an invalid partition table is applied.
    fdisk -l says

    GPT PMBR size mismatch (125045423 != 123091919) will be corrected by w(rite).
    Disk /dev/sda: 58.7 GiB, 63023063040 bytes, 123091920 sectors
    

    I tried manually recreating a valid partition table, but it seems that Fog restores the partition table from the image, even though it is invalid for that SSD drive.

    Do you have any idea of something that I could do to restore the image?



  • Hello,

    I updated our Fog server to 1.3.5 and am happy to report success!
    The image was deployed to the computer that was having the problem without any action.

    How can I flag this post as solved?


  • Moderator

    I agree with @george1421 FOG 1.3.5 specifically has tons of fixes for GPT resizing. It is probably safe to say that GPT resizing never even worked until FOG 1.3.5


  • Moderator

    Can we get you to update to 1.3.5? There were several fixes addressed between 1.3.4 and 1.3.5. If you can tolerate being on a RC (dev) release 1.4.0RC4 fixes a few more issues with differing disk sizes.


Log in to reply
 

457
Online

38998
Users

10717
Topics

101747
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.