SOLVED No partition number passed (EBRFileName)

  • Server
    • FOG Version: 1.3.4
    • OS: Centos 7.3.1611
    • Service Version:
    • OS: Windows 7

    Unable to deploy an image. Display is:
    An error has been detected!
    No partition number passed (EBRFileName)
    Args passed: /images/LenovoE440V4/LenovoE440V4.* 1

    History: This image was created under a previous version of Fog. This is a Raw Image type image. I tried another version of this image for this laptop model with the same error resulting. I have not been able to find this exact error in the forums. Any ideas on what may be wrong?

  • @Tom-Elliott
    That did it. After that last update, I was able to deploy the raw image successfully! Thanks for working with me on this.

  • @Alan-Anderson I’ve rebuilt the init’s to try to do the download.

    Please run:

    wget -O /var/www/fog/service/ipxe/init.xz
    wget -O /var/www/fog/service/ipxe/init_32.xz

    Then try deploying your raw image again? I sure hope for success. Glad you got further along for sure.

  • @george1421
    FOG now shows:
    Running Version 1.4.0-RC-8
    SVN Revision: 6069
    I tested a new image using Multiple Partition Image - Single Disk (Not Resizable) and it worked great. So nothing broke during the update. Then I tried to deploy the older raw image and got further than before in that no error was displayed. However it reported that the partition file was missing (See image). I listed the directory just to be sure and here is the result:

    [root@fog2 LenovoT450V3]# pwd
    [root@fog2 LenovoT450V3]# ls -l
    total 53134492
    -rwxrwxrwx. 1 fog root 54409716700 Feb 10 00:49 LenovoT450V3

    So the image files exists.
    One final note in case it’s relevant: I did receive these two errors doing boot:
    Error parsing PCC subspaces from PCCT
    Populating /dev using udev: udevd[2524]: error creating epoll fd: Function not implememted

  • @Alan-Anderson @Wayne-Workman @george1421 Also I added a change within RC-8 so the function call specifically for EBRFileName will no longer halt forward progress. So PLEASE update to RC-8 and give it a test. Of course it would be great to re-capture in resizable just to see if things work. Essentially this should enable your server to image or at least give us more information that we could use to get this working for you.

  • Moderator

    @Alan-Anderson We’d like to have you update to the latest RC release of fog 1.4.0RC8. There was a bunch of effort put into disk resizing and imaging between FOG 1.3.4 and 1.3.5, with a critical fix added to 1.4.0RC1.

    Once you update, please try your imaging again.

  • @Wayne-Workman
    Sorry for the long delay in replying. I see the image type as you described. The original image was captured as Raw. And I am deploying it as Raw as well. So have hit a dead end on this.

  • @Alan-Anderson Any status update?

  • Deploying in raw format: I don’t see an option to control deployment type of an image. I thought that Fog looked at the type of image and deployed based on the image type.

    It’s pictured below. If you change the type, you have to re-capture. FOG does not do any such automatic selection of image type - all settings are left up to the fog administrator / imaging technician to configure properly.

    0_1491603628160_Image Type.png

    1. Deploying in raw format: I don’t see an option to control deployment type of an image. I thought that Fog looked at the type of image and deployed based on the image type.
    2. I agree that it looks like there is no partition on the hard disk. But there is. The hard disk I want to image currently has a Windows partition and happily boots to Windows 7. So not sure what the issue is. I have tried two different versions of this laptop image and they both fail with the above error.

    Just to troubleshoot I created an image of this laptop series using Multiple Partition Image - Single Disk (Not Resizable) and then deployed it back and it works fine. So it may just be something wrong with this group of raw images brought over from the old Fog server. Not my first choice but I’m willing to create a new image and move on if no one has any other ideas.

  • @Alan-Anderson The image you’ve provided appears to show your disk has no partition layout on it.


     * Processing Partition: /dev/sda ()

    That should display as:

     * Processing Partition: /dev/sda1 (1)

  • @george1421 said in No partition number passed (EBRFileName):

    ls -la /images/LenovoE440V4

    Here’s the output:
    ls -la /images/LenovoE440V4
    total 67078552
    drwxr-xr-x. 2 root root 34 Feb 9 19:42 .
    drwxrwxrwx. 46 root root 4096 Mar 31 13:03 …
    -rwxr-xr-x. 1 root root 68688429631 Feb 9 21:29 LenovoE440V4

    I believe the original image was captured using Fog 1.2.0. This is what is currently running on my old Fog server. It’s possible that it was an earlier version.

    Here’s a screen shot:

  • Moderator

    Can you provide a clear screen shot of the error message taken with a mobile? The context of the error is just as important as the error itself.

    When you captured this image what version of FOG was used?

    If the image was taken using raw format, then you must deploy in raw format too.

    Will you also post the output of this command ls -la /images/LenovoE440V4 This will tell us the structure of the files for this image.