PXE Boot - Connection timeout error



  • Hello,

    I’m getting an error on my machines when I try to boot to FOG, it says

    'Received DHCP answer on interface net0
    tftp://(IP ADDRESS)/default.ipxe…0%

    It then says connection timeout after a few minutes, I swapped the HDD into another machine as i think there’s an issue with the NIC in the other machine, It boots FOG up fine etc. At first, the IP Address was set back to DHCP instead of Static (manual). I’ve set it back to what it was set as on the old machine, and FOG allows me to connect to the server etc, it is working fine, however, it just won’t boot up.

    Any one have any ideas what to do?

    Thanks,

    Dan


  • Moderator

    @dloudon96 In fog images have 2 components.

    1. Raw data files
    2. Database definitions (descriptors) of the image

    You can copy (move) files between your old fog server and your new fog server no problem. You must recreate the image definitions in the database by hand on the new fog server. If you have the old fog server still running you can just copy and paste between the web GUIs.

    FYI: If your old fog server is a 1.3.x you can export the database definitions from the web gui of the old fog server and import them into the new fog server.



  • @george1421

    Hello,

    That’s worked great.

    Just another question, is it possible to transfer the images from the ‘OLD’ FOG server, to the new one, is it just a case of copying the images inside the folder that contains the images, and then paste them back to the new FOG server, and then changing the names to match the new image names etc?

    Thanks,

    Dan


  • Moderator

    @dloudon96 no image loss, this is on the communication side only. More specifically on the pxe boot side.

    <edit>OK let me put a caveat in there don't delete anything in the /images directory or you will loose your images.



  • @george1421
    Am I going to lose everything, Image/Host wise? I’ve got machines that have been images from FOG.

    Thanks,

    Dan


  • Moderator

    @dloudon96 now that the IP address is at the old server’s IP address.

    1. Please check the following file on the FOG server /opt/fog/.fogsettings We need to ensure the fog server IP address listed there is accurate.

    2. Rerun the installer in .../bin/installfog.sh that file will be in the git repository you downloaded.

    3. Then confirm in /tftpboot/default.ipxe that the IP address listed there is consistent with the IP address of the fog server.

    4. Finally check on the fog management gui, the storage node definition for this FOG server, make sure the IP addresses there are accurate.

    5. OK, one last check, your dhcp option 66 is set to the IP address of your fog server.



  • @george1421
    Hello,

    OLD IP: 10.31.97.124
    Current, same IP: which I’ve changed back is the same as the above: 10.31.97.124

    I know things will break if the IP is changed, that’s why I’ve changed it back from the IP that the machine was allocated dynamically, back to the static IP, as above.

    I can access the dashboard etc, and load the images up on the screen, just whenever I try to download, or capture an image, it isn’t picking up the server, even though it sort of is as it has the IP of the server on the PXE boot screen.

    Thanks,

    Dan


  • Moderator

    @dloudon96 Lets use some real numbers here.

    What is your new (current) IP address of your FOG server?

    If your fog server IP address changes from when FOG was originally installed things WILL break. Rerunning the installer script again should clean up all the places where the old IP address is hiding.

    Does the fog management interface work as it should under the new IP address?



  • FOG version: 1.3.4
    Server OS version: 14.04 LTS

    What’s the distribution of Linux?

    Same for the distribution server, what’s that?

    I’ve set the IP for the 066 - Boot Server Host Name: (IP of FOG Server)
    I’ve also set the IP for the 067 - Bootfile Name: undionly.kpxe

    Basically, the machine I was using was really slow at downloading images, and was taking around 1hr to download a small image, where on the old FOG server, it only took around 10 minutes per machine, it’s even slow when there’s only one machine downloading the image.

    I swapped the HDD over, it’s exactly the same machine, just with a new NIC, but I know that one works fine, as that was my ‘old’ fog server (I say old, as i was running out of space, so decided to upgrade the HDD, and set up FOG again).

    I got it all set back up again, it just takes ages to download the images etc, so swapped the machine (as I’ve said above), this is now where I face the issue of:

    The IP changed on the FOG Server, even though the HDD was just swapped, so I set it back to manual on the new machine, and then it loaded the dashboard up on my Windows Machine, and this is now where it won’t allow me to PXE boot to FOG.

    Thanks,

    Dan


  • Moderator

    We need to know 1. the version of FOG the server is running and 2. the distribution of Linux and 3. the version of the distribution the server is running on.

    Also, there are multiple problems here. What’s not booting? The fog server? The target host?

    Did you update your DHCP options to reflect the new FOG Server address when you tried changing the IP? Did you update the boot file setting in DHCP?

    Also, you are talking about an old fog server and a new one - what happened?


Log in to reply
 

461
Online

38959
Users

10706
Topics

101583
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.