Could not find any nodes containing this image



  • Server
    • FOG Version: 1.3.5
    • OS: Centos 6.8
    Client
    • Service Version: N/A
    • OS: N/A
    Description

    Whenever I attempt to create a capture task for a registered host this error appears. The host I’m trying does have an image associated with it. I’ve verified files do exist in /images and are chowned fog:root.

    I’m uncertain where I might begin looking for useful logs/debug data.


  • Senior Developer

    Found the issue.

    The maxClients field was being scanned for. This only allowed a “maxClients” of between 1 and 9999. The idea for this range was to get nodes that were not set to 0 max clients. I was trying to make the sql handle the return, but this would imply some form of array to search for. I just moved the check to look if it is less than 1.


  • Moderator

    @Carl

    In your storage node’s configuration, change:

    Max Clients 999999

    to

    Max Clients 10

    This fixes it for me, please confirm if it works for you.

    @Tom-Elliott I’m pinging you to just let you know.



  • Chat/PM sent…


  • Moderator

    @Carl I’d like to try to replicate your issue - I think it’s something to do with your database - or some setting somewhere that is stored in the database. If you would PM me via the forums chat, I can share my email and you can send me a copy of your database. With that, I can find exactly what is wrong with it.



  • Ah. Ok. Understood. I’ve actually done this before. Even now, doing it again effects no changes. I still get the same error.


  • Senior Developer

    @Carl go-to image management page
    Find your image definition
    Click storage group
    Ensure at least one storage group is present.

    If there is only one, check the Primary group check box. If more than one check the box for the group you want as primary. Press the button to make the update.



  • So i’m clear on exactly what you need… what exactly is the points/clicks that i should be making?


  • Senior Developer

    @Carl can you go to image management page and verify and ensure a storage group is defined for this image and try again? Yes it means actually updating the image.



  • @george1421 said in Could not find any nodes containing this image:

    ls -la /images

    Sorry for the confusion… “I’ve verified files do exist in images…” I meant that to imply that I’ve used this same setup to image many other machines before. Not images/files that pertain specifically to the host thatI’ve got issues with right now.

    [root@FOGstorage ~]# ls -la /images
    total 152
    drwxrwxrwx  77 fog root  4096 Mar 20 12:25 .
    drwxrwxrwx. 31 fog root  4096 Mar 20 11:55 ..
    drwxrwxrwx   2 fog root    64 Jan 22  2014 32BpreJDHV11
    drwxrwxrwx   2 fog root    64 Jan 22  2014 32BpreJDHV12
    drwxrwxrwx   2 fog root    49 Jan 15  2015 5FLVGW1
    drwxrwxrwx   2 fog root  4096 Feb 15  2016 AppVersion573034RDbVersion573034R
    -rwxrwxrwx   1 fog root    18 Feb  6  2015 .bash_logout
    -rwxrwxrwx   1 fog root   176 Feb  6  2015 .bash_profile
    -rwxrwxrwx   1 fog root   124 Feb  6  2015 .bashrc
    drwxrwxrwx   2 fog root    94 Feb 21  2013 CApassedLB
    drwxrwxrwx   2 fog root    64 Mar 21  2013 CApassedLBpre5PC
    drwxrwxrwx   2 fog root  4096 Feb  9  2015 testREDobjects
    drwxrwxrwx   2 fog root  4096 Feb 11  2015 testREDobjectWORKING
    drwxrwxrwx  37 fog root 12288 Mar  7 10:20 cd_images
    drwxrwxrwx   2 fog root   107 Feb 11  2015 CSonMINTwACQ
    drwxrwxrwx   2 fog root  4096 Feb 11  2015 cLABtoprer2
    drwxrwxrwx   2 fog root    49 Mar  1  2013 CSP1r
    drwxrwxrwx   2 fog root    49 Mar 12  2013 CSP1R9_new
    drwxrwxrwx   2 fog root    64 Feb 23  2013 ConferenceRoom
    drwxrwxrwx   7 fog root   120 Mar 20 11:36 dev
    drwxrwxrwx   2 fog root    64 May 27  2014 DB20140527
    drwxrwxrwx   2 fog root    64 Feb 23  2013 FrontDoor
    drwxrwxrwx   2 fog root    94 Apr  8  2016 GXv22prer54L72server
    drwxrwxrwx   2 fog root     6 Nov 11  2010 .gnome2
    drwxrwxrwx   2 fog root    94 Apr 29  2013 HERE
    drwxrwxrwx   2 fog root  4096 Jul 12  2016 J7q6r5WWPQ1_with_drivers
    drwxrwxrwx   2 fog root    23 Feb 17  2016 JLAPTOP
    drwxrwxrwx   2 fog root  4096 Mar 11  2016 JM57SP4WithWOL
    drwxrwxrwx   2 fog root    34 Jun 19  2014 JDLMint16
    drwxrwxrwx   2 fog root    34 Feb 20  2014 JDPC
    drwxrwxrwx   2 fog root    51 Apr 28  2014 JPlaybox
    drwxrwxrwx   2 fog root  4096 Aug 11  2015 JMLSamsungWindows81
    drwxrwxrwx   2 fog root    94 May 27  2014 JS20140527
    drwxrwxrwx   2 fog root    79 May 27  2014 KKLatitudeE6420
    drwxrwxrwx   2 fog root  4096 Feb 12  2015 LABpbx
    drwxrwxrwx   2 fog root    79 Mar  7  2014 MadLaptop
    drwxrwxrwx   2 fog root   142 Apr 22  2015 MadLaptop2
    drwxrwxrwx   2 fog root  4096 Mar 10  2015 mcSTREAMER
    drwxrwxrwx   2 fog root  4096 Mar  9  2015 Mc57Clean
    drwxrwxrwx   2 fog root  4096 Mar 10  2015 Mc57SP1HP1Clean
    drwxrwxrwx   2 fog root  4096 Mar 11  2015 Mc57SP2Clean
    drwxrwxrwx   2 fog root  4096 Mar  3  2015 Mc57SP2HP3Working
    drwxrwxrwx   2 fog root  4096 Mar 11  2015 Mc57SP3Clean
    drwxrwxrwx   2 fog root  4096 Mar 11  2016 Mc57SP4
    drwxrwxrwx   6 fog root    89 Feb  5  2015 McBackup
    -rwxrwxrwx   1 fog root     0 Feb 20  2013 .mntcheck
    drwxrwxrwx   4 fog root    37 Feb  9  2013 .mozilla
    drwxrwxrwx   2 fog root    64 May 21  2013 NewBlank1
    drwxrwxrwx   2 fog root    94 May 21  2013 NewBlank2
    drwxrwxrwx   2 fog root    94 Apr 15  2014 NewBlank3
    drwxrwxrwx   2 fog root  4096 Apr  4  2014 Phantom94R2b8
    drwxrwxrwx   2 fog root  4096 Oct  6  2014 BuckeyeCLIP93r2b5
    drwxrwxrwx   2 fog root  4096 Oct 14  2014 BuckeyeCLIPEdited
    drwxrwxrwx   2 fog root  4096 Oct 15  2014 BuckeyeCLIP
    drwxrwxrwx   2 fog root  4096 Aug 25  2014 Vista31117
    drwxrwxrwx   2 fog root  4096 Aug 29  2014 Vista31117SIGINITandDTRAM
    drwxrwxrwx   2 fog root  4096 Sep  8  2014 Vista31117WorkingKBX
    drwxrwxrwx   2 fog root  4096 Sep  5  2014 VistaFSB31117
    drwxrwxrwx   2 fog root  4096 Sep  5  2014 VistaFSBPostPOTS
    drwxrwxrwx   2 fog root    29 Feb  5  2015 postdownloadscripts
    drwxrwxrwx   2 fog root    64 Aug  9  2013 PreGITBootSvr
    drwxrwxrwx   2 fog root    78 Feb 22  2013 pxelinux.cfg
    drwxrwxrwx   2 fog root    34 May  6  2013 RW05062013
    drwxrwxrwx   2 fog root    92 Mar 26  2015 RWrightPC
    drwxrwxrwx   2 fog root    64 Mar 26  2013 ScTBLaptop
    drwxrwxrwx   2 fog root    47 Oct 28  2014 SDM550
    drwxrwxrwx   2 fog root    64 Apr 23  2013 SenoNPC
    drwxrwxrwx  25 fog root  4096 Oct 26 13:49 share
    drwxrwxrwx   2 fog root    64 Aug 20  2013 Spare2Image
    drwxrwxrwx   2 fog root  4096 Apr 25  2016 SparePCImage
    drwxrwxrwx   2 fog root  4096 Sep  9  2014 SpecterVista3117090914
    drwxrwxrwx   6 fog root  4096 Feb  5  2015 tftpboot
    drwxrwxrwx   2 fog root    94 Oct  2  2013 TimsPC
    drwxrwxrwx   4 fog root    29 Nov 15 12:42 .Trash-0
    drwxrwxrwx   2 fog root  4096 Aug 29  2014 Vista31117NoSitPatch
    drwxrwxrwx   2 fog root    35 Oct 10 10:12 TCNE6353MMZclean
    drwxrwxrwx   2 fog root    64 Mar 26  2014 TCOMLab
    drwxrwxrwx   2 fog root    49 Aug 23  2013 TCOTSbootSrvr
    drwxrwxrwx   2 fog root    49 Dec 16  2013 VPNLaptopFactoryImage
    drwxrwxrwx   2 fog root    29 Mar 24  2016 VPNlaptopWITHCCQ
    drwxrwxrwx   2 fog root    49 Jan 30  2014 VPNLinuxBaseline
    

    I’ve removed part of the name here since it contains a real S/N, but you can see that the associated image isn’t present in /images.
    0_1490190071075_Capture.PNG

    In addition, there’s other “HP-<S/N>” boxes that should be there too but aren’t.


  • Moderator

    I’m seeing a conflict (in my mind) between what you posted.

    #1

    The host I’m trying does have an image associated with it. I’ve verified files do exist in /images and are chowned fog:root.

    #2

    These three items have been done previously, however I cannot seem to locate the previously captured image/files on disk

    It may just be my head space that is causing the confusion here.

    Can you do 2 things for me.

    1. Post the output of this command ls -la /images
    2. You noted there was “this error appears”. Can you post a clear screen shot of this error.

    I’ve seen 2 threads with similar issues (I think) we are trying to compile these to see if there are similarities since FOG 1.3.5 was just released.



  • george1421:
    These three items have been done previously, however I cannot seem to locate the previously captured image/files on disk. Attempts to create new hosts/images also end in the same failure.

    Wayne:
    No. The only listed plugin I’ve showing in Plugins>Installed plugins is “fileintegrity”.


  • Moderator

    Just for clarity, before you capture an image, you MUST create an image definition.

    The typical workflow is this:

    1. Create the image definition
    2. Register the host and associate the image definition with the host
    3. Capture the image into the image definition.

  • Moderator

    Are you using the location plugin?


Log in to reply
 

463
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.