MacOS + BootCamp - Does it work?



  • Server
    • FOG Version: 1.3.5 SVN 6067
    • OS: CentOS 6.7
    Client
    • Service Version: N/A
    • OS: Macintosh
    Description

    This is a similar question to this older post: https://forums.fogproject.org/topic/7629/macos-with-bootcamp/16

    I have tried to perform a DD image, a single disk (non-resizable) partition, and am currently trying to perform a 4-part partition installation to see if it will take. (MBR, Part 1, Part 2, Part 3)

    Am I doing it wrong; is there a better way to approach it?

    I mean, the Macintosh partition takes perfectly fine but when the Windows BootCamp partition rolls around it begins to have issues.

    I have also noticed, while Macintosh sees a 100 GB drive (20 GB Mac + 80 GB Windows), FOG sees 20 GB Mac + 580 GB Windows. Even if the rest of the drive is empty, it grabs the entire partition and empty space.

    **I should point out that the drive size is 600GB (give or take 20), but the partition is shrunk to 100GB.



  • @Wayne-Workman I may have miss-configured or did something incorrectly then; the very first time I tried RAW with this dual-boot system, it did not work.

    Currently, the ‘Current Setup’ I stated in the last comment does in-fact work - in my scenario.

    I have successfully managed to image two machines, although it takes upwards of eight hours; however, a day to image a machine beats five days of needing to rebuild the system every time something happens to it.

    Side notes though:

    • You need the MacOS disk, or access to the Macintosh partition to enable the bless so you can image it (as per the FOG Wiki)
    • After you image it, the PXE menu shows back up; return to the main menu, refresh to populate the Macintosh Partition into the menu. Boot into the Macintosh Partition and put in the Windows CD, then run BootCamp. Do not erase the partition, just run the Windows Installer.
      • Doing this ‘unlocks’ the Windows partition, so you don’t actually have to go into the Windows Installation Disc - just let it boot past that and into Windows.
      • Configure Windows like you normally would. FOG does not change the hostname on this side of the partition, so make sure you change that when and if you are putting the computer on the domain.

    Beyond that, it works. Ain’t perfect, but it is about 210% better than what I was doing before - even with the additional side stuff you have to do before and after the image hits.

    So, I will call it closed.


  • Moderator

    @ttrammell I would always expect RAW to work.



  • UPDATE: I may have it working; will test on other machines (So far, it managed to install the image and have both partitions).

    Current Setup is:
    OS: Apple Mac OS - (8)
    Image Type: Raw Image (Sector by Sector, DD, Slow)
    Partition: Everything
    Image Manager: Partclone Zstd

    I have a few more machines to test this on before I can say, “Yes, this worked.” Will update in a few days.



  • @Tom-Elliott This is what I just got when I tried it again under Other/Single Disk All Paritions (Non-Resizable)/Gzip 200MB
    0_1490186267298_upload-52b16b5b-790c-41d3-9473-4572aa407955

    Same error as before (Sorry, just now posting it):
    Error trying to restore GPT partition tables (restorePartitionTablesAndBootLoaders)
    Args Passed: /dev/sda 1 /images/MacU 99 all
    CMD Tried: sgdisk -gel /images/MacU/d1.mbr /dev/sda
    Exit returned code: 2

    I’ll do a bit more testing.


  • Senior Developer

    @ttrammell it doesn’t have the d1.minimum.partitions.



  • 0_1490118639649_upload-9df3b556-b853-4755-9a3d-69ab77944744

    This was uploaded with the Zstd image type (as a test), but it cannot restore the GPT partition tables.



  • @Wayne-Workman
    I am trying the other image type right now, and I did try the RAW/DD type before.

    @Tom-Elliott
    No problem about the Mac imaging - this probably wouldn’t even be a problem if we did not have the 22 macs that made up the lab.

    I’ll still do some playing around. The ‘problem’ that I am getting is that it will either (a) take the image, but fail to install on another device or (b) not take the image at all.

    So far, from what I see, the image makes up something like this (What FOG sees):

    /dev/sda1          200MB   Windows Reserve   FAT32
    /dev/sda2           20GB   Macintosh         HFS
    /dev/sda3          620GB   Windows (C:)      RAW
    

    However, what the Macintosh Disk Utility sees:

    /dev/sda1          20GB   Macintosh        HFS
    /dev/sda2         100GB   Windows          MS-DOS
    Free Space        480GB
    

    Looking at it now, even I am confused. It seems to be taking the entire space of /dev/sda3 (which is the Windows BootCamp Partition) and counting it separate from the entire drive, with the Macintosh and separate Windows Reserve Partition being added onto it.

    So, it’s getting /dev/sda1, /dev/sda2, and /dev/sda (as /dev/sda3) - if that makes any sense.

    *Edit: I can send you guys an ls -lhrt /images/MacU when the upload is done, if you want?


  • Moderator

    Some people have had some success with the ‘other’ image type, I recall.

    But remembering threads here on the subject of dual boot, it was usually a lot of issues, and most didn’t make it.


  • Senior Developer

    What’s the problems you’re seeing?

    We do support (at a very basic level) multi-boot though as @Wayne-Workman stated FOG was originally designed around a Single OS system. Multiboot, in the sense described, is most often thought of as Windows and Linux or Linux/Linux. Possibly Mac and windows (where Windows is the “primary”) though I’ve never tested Mac imaging as I don’t have that kind of money (sorry).


  • Moderator

    FOG is designed to capture/deploy single OSs. Otherwise you have the RAW option.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.