Power controls do not work



  • Server
    • FOG Version: 1.3.4
    • OS: Ubuntu 16.04
    • Dell PE R610 (all physical systems)

    Hello all,

    I am having a bit of an issue with the power options in FOG, I’ve verified that my server has Wake on LAN enabled and that it will find DHCP from FOG and boot over PXE without an issue. I did have MaaS installed previously and my servers would boot using IPMI without fail, which was great. However; since MaaS only seems to let you use Ubuntu, Cent or Windows and will only let you download custom Ubuntu images from the web, it won’t be as flexible as I’d like for it to be. FOG seems to be content with pushing out any image I want and that is more important than integrated power controls.

    I am testing this with both physical hosts and VMs on ESXi 5.5 and I have a private PXENET to serve images and control power on the servers and neither are able to wake, shutdown, or restart. Here are some articles that I have looked at to be sure that my systems had the right config:

    http://en.community.dell.com/support-forums/servers/f/956/t/19663975

    https://communities.vmware.com/thread/478640?start=0&tstart=0

    https://forums.fogproject.org/topic/3767/wake-on-lan-does-not-work/9 (installed wakeonlan and ran as mentioned with the correct MAC in the last comment and it did not work either.)

    Any help provided will be greatly appreciated, please let me know if you need any more details.


  • Senior Developer

    Also remember, with the exception of WOL, Shutdown and Restart “on demand” Power Management items are not “immediate”. As @Junkhacker stated, they require the New FOG Client on the systems to be “tasked” and they will be performed on the next time the check in with the FOG Server.


  • Developer

    @dws88 shutdown and restart options are for interaction with the fog client running on client computers and for wake on lan, not IPMI or any other hardware interface level of management.


  • Moderator

    Just be aware that IPMI is not the same a WOL. And not all servers support WOL and / or IPMI. For the R610, you either need to have the BMC programed to respond to IPMI commands or have a drac card installed to respond to IPMI. I have not personally tested to see if WOL actually works with a R6x0 system. I seem to remember something about it only working on eth0 (or the first built in network adapter).

    To remove FOG from the equation, get a third party WOL program and see if you can wake up the R610 externally.

    Solarwinds free WOL
    http://www.solarwinds.com/free-tools/wake-on-lan

    Or free version of Emco Wake on lan
    https://wake-on-lan.net/

    The key here is to first establish that you can’t wol these servers. I’m aware that some devices will respond to different magic packets, so that also comes into play.

    It “might” be interesting to see if FOG could send ipmi messages at some point in the future, hint, hint…



  • @Tom-Elliott I am looking at the options under power management on the web interface, I check the perform immediately tick box and in the action drop-down there is an option there to shutdown the host. This is what I am referring to, none of the three options work for me.


  • Senior Developer

    @dws88 So the fact that you can’t do it on “physical” machines leads me to think something is blocking multicast (udp) traffic altogether.

    I’m not sure I understand what you mean by Shutdown a box though. FOG doesn’t shutdown systems using WOL.



  • @Tom-Elliott Wake on LAN, Restart, and shutdown doesn’t seem to work and the VMs are capable of PXE booting from FOG. The VM passes through a vswitch so it is able to get out to the physical network. I also have a physical box that can’t utilize WOL either even though it is connected on an isolated network that FOG manages and I have ensured that the network card allows WOL.


  • Senior Developer

    I’m not sure I understand what you mean by “Power controls do not work”.

    Do you mean WOL isn’t working? If installing an external program such as wakeonlan doesn’t work, that would lead me to think something is not configured properly.

    For example your NIC on the VM is not bridged, so network packets are restrained to the internal VM network?


Log in to reply
 

519
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.