[Solved] Unable to boot FOG from PXE with a VM (virtualbox guest)



  • Re: Unable to boot Fog from PXE

    Server
    • FOG Version: 1.3.5 rc13 (and rc10 before updating)
    • OS: ubuntu 16.04 x64
    Client
    • Service Version: 0.11.10 (not in use atm)
    • OS: windows 10 pro x64
    Description

    Re: Unable to boot Fog from PXE

    Hello guys,

    First thing: Many thanks to the FOG team to provide such an amazing software!! :o)
    I use it since the 0.32 and I love this cloning solution.

    So, I lately try the latest versions :1.3.4 (but had a problem during the end of the installation with the update of database shema) and 1.3.5 rc10.
    This last one works like a charm with physical computers but I have an issue with a virtualized one (under virtualbox). This is very similar to the linked topic:

    At the beginning, it didn’t boot to PXE nor receive the right network configuration from the DHCP server. Since having changed the network configuration from NAT to Bridged, the VM try boot from network contacting the DHCP server, receive the proper configuration (from this DHCP server): IP address, mask and gateway are OK, iPXE is launched… But it doesn’t load the FOG bootloader and I’m facing the same error message as swaroop:
    “No configuration methods succeeded (…)
    DHCP failed, hit ‘s’ for the iPXE shell; reboot in 10 seconds”.

    and the VM reboot again and again…

    I tried all the network adapters of virtualbox, each time with each of the 3 “promiscuous options” (refuse/ allow VM/ allow all) in the bridged mode :

    • the PCnet-pci II and PCnet-Fast III adapters make the VM reboot only one time and load the installed OS but don’t work with Windows 10 x64;
    • both Intel Pro/1000MT adapters make the VM reboot without ending but work with Win10x64;
    • Intel Pro/1000T make boot-loops and don’t work with Windows10x64.

    According to the linked topic, I checked and changed the network cable. I don’t know what could be the good Timeout value to set so I didn’t test to change it.

    I updated FOG to the the 1.3.5 rc13 seeing an iPXE update but it’s the same situation.

    Please: Could someone help me?
    Thank you in advance.

    P.S: Sorry if my english isn’t good… You know I’m french and… maybe you know … frenchies and other languages… x)



  • Ok guys : it’s solved!!!

    The issue was due to the chipset selection…
    I finally tried on a default VM hosted on an Ubuntu for testing (maybe it was the virtualbox /windows version causing the issue) and it launched the fog pxe environment.
    So I changed to the same settings on my windows host and that was fine…

    I hope it would help if someone has the same situation.

    Thank you all!!

    I installed the last stable version of fog (1.3.5) and find it awesome: the improvements since the 0.32 are really great!!

    I don’t know (and don’t want) to make software developement but I’d like to help about french translation (if you need it) when my windiws 10 migration will be done. Tell/contact me if you want :)



  • I’m sorry george but I forgot to answer to confirm I installed the expension pack for virtualbox.



  • First time it was natted (just when I installed and updated windows) but when I wanted to try imaging, I replace by bridged and let this option until now.


  • Senior Developer

    @sylkyls When you setup your nic, did you ensure it was in “bridged” not “natted” mode?



  • I’m using vitualbox 5.1.16 for windows on a dell optiplex 7040 under Windows 10 pro x64.
    The only particular settings for my vm are (as far as I remember because I’m not at work now):

    • windows 10 x64 computer;
    • ich (8 or 9) chipset;
    • intel pro 1000 MT network card.

    Tell me if you think of another option I could forget…


  • Moderator

    What version of virtual box are you using and did you remember to install the extension pack to support pxe booting?


  • Developer

    @sylkyls i am unable to reproduce this so far. what settings did you create the VM with?


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.