Deploying Single Snapins to Group All



  • Server
    • FOG Version: 1.3.4
    • OS: Ubuntu 14.04
    Description

    I have problems deploying several snapins to all hosts.

    I deleted all active tasks, active snapin tasks and scheduled task. I created a group called “All” and added all hosts as members.

    I select the group “All”, Advanced, Basic Task, Single Snapin and deploy a snapin (.exe) with Schedule Instant (.exe). That works fine.
    I select athe group “All”, Advanced, Basic Task, Single Snapin (.exe) and deploy another snapin with Schedule Instant.

    The error message:

    Failed to create tasking to some or all All Failed to start tasking type Single Snapin There is a host in a tasking

    A way to avoid this message, is to choose “Schedule Delayed”, choose a date in the future and deploy. The problem is, that this task get stuck in the “Scheduled Tasks” forever and never deploys the snapin.

    I also can deploy the same snapin via manage hosts, choose a host, basic tasks, advanced, single snapin. That works. But repeating this for 180 hosts is not so funny.

    This process worked in version 1.2.0



  • @tom-elliott

    DELETE FROM `fog`.`snapinAssoc` WHERE `saHostID` NOT IN (SELECT `hostID` FROM `fog`.`hosts`) OR `sSnapinID` NOT IN (SELECT `saSnapinID` FROM `fog`.`sID`);
    

    Returns #1146 - Table ‘fog.sID’ doesn’t exist


  • Senior Developer

    @MarkusK Entirely.



  • @Tom-Elliott Does this also delete the Active Snapin Jobs in the queue or just the history?


  • Senior Developer

    @MarkusK I can only imagine the “SnapinTasks” table is filled with erroneous data.

    You could test this theory by: (It will remove any snapin history of course.)

    TRUNCATE TABLE `fog`.`snapinTasks`;
    TRUNCATE TABLE `fog`.`snapinJobs`;
    DELETE FROM `fog`.`tasks` WHERE `taskTypeID` IN (12, 13);
    DELETE FROM `fog`.`snapinAssoc` WHERE `saHostID` NOT IN (SELECT `hostID` FROM `fog`.`hosts`) OR `sSnapinID` NOT IN (SELECT `saSnapinID` FROM `fog`.`sID`);
    

    Because of all the “changes” I’m suggesting, I would highly suggest getting a backup of the database before performing these actions. This can be done from FOG Configuration Page->Configuration Save->Export



  • @Tom-Elliott Image name sounds logical and is not so necessary. I only prefer to see the active snapin tasks and I wonder why they execute but I can’t see them under “Active Snapin Tasks”.


  • Senior Developer

    @MarkusK the image name is not important if the tasking is a snapin tasking.



  • @Tom-Elliott I did some more tests. All snapins deploy to the host, but they are not correctly displayed under “Active Tasks” or incomplete under “Active Snapin Tasks” (The Image name is missing, when submitting a single snapin task to a group".


  • Senior Developer

    @MarkusK Why would “image” be visible or not?

    Essentially, the tasks link into a snapin job. Those jobs are what are used to determine what’s available for the host to use.

    Either it’s working, or it’s not working.



  • @Tom-Elliott I upgraded to

    Running Version 1.4.0
    SVN Revision: 6069

    but the problem is still there. The second time I submit a single snapin to the same group, there is no Task visible under “Active Snapin Tasks”. Only the first time I submit a single snapin, the Tasks are created.

    Looking for the missing tasks, I found out, that there are tasks visible under “Active Tasks”, but the Image field is empty.



  • @Tom-Elliott Thanks, I’ll give dev-branch a try next week.


  • Senior Developer

    @MarkusK Sure. Just make sure you’re on dev-branch.



  • @Tom-Elliott It’s maybe two weeks ago since. Should I give it another try?


  • Senior Developer

    @MarkusK have you updated?



  • @MarkusK said in Deploying Single Snapins to Group All:

    still exists

    Anyone?



  • @Tom-Elliott I pulled and updated my installation again. Now I do no longer reproduce the blank page on Active Tasks page.

    The first problem I have still exists. I can submit a Single Snapin to a group. The Snapin Tasks are showed on the Active Tasks page. I can submit another Single Snapin to the same group. There are no error messages, but the second Single Snapin does not show up under Active Tasks page. I only see the Tasks for the first submit.


  • Senior Developer

    @MarkusK The strangeness of what you’re seeing seems to be odd for sure, but not the end of the world right now I suppose.

    Can you provide your apache error logs after going to the Active Tasks page? When pages go white as you’re describing it usually indicates a syntax issue, or there was a memory usage issue. If it is syntax related, chances are it will point us to the issue so I can provide a fast fix for the problem.



  • @Tom-Elliott Thanks. I moved to 1.4.0-RC-3. I now can submit several Single Snapins to a group. There’s just some strange behaviour. The first time i submit a single snapin to a group with 100 clients, I can see 100 Snapin Task under Task Managment…Active Snapin Tasks. The second time I submit a Single Snapin to 100 clients, there are only 2 Snapin Tasks created. When I repeat the last step, aprox. 20 Snain Tasks are created. I somehow also expect 100 Single Snapin Tasks under Task Managment…Active Snapin Task. When I click Task Management…Active Tasks… I only get a white page.


  • Senior Developer

    @MarkusK please repull and try again. I meant to remove a “testing” element that I found a similar problem but had reset for other reasons. Readded and pushed.



  • @Tom-Elliott Thank you very much for effort!

    I moved to the working branch and installed it. After the update I was no longer able to login. I reset the password, but this didn’t help. So unfortunatly I couldn’t test your changes.

    I really would like to see this in action, because deploying different snapins to groups is one of my main workflows.

    Any chance you can help me testing this?


Log in to reply
 

427
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.