Fog failed to update from 1.2.0 to 1.3.4



  • Server
    • FOG Version: 1.2.0
    • OS: Mint 16
    Client
    • Service Version:
    • OS:
    Description

    I tried to update fog from 1.2.0 to 1.3.4 When I run update this is what happens (I am not really linux savvy so please be gentle). Everything was working fine before trying to update (I tried updating because FOG wouldn’t image a lenovo laptop) Any help would be appreciated, right now fog doesn’t work at all

     * Here are the settings FOG will use:
     * Base Linux: Debian
     * Detected Linux Distribution: Ubuntu
     * Server IP Address: 192.168
     * Server Subnet Mask: 
     * Interface: eth0
     * Installation Type: Normal Server
     * Donate: 0
     * Internationalization: 0
     * Image Storage Location: /images
     * Using FOG DHCP: No
     * DHCP will NOT be setup but you must setup your
     | current DHCP server to use FOG for PXE services.
    
     * On a Linux DHCP server you must set: next-server and filename
    
     * On a Windows DHCP server you must set options 066 and 067
    
     * Option 066/next-server is the IP of the FOG Server: (e.g. 192.168.)
     * Option 067/filename is the bootfile: (e.g. undionly.kpxe)
    
    
     * Are you sure you wish to continue (Y/N) Y
    
     * Installation Started
    
     * Installing required packages, if this fails
     | make sure you have an active internet connection.
    
     * Adding needed repository....................................OK
     * Preparing Package Manager...................................OK
     * Packages to be installed:
    
    	apache2 bc build-essential cpp curl g++ gawk gcc gzip htmldoc lftp libapache2-mod-php7.1 libc6 libcurl3 m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php7.1 php7.1-bcmath php7.1-cli php7.1-curl php7.1-fpm php7.1-gd php7.1-json php7.1-ldap php7.1-mbstring php7.1-mcrypt php7.1-mysql php7.1-mysqlnd php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g 
    
    
     * Installing package: apache2.................................Failed! (Will try later)
     * Skipping package: bc........................................(Already Installed)
     * Skipping package: build-essential...........................(Already Installed)
     * Skipping package: cpp.......................................(Already Installed)
     * Installing package: curl....................................Failed! (Will try later)
     * Skipping package: g++.......................................(Already Installed)
     * Skipping package: gawk......................................(Already Installed)
     * Skipping package: gcc.......................................(Already Installed)
     * Skipping package: gzip......................................(Already Installed)
     * Skipping package: htmldoc...................................(Already Installed)
     * Skipping package: lftp......................................(Already Installed)
     * Skipping package: libapache2-mod-php7.1.....................(Does not exist)
     * Skipping package: libc6.....................................(Already Installed)
     * Skipping package: libcurl3..................................(Already Installed)
     * Skipping package: m4........................................(Already Installed)
     * Skipping package: mysql-client..............................(Already Installed)
     * Skipping package: mysql-server..............................(Already Installed)
     * Skipping package: net-tools.................................(Already Installed)
     * Skipping package: nfs-kernel-server.........................(Already Installed)
     * Skipping package: openssh-server............................(Already Installed)
     * Skipping package: php7.1....................................(Does not exist)
     * Skipping package: php7.1-bcmath.............................(Does not exist)
     * Skipping package: php7.1-cli................................(Does not exist)
     * Skipping package: php7.1-curl...............................(Does not exist)
     * Skipping package: php7.1-fpm................................(Does not exist)
     * Skipping package: php7.1-gd.................................(Does not exist)
     * Skipping package: php7.1-json...............................(Does not exist)
     * Skipping package: php7.1-ldap...............................(Does not exist)
     * Skipping package: php7.1-mbstring...........................(Does not exist)
     * Skipping package: php7.1-mcrypt.............................(Does not exist)
     * Skipping package: php7.1-mysql..............................(Does not exist)
     * Skipping package: php7.1-mysqlnd............................(Does not exist)
     * Installing package: php-gettext.............................Failed! (Will try later)
     * Skipping package: sysv-rc-conf..............................(Already Installed)
     * Skipping package: tar.......................................(Already Installed)
     * Skipping package: tftpd-hpa.................................(Already Installed)
     * Skipping package: tftp-hpa..................................(Already Installed)
     * Skipping package: unzip.....................................(Already Installed)
     * Skipping package: vsftpd....................................(Already Installed)
     * Skipping package: wget......................................(Already Installed)
     * Skipping package: xinetd....................................(Already Installed)
     * Skipping package: zlib1g....................................(Already Installed)
     * Updating packages as needed.................................OK
     * Installing now everything is updated........................Failed!
    

    Mod edited to use code box.


  • Developer

    @SOL that should work



  • @Junkhacker Since I got images on external HDD can I just move that and mount on new server and only import databases ?


  • Developer

    @SOL images are compatible. instructions for migrating to a new server is covered in the wiki https://wiki.fogproject.org/wiki/index.php?title=Migrate_FOG



  • I looked through the error log file and it has a lot of errors fetching binaries. I guess because I am on unsupported distro version(I get same errors trying to update anything). Is that why the install failed ? At this point it would it make more sense to install from scratch on newer distro ?

    I guess my question is can I still use the images I already got ? I got plenty on external HDD, is there a way to export the client image DB and import to new installation (with fog being down). ? Are images made with 1.2.0 compatible with 1.3.4 ?


  • Moderator

    Wherever you put the fogproject files (don’t know where you got them or where you putt them), inside of the bin directory that you went into to run the installer, there is another directory in there called error_logs and it has logs that we need. One will be called fog_error_1.3.4.log please upload a copy here or copy/paste & use the code formating tool when pasting in the forums, it looks like this in the editing area: </>


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.