UNSOLVED Permission denied with SMB share for image capture.

  • Server
    • FOG Version: 1.3.4
    • OS: Debian 8
    • Service Version: Last
    • OS: Windows


    I setting up a fog server on a Debian 8 VM and it’s great. But, I would change the image storage location with a SMB share to a folder on my hardware server (srv-backup on Windows 2008 Server). I mounting my folder with fstab

    //srv-backup/ImagesPC /images/ cifs rw,username=...,password=...,domain=...,uid=1001,dir_mode=0777,file_mod=666

    uid=1001 : fog user UID

    My smb share works because I can write inside.

    The mistake :
    When I want capture an Images, I booting on the pxe, and at last, I have the error “Permission Denied”.
    alt text

    I can’t mount a nfs share because my server doesn’t support(disable) this protocol.

    However, on my fog Dashboard, I can seeing the capacity of my SMB share in “Storage Node Disk Usage”.

    How to do for the fog user can read/write (owner) in my SMB share ?

    Thanks you in advance.


  • OK thanks you. Finaly, I’ve up my VM size and problem solved :P.
    My windows server is in prod, I can’t make tests on it.

    Thanks you guys 🙂

  • I would not advise using windows as a storage node though. Not worth the hassle to me.

    You can however mount an iSCSI volume as a local disk on the fog server and export that via NFS, because iSCSI is block-level. smb/cifs/nfs is not block level, therefore cannot be re-exported.

  • Moderator

    The problem is here you can not share out a directory in FOG that is actually mounted to a remote server. Its hard to explain but you are trying to reshare a remotely mounted share. This is a linux/nfs restriction not a fog one.

    If you can enable nfs on your windows box you can setup your windows server as a fog storage node. Understand this is not supported by FOG, but its possible. I wrote a proof of concept to setup a windows server as a FOG storage node.

    I did use windows 2012 because it was easier to script the install, but windows 2008 or 2012 will / should work.